none
SharePoint Services Stuck in Provisioning

    Question

  • I have a multi server SharePoint farm where any job is stuck .

    If start a service instance it stucks in starting or stopping state,if i deploy a wsp it stucks in deploying forever. Similarly 

    I see that something is happening with timer jobs that do these tasks.

    I tried to delete the cache,restart the timer services,force the service to stop. Nothing works.

    How do i restore the services and start them properly.


    Raj-Shpt

    Tuesday, January 19, 2016 10:14 PM

Answers

  • we have some problem , when we check the timer job stuck in pousing or running stage, or search page seems red or yellow mark..

    This is usually due to the configuration cache being outdated. So you need to perform some steps on the SharePoint server to force a rebuild of the configuration cache.

    download The Script /docs : https://gallery.technet.microsoft.com/SharePoint-2010-2013-21f55320

    Note:add task for Clearing the Cache monthly.


    Deepesh Yevle -MCP MCTS MCITP ITIL

    Thursday, January 21, 2016 3:19 AM

All replies

  • Hi Raj-Shpt,

    For troubleshooting the issue, you could check things below:

    1. After you start a service, you could check if there is related information in the USL log. (The path of ULS Log: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\Logs)

    2. Do IIS reset to check if it can work.

    3. Run SharePoint products configuration wizard to check if it can work.

    4. Start or stop the service by PowerShell command to check if it can work.

    Start or stop a service (SharePoint 2013).

    https://technet.microsoft.com/en-us/library/ee704549.aspx

    Best regards,

    Sara Fan


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, January 20, 2016 7:33 AM
    Moderator
  • None of these worked. In addition when i run power shell command  Get-SPServiceInstance  | where {$_.TypeName -like "SQL*"}

    Same command gives different results in different servers. 

    Looks like servers are out of sync.

    How do i repair this ?/


    Raj-Shpt

    Wednesday, January 20, 2016 7:32 PM
  • we have some problem , when we check the timer job stuck in pousing or running stage, or search page seems red or yellow mark..

    This is usually due to the configuration cache being outdated. So you need to perform some steps on the SharePoint server to force a rebuild of the configuration cache.

    download The Script /docs : https://gallery.technet.microsoft.com/SharePoint-2010-2013-21f55320

    Note:add task for Clearing the Cache monthly.


    Deepesh Yevle -MCP MCTS MCITP ITIL

    Thursday, January 21, 2016 3:19 AM