none
Workflow down after Patching RRS feed

  • Question

  • Hi,

    We have a custom site workflow for our project server 2013 instance which is basically a demand management workflow.

    We patched our whole system with the latest patch for both SharePoint and Project Server but now after patching the workflows are not working. We are getting message like "workflow action could not be loaded" while we are trying to open the workflow in SharePoint Designer. Also we are getting the below error message :

    Your WorkflowStartWorkflow job failed.  Its current state is FailedNotBlocking.  It was 0% complete.  It entered the queue at 09/26/2016 06:03:24.

    To get more information about the job failure, please go to Project Web App.  Select Personal Settings from the left menu.  Then select My Queued Jobs.

    The errors returned from the queue are as follows:

     Error ID: 35115

     Error ID: 35100

     Error ID: 26000

    Detailed error below - send it to the administrator for more detailed troubleshooting.

    <?xml version="1.0" encoding="utf-16"?>

    <errinfo>

      <general>

        <class name="Exception Starting Workflow: The INSERT statement conflicted with the FOREIGN KEY constraint &quot;FX_MSP_WORKFLOW_STATUS_STAGES&quot;. The conflict occurred in database &quot;ProjectWebApp&quot;, table &quot;pub.MSP_WORKFLOW_STAGES&quot;, column _STAGE_UID_.. Trace:    at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)&#xD;&#xA;   at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose)&#xD;&#xA;   at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean&amp; dataReady)&#xD;&#xA;   at System.Data.SqlClient.SqlDataReader.TryHasMoreRows(Boolean&amp; moreRows)&#xD;&#xA;   at System.Data.SqlClient.SqlDataReader.TryHasMoreResults(Boolean&amp; moreResults)&#xD;&#xA;   at System.Data.SqlClient.SqlDataReader.TryNextResult(Boolean&amp; more)&#xD;&#xA;   at System.Data.SqlClient.SqlDataReader.NextResult()&#xD;&#xA;   at Microsoft.Office.Project.Server.DataAccessLayer.DAL.SqlBatchRequest.SqlBatchRequestProcessor.InvokeAllCallbacks(SqlDataReader reader)&#xD;&#xA;   at Microsoft.Office.Project.Server.DataAccessLayer.DAL.SqlBatchRequest.SqlBatchRequestProcessor.&lt;Execute&gt;b__94(IProjectServerSqlSession session)&#xD;&#xA;   at Microsoft.Office.Project.Server.Security.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)&#xD;&#xA;   at Microsoft.Office.Project.Server.DataAccessLayer.DAL.RetryableExecuteHandlerWithSession(IProjectServerSqlSession session, Action`1 actionHandler, Boolean allowRetry)&#xD;&#xA;   at Microsoft.Office.Project.Server.DataAccessLayer.DAL.RunInActiveSession(DataStoreEnum store, Action`1 actionHandler)&#xD;&#xA;   at Microsoft.Office.Project.Server.DataAccessLayer.DAL.SqlBatchRequest.SqlBatchRequestProcessor.Execute(DAL dal, DataStoreEnum store)&#xD;&#xA;   at Microsoft.Office.Project.Server.DataAccessLayer.DAL.SqlBatchRequest.ProcessRequests()&#xD;&#xA;   at Microsoft.Office.Project.Server.DataAccessLayer.DAL.SubDal.HandleUpdateDataTable(SqlDataAdapter sqlDa, DataTable updates, DataRowState operations)&#xD;&#xA;   at Microsoft.Office.Project.Server.DataAccessLayer.DAL.SubDal.UpdateDataTable(TableInfo tableInfo, DataTable updates, DataRowState operations, Int32 revisionCounter)&#xD;&#xA;   at Microsoft.Office.Project.Server.DataAccessLayer.WorkflowDal.UpdateWorkflowStatusViaADONET(WorkflowDataSet workflowDS)&#xD;&#xA;   at Microsoft.Office.Project.Server.BusinessLayer.Workflow.StartWorkflow(Guid projectGuid, Guid enterpriseProjectTypeUid, Boolean isNewProject, Guid previousEntepriseProjectTypeUid, Boolean skipStage, Guid stageToSkipTo)">

          <error id="35115" name="WorkflowExceptionStartingWorkflow" uid="ae20c075-d083-e611-9439-0050569532f4" />

        </class>

        <class name="">

          <error id="35100" name="WorkflowCannotStartWorkflow" uid="af20c075-d083-e611-9439-0050569532f4" />

        </class>

        <class name="Queue">

          <error id="26000" name="GeneralQueueJobFailed" uid="b020c075-d083-e611-9439-0050569532f4" JobUID="dc968973-d083-e611-9439-0050569532f4" ComputerName="xxx" GroupType="WorkflowStartWorkflow" MessageType="WorkflowStartWorkflowMessage" MessageId="1" Stage="" CorrelationUID="fc81a79d-dd08-b0f5-65f1-576a7925a455" />

        </class>

      </general>

    </errinfo>

    Please help ! thanks in advance !

    Tuesday, October 4, 2016 10:19 AM

All replies

  • On your Web Front Ends, confirm that the following services are running:

    1) Workflow Manager Backend

    2) Windows Fabric Host Service

    3) Service Bus Gateway

    4) Service Bus Message broker

    if they are not started, try starting them manually,.

    If they are already started, try publishing a dummy brand new workflow using SharePoint Designer. This will reestablish any missing dependencies.

    We had a similar issue in the past, where these services would not start no matter what we did.and the resolution was to reconfigure the workflow manager, with the latest update. 


    Cheers,

    Prasanna Adavi, Project MVP

    Blog:   Podcast:    Twitter:    LinkedIn:   


    Tuesday, October 4, 2016 12:29 PM
    Moderator
  • Hi Prasanna,

    Thanks , we tried all of the above. thing is we are not able to create a new workflow, we are getting the same message "Workflow actions cannot be loaded" , the update of workflow manager we have not tried maybe we will do that and come back to you.

    Tuesday, October 4, 2016 1:00 PM