locked
RDP on W7 - need to always open on a second monitor RRS feed

  • Question

  • Hello,

    I installed W7 x64 on the same hardware that I had my W XP x32 on before.

    I have Nvidia GeForce 9600 GT dual dvi/vga video card. Windows desktop stretched among the two monitors, however Windows taskbar displays only on the left one.

    I should note that on W XP x32 everything worked well. W7 (as well as W XP x64 I tried briefly) both have annoying behavior when using RDP client.

    I have a pre-configured RDP file that is pointed to a particular terminal server and is set to full screen on one monitor (1680x1050).  I want the connection to maximize on start onto the right monitor and it worked well in W XP x32.

    In W7 (as well as in W XP x64), no matter what I try, the connection always maximizes to the left screen, so I have to manually un-maximize it, move it to the right screen, and then maximize it again.

    I have full admin rights on my machine.

    I should note that the same behavior occurs to not full-screen connections.  Even after I minimize and then restore an active RDP window placed on the right monitor, it always restores to the left monitor.

     

    Thanks in advance,

    Gregory

    Wednesday, April 28, 2010 3:51 PM

All replies

  • I have just confirmed that W7 x32 with the same video card does not exhibit this problem.

     

    Thank you,

    Gregory

    Wednesday, April 28, 2010 4:15 PM
  • Does MS ever answer questions posted here?
    Friday, May 7, 2010 2:10 PM
  • After many days i found solution:

    1. Run the client and get it set up the way you prefer, or Open your saved RDP file
    2. On the Display tab, choose a non-fullscreen resolution.
    3. On the General tab, click "delete these credentials", if possible.
    4. Click Connect .
    5. You will immediately get a local login dialog. Leave it blank and click OK .
    6. When you are connected and the remote login dialog appears, drag the window to the desired monitor.
    7. On the remote login dialog, click Cancel . The settings dialog should reappear locally.
    8. On the Display tab, you can now choose fullscreen.

    You can now save your session with the Save button on the General tab, as well as save your login credentials.

     

    Try more times ,worked for me.

    • Edited by luka10002 Thursday, June 10, 2010 1:39 PM solution
    • Proposed as answer by luka10002 Thursday, June 10, 2010 1:39 PM
    Thursday, June 10, 2010 1:19 PM
  • This worked perfectly. Thanks for the post.
    Wednesday, January 22, 2014 11:47 PM