locked
Last Error: The mailbox recipient does not have a mailbox database RRS feed

  • Question

  • Hello,

    I have recently run into an issue where a client's Exchange 2010 server (which was migrated from 2003 a few months back) was frozen up the other day and long story short had to be cold booted. Today the users are informing us that they can not send to public folders - they received a bounceback:

    #554 5.2.0
    STOREDRV.Deliver.Exception:ObjectNotFoundException; Failed to process message
    due to a permanent exception with message The Active Directory user wasn't
    found. ObjectNotFoundException: The Active Directory user wasn't found.

    Now we fixed this by using ADSI edit and following http://blog.bruteforcetech.com/archives/766 this procedure, or so we though. There is no bounceback, but no mail is received for the public folders. I look in the queue viewer and see the following error on those test messages: "Last Error: The mailbox recipient does not have a mailbox database". So it looks like something has gone wrong with a reference to the database.

    I tried disabling mail for a public folder and re-enabling but nothing was fixed.

    Any suggestions?

    Additional notes: 2 DC's running 2008 R2, 2003 functional level for domain and forest, Exchange is running on 2008 R2

    Wednesday, February 27, 2013 9:41 PM

Answers

  • no need. 

    it might be outlook cache issue. try send mail using OWA. if it works, then clear the cache mode in outlook client and then try.


    kesav

    • Proposed as answer by wendy_liu Wednesday, March 6, 2013 4:26 PM
    • Marked as answer by wendy_liu Wednesday, March 6, 2013 4:26 PM
    Wednesday, March 6, 2013 10:31 AM

All replies

  • Hi,

    1. Try adding secondary email address for that public folder and test.

    2. Give some permission (i.e: editor, owner) to user for PF and try.


    Kottees : My Blog : Please mark it as an answer if it really helps you.

    Wednesday, February 27, 2013 9:59 PM
  • Hi imkottees,

    I have tried your suggestions but it still ends up in the queue :(

    Thanks for the reply

    Thursday, February 28, 2013 3:04 PM
  • Check the homeMDB attribute in ADSI edit for the PF. Also you can try creating a new PF and try sending test mails.
    Thursday, February 28, 2013 3:24 PM
  • Where can I find this? Is that Under "Exchange Administrative Group" > Databases > Public Folder Database? I just see one class, msExchMDBCopy listed there and if I go into the properties I don't see homeMDB.
    Thursday, February 28, 2013 6:29 PM
  • Hi ,

    Please ensure you have mail enabled for public folder.

    If yes, please try disable and enable it again to test if the issue presists.

    Also check if homeMDB is missing.

    1 >Start ADSI Edit and navigate to CN=Configuration,DC=,DC=,DC=/Services/Microsoft Exchange//Administrative Groups/Exchange Administrative Group (FYDIBOHF23SPDLT)//Servers/MBXServerWithIssue

    2 >Right-click Microsoft System Attendant, and then click Properties to display the  Attributes list and find the homeMDB attribute.

    3 >If the homeMDB attribute has a value make sure  it points to a valid mailbox database. If the value of the homeMDB attribute is empty (not set) or incorrect you need to fix this.


    Wendy Liu
    TechNet Community Support

    Friday, March 1, 2013 7:49 AM
  • i think, he already disabled and enabled, but he still have problem. verify email address of re-enabled and also have you tried with new public folder?

    how many PFs having problem?



    kesav


    • Edited by RK7L Friday, March 1, 2013 8:00 AM addition
    Friday, March 1, 2013 7:55 AM
  • Hi ,

    Please ensure you have mail enabled for public folder.

    If yes, please try disable and enable it again to test if the issue presists.

    Also check if homeMDB is missing.

    1 >Start ADSI Edit and navigate to CN=Configuration,DC=,DC=,DC=/Services/Microsoft Exchange//Administrative Groups/Exchange Administrative Group (FYDIBOHF23SPDLT)//Servers/MBXServerWithIssue

    2 >Right-click Microsoft System Attendant, and then click Properties to display the  Attributes list and find the homeMDB attribute.

    3 >If the homeMDB attribute has a value make sure  it points to a valid mailbox database. If the value of the homeMDB attribute is empty (not set) or incorrect you need to fix this.


    Wendy Liu
    TechNet Community Support

    I checked the HomeMDB attribute and it does have a value which points to the correct database name. I also tried disabling/enabling the mail features on the public folder.

    As for creating a new PF alltogether I have not tried that yet - Will do

    Friday, March 1, 2013 5:47 PM
  • Ok, looks like creating a new PF worked. So I'm guessing the best thing to do now is re-create them all and export/import the messages.
    Friday, March 1, 2013 5:57 PM
  • no need. 

    it might be outlook cache issue. try send mail using OWA. if it works, then clear the cache mode in outlook client and then try.


    kesav

    • Proposed as answer by wendy_liu Wednesday, March 6, 2013 4:26 PM
    • Marked as answer by wendy_liu Wednesday, March 6, 2013 4:26 PM
    Wednesday, March 6, 2013 10:31 AM