locked
Service Offerings are not being shown on SelfService Portal RRS feed

  • Question

  • Hi,

    I'm struggling with visibility problems on the Self Service Portal.

    I've created Service Requests and Service Offerings, the Catalog Group and the User Role. 

    For testing purpose I only add  1 service offering and 2 request offering as a member on the Catalog Group that I created.

    https://technet.microsoft.com/en-us/library/hh519595(v=sc.12).aspx

    and I used management pack: Service Manager Service Request Configuration Library which I also used in my request offering and service offering.

    Then I create user role I followed this tutorial:

    https://technet.microsoft.com/en-us/library/hh519644(v=sc.12).aspx

    and as for testing I only add 1 user.

    When the user login the Service Catalog is blank. When I login as my account service catalog page is displaying.

    What is the problem? Did I make mistake or missing configuration?

    Thank you.


    Monday, October 2, 2017 6:12 AM

All replies

  • Hi 

    This is usually a permissions issue -when you log on as admin you can see the service offering, but when you log on as a user it they can't. I would start checking permissions first and then look for other causes if permissions are OK.

    I would increase the permissions that you have given then User Role to see what is missing. Try giving All access to one element at a time eg All Queues, then test. All Catalog Groups, then test. Or just set them all on and work backwards (ie take them off and give specific permissions to objects). 

    Regards

    Glen


    Web: www.xapity.com  |   Twitter: @xapityapps  |   Facebook: xapityapps

    Monday, October 2, 2017 8:09 PM
  • I noticed on the catalog item group that I created when I view group member nothing display. What probably the reason?

    Thank you

    Tuesday, October 3, 2017 5:17 AM
  • Hello,

    If you could not see the service offering on the portal, I suggest you make sure that when you add service offering to the catalog group, request offerings that added in the service offering also add to that group. 

    Here is a similar thread for your reference:

    https://social.technet.microsoft.com/Forums/systemcenter/en-US/4c54290c-850e-45b9-b26e-65203e1fd744/scsm-2012-portal-permissions-on-service-offerings?forum=portals

    Regards,

    Yan Li


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 3, 2017 5:58 AM
  • Yes I did both service and request offering I added on the Group but when I view the group member nothing display.
    Tuesday, October 3, 2017 6:06 AM
  • Then can you see the service request in the portal with proper user logged on? 

    Regards,

    Yan


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 3, 2017 8:15 AM
  • Different user which I did not add on the user role that I created for the catalog item group they saw all the service request and request offering. But when the user login whom I add on the user role that I created for the catalog item group the service catalog is blank.  I think because the group member is blank. But I dont know why it become blank even I add service and request offering.
    Tuesday, October 3, 2017 8:24 AM
  • Hello,

    Please follow the article below to check whether proper settings are configure:

    https://blogs.technet.microsoft.com/servicemanager/2011/11/09/faq-why-doesnt-my-request-offering-show-up-in-the-category-view-of-the-service-catalog/


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 9, 2017 5:23 AM
  • But I think on doing the catalog group i have an issue because is not added in the member. when i click view member no data display even i add Service Offering and Request offering.
    Monday, October 9, 2017 5:36 AM