Can't create any Virtual Switch in Hyper-V, Failed while creating virtual Ethernet switch 0x800401F3 RRS feed

  • Question

  • Hi,

    I'm absolutely stuck in Hyper-V since it lost connectivity. I removed all the virtual switches but now I'm unable to create new ones. Whenever I try to create a new one, either external, internal or private, I just get:

    Error applying Virtual Switch Properties changes

    Failed while creating virtual Ethernet switch.

    Switch create failed, name = '(some hexa address'), friendly name = 'Some Switch': Invalid class string (0x800401F3).

    Working with PowerShell ends with the same result:

    PS C:\> New-VMSwitch "Virtual Switch" -NetAdapterName "Wi-Fi" -AllowManagementOS $True
    New-VMSwitch : Failed while creating virtual Ethernet switch. 
    Switch create failed, name = '567871B6-FF85-49D2-B2C0-F497EFC556F2', friendly name = 'Virtual Switch': Invalid class string (0x800401F3). At line:1 char:1 + New-VMSwitch "Virtual Switch" -NetAdapterName "Wi-Fi" -AllowManagemen ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~     + CategoryInfo          : NotSpecified: (:) [New-VMSwitch], VirtualizationException     + FullyQualifiedErrorId : OperationFailed,Microsoft.HyperV.PowerShell.Commands.NewVMSwitch

    Any idea on how to fix this?

    Solution: Admin command promt, "netcfg -d" did the trick. Everything is working now.

    c:\> netcfg -d

    Wednesday, January 13, 2016 2:16 PM


  • Admin command promt, "netcfg -d" did the trick. Everything is working now.

    c:\> netcfg -d

    Thursday, February 18, 2016 10:25 PM

All replies

  • Can you try to use an other network adapter for the virtual switch,

    as this might be a problem of the driver of the "Wi-Fi" card.

    Do you get a different error when you try to add the switch not via PowerShell, but in the Hyper-V manager?

    Wednesday, January 13, 2016 3:01 PM
  • Hi. No. That's why I mentioned "either external, internal or private".
    Wednesday, January 13, 2016 3:04 PM
  • I meant: can you try to use the Ethernet adapter instead of Wifi.
    Wednesday, January 13, 2016 9:10 PM
  • Hi Carlos J S A,

    Please remove all the Hyper-V virtual network adapter from the device manager(show hidden devices).

    The following registry keys includes all the Hyper-V virtual network adapter information. Please back up the registry keys before we made modifications to them.
    ◾Under this key, you can find Parameters\SwitchList which contains all Virtual Switches and Parameters\NicList which contains all virtual adapter information on the parent partition
    ◾Under each virtual switch entry, you can find references to all virtual adapters in guest as well as parent partition

    Considering the virtual network adapter is based on the physical network adapter, please reinstall the physical network adapter from the device manager then re-create the virtual network adapter again to have a test.

    Best regards

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, January 14, 2016 7:16 AM
  • Update Windows and re-install Hyper-V feature, This will solve your issue.

    Mark as answer if this help You!


    Mayank Dhama

    Thursday, January 14, 2016 7:40 AM
  • Already mentioned it doesn't help.
    Thursday, January 14, 2016 10:54 AM
  • You do know that, if you select private network, there is no physical adapter involved... Right?

    Anyway, no: There's no change no matter which adapter I try.

    Thursday, January 14, 2016 7:40 PM
  • From what you've written, you've already done so, but still.

    Try listing NICs

    WMIC NICCONFIG GET Description,SettingID

    Check bindings using nvspbind and attempt to remove the GUID returned in HRESULT:

    nvspbind.exe –u {GUID}

    Recreate protocol bindings as written here:

    Hyper-V Error: Error Applying New Virtual Network Changes - Cannot bind to <nic description="">because it is already bound to another virtual network </nic>

    Well this is the world we live in And these are the hands we're given...

    Friday, January 15, 2016 11:59 AM
  • Hi, thanks for your reply.

    There is no Hyper-V virtual network adapter installed.

    Under HKLM\SYSTEM\CurrentControlSet\Services\vmsmp\parameters there's no key; is empty.

    I've already installed, reinstalled and removed all the network adapters with no success.

    Sunday, January 17, 2016 4:53 PM
  • Hi. Already checked that... There seems to be no bind or leftovers at all. And the error is different. This is really worrying and I don't seem to get nowhere.
    Sunday, January 17, 2016 5:01 PM
  • Sunday, January 17, 2016 5:11 PM
  • So... No fix at all for this?  :(
    Saturday, February 6, 2016 6:37 PM
  •   I had a problem like this after an OS upgrade. Nothing I could think of worked. I eventually rebuilt Windows. 


    Saturday, February 6, 2016 11:07 PM
  • Hi Bill.

    Rebuilt = reinstalled? Completely? That's a nightmare. :@

    Sunday, February 7, 2016 3:17 AM
  •   Settings>Update and Security>Recovery>Reset your PC.


    Sunday, February 7, 2016 10:50 PM
  • Well it appears an invalid class error, so perhaps before the 'nuke it from orbit' approach that sounds unfortunately the way to go, a System file check (SFC) Scan and Repair System Files & DISM to fix things SFC cannot (guide by Team ZigZag) before too see if any underlying issues with Windows are causing this.
    Sunday, February 7, 2016 11:39 PM
  • I got some errors during this scans. I'll look into them and keep you updated.

    Thanks for the suggestion!

    Edit: Didn't work out.

    Friday, February 12, 2016 3:31 AM
  • Admin command promt, "netcfg -d" did the trick. Everything is working now.

    c:\> netcfg -d

    Thursday, February 18, 2016 10:25 PM
  • I had the same issue and I had to do the same (netcfg -d). The first time it did not work as I had not remove the HyperV Windows feature. so the next time around I did both the "netcfg -d" and removed the HyperV feature. 

    After a reboot I added the HyperV Windows feature and this time the Virtual Switch Manager worked fine and Iw as able to create the virtual adapters.

    Thanks a bunch!


    Thursday, October 13, 2016 12:50 AM
  • Thanks! That fixed my network switch problems (Generic Failure) with Hyper-V as well.  I assume could happen when enabling NDIS features on a card/driver that may not support such a feature within a hypervisor?
    Saturday, March 4, 2017 5:22 AM
  • Admin command promt, "netcfg -d" did the trick. Everything is working now.

    c:\> netcfg -d

    I had this problem on a previous system, but I never fixed it as I setup a new Windows installation.

    I came across exactly the same problem again (on a different system). It appeared to manifest after running the Creators Update, and also had an issue with the LAN driver which had to be re-installed.

    I tried the command posted, and all appears to be working again.

    I wish I found this the last time.


    Adding this note later.

    I had other issue with the Firewall and Hyper-V after the Creators Update.

    I was provided this thread: Thread

    I used this information and found I only needed to enable the Firewall rule "Windows Management Instrumentation (DCOM-In)" under "Inbound Rules" for the Private Profile.

    This may only apply for using Hyper-V in Workgroup, as mine is.

    • Edited by Mr Cheese Friday, December 15, 2017 9:49 AM Related information
    Monday, November 20, 2017 5:14 AM
  • Thank you, this save me a lot of troubleshooting time
    Wednesday, June 20, 2018 9:27 AM
  • Hi,

    I had the same issue to. I followed your solution: netcfg -d and remove HyperV. After reboot, add HyerV again. It worked wonderful.



    Friday, October 18, 2019 11:02 PM
  • I had the same problem on a Windows Server 2019. Looking in the HyperV log, there was a message that VMQ etc. wasn't supported on this network card (Intel x722). Updating the driver solved the problem.
    Wednesday, November 27, 2019 10:41 AM
  • Admin command promt, "netcfg -d" did the trick. Everything is working now.

    c:\> netcfg -d

    No possible way everything is working after running that command. That deletes your network adapters. By default nothing can work. Not a good answer.
    Saturday, January 18, 2020 3:43 PM
  • What does it mean if these registry entries don't exist?
    Thursday, February 20, 2020 9:06 PM
  • In a my server Dell I have had same problem but updating driver and firmware ethernet card (I haven't last version driver and firmware..) without uninstall hyper-v and without netcfg -d I have resolved problem. If it can be useful ...  


    • Edited by nicogis Wednesday, March 4, 2020 4:35 PM
    Wednesday, March 4, 2020 4:33 PM