locked
External HDD not showing up , RRS feed

  • Question

  • Hey guys ,

    Im really hoping that somebody can help me out. My laptop has recently up dated itself and now my external hard drive will not show up in auto play or in devices and drives. The computer does know it is there as it is showing as an option to " Safely remove" .

    I have tried all the information I can find on line and on Youtube videos, Which all keep directing me to change the device letter in " computer management". However whislt I am in there it is showing the HDD as Disk 1 in the lower part of the screen but nothing is accessable in the upper part. If anyone can help out I would be very much appreciative.

    Thanks in advance

    Tuesday, October 4, 2016 1:18 PM

Answers

  • Hello,

    You can try on Computer Management to choose Storage/Disk Management, after that identify your external HD and Change or Add an drive letter.

    cheers

    nuno


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, October 4, 2016 5:48 PM
  • Which all keep directing me to change the device letter in " computer management". However whislt I am in there it is showing the HDD as Disk 1 in the lower part of the screen

    How about RIGHT click at the HDD in the lower part of the screen ?

    Do you see " Change driver letters and paths..." option ?

    Tuesday, October 4, 2016 6:05 PM

All replies

  • Have you tried it in a different USB port?

    Have a look at http://www.nirsoft.net/utils/usb_devices_view.html and see if the device appears in that. If it does you can right click and Uninstall the selected device. Then remove it plug it in again see if that helps.

    Tuesday, October 4, 2016 5:39 PM
  • Hello,

    You can try on Computer Management to choose Storage/Disk Management, after that identify your external HD and Change or Add an drive letter.

    cheers

    nuno


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, October 4, 2016 5:48 PM
  • Which all keep directing me to change the device letter in " computer management". However whislt I am in there it is showing the HDD as Disk 1 in the lower part of the screen

    How about RIGHT click at the HDD in the lower part of the screen ?

    Do you see " Change driver letters and paths..." option ?

    Tuesday, October 4, 2016 6:05 PM
  • Have you tried reboot with the external hdd (presumably using usb?) plugged in?

    I have noticed none of my usb works if I plug them in after windows is up and running (from mouse to phone). But, if it's plugged in during the reboot, it'll work.

    I have no solution to that issue yet. Have tried updating usb drivers, etc. The only thing that works for me at this time is making sure the device is already plugged in during windows startup.

    I'm on Windows 10 PRO version 1511.


    Tuesday, October 4, 2016 7:01 PM
  • Hi,

    How about the issue, is there anything to update?

    Best regards


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, October 14, 2016 7:08 AM