AppV 5: Sequence an application with license key RRS feed

  • Question

  • Hello

    I am new to App-V Subject.  Here is my Q - I am try to sequence an app (using Win 8 Entp) that require license key to be entered during the sequencing stage (run the app before creating the package).  When, I run the app it open and I am able to enter the license key - however at the end of app-v package creation, I get a message not successful in the creation.  So my Q is how to enter the license key and get it saved to the app-v package during/end of sequence process???

    Appreciate your help.


    Monday, April 1, 2013 8:55 PM

All replies

  • The real question is how does it get set when not in App-V, When just installed locally. You should do a monitor to see where the license key gets put down. I would guess it's not an issue with your license. It likely get's stored in a config file or registry hive and did get sequenced with the app. If you have doubts you could verify by checking in the Sequenced application to see if the license is in the registry or wherever or check the outputted report to see if it may have been excluded.

    Also, not successful in creation? is that the exact error? Have you succesffuly sequenced on that machine before? It could be an issue with the sequencer.

    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    • Edited by RorymonMVP Monday, April 1, 2013 8:58 PM
    Monday, April 1, 2013 8:57 PM
  • I'll second that - what is the exact error message? What is the application?

    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.

    This forum post is my own opinion and does not necessarily reflect the opinion or view of my employer, Microsoft, its employees, or other MVPs.

    Twitter: @stealthpuppy | Blog: stealthpuppy.com | The Definitive Guide to Delivering Microsoft Office with App-V

    Monday, April 1, 2013 9:59 PM
  • I will re-create and get the full error message.  When, I ran the application during the sequence process, I got error message and then the application opened and was able to enter the license key.  Please wait for few more hours to re-create the error message.

    Now, I am faced with another problem.  I deployed over 8 applications successfully.  I tried all the applications on the client and it worked successfully.  Now after few hours, I tried to test those applciations again, I keep getting this error

    The application failed to launch.  This may be due to a network failure.  Error code 0x84000D2A-00000436

    No clue what is wrong with the publishing server.  I can ping and can access publishing server.  I have given everyone - read, Management Server - full control, app-v administrators groups - full control and app-v users - read - yet i keep getting network failure error.

    Monday, April 1, 2013 11:17 PM
  • Do you have a firewall in your environment? If so have you granted an exception for App-V?

    So the error appeared when you chose to run the application? Not after you tried to finish the capture\sequence?

    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Tuesday, April 2, 2013 2:13 AM
  • Firewall - disabled on publishing server, management server, database server and win8client machine.  The error appeared when, I ran the application during the sequence process and not after the finish capture/sequence

    • Edited by lanram Tuesday, April 2, 2013 3:35 PM
    Tuesday, April 2, 2013 2:09 PM
  • I suggest to stick on that other post for the Network Error issue (to avoid mixing issues and differences between topic name and actual issue)


    Twitter @kirk_tn   |  Blog kirxblog   |  Web kirx.org

    Tuesday, April 2, 2013 3:15 PM
  • Failure to launch will be related to the App-V client talking to the UNC or URL based back-end file storage and not the Publishing or Management server.  In 5.0, the client doesn't even try to contact the pub server on app launch, and never talks to the Management server (unless it is also the access point for the UNC/URL back-end file storage).

    If this worked and now doesn't, it is more likely that you have opened a share to the UNC server using a password originally and now you need it again.  The client requires access to this share (and folders and files within) without additional credentials.

    Tim Mangan MVP for App-V and Citrix CTP Author of AppV books: "The Client Book" and "OSD Reference Book" (http://www.tmurgent.com/Books )

    Wednesday, April 3, 2013 2:22 PM