locked
Adobe Files not opening in browser on citrix server RRS feed

  • Question

  • Hello Everyone,

    I have an issue wherein we have an intranet browser related app which has various links and many of these links point to PDF files on an intranet server.

    So, I sequence this package with adobe reader locally installed on sequencer machine and

    then publish it with same version of adobe reader virtual package published on client machine. 

    Result on our test VM's - Everything works fine, PDF files opens up without any prompt.

    Result on Citrix server - PDF File does not opens up instead we see a blank page with x sign on the top left corner.

    I don't think connection group should be required in this case, but still going to give atry. getting "this may be due to a network failure " as of now with connection group.

    2nd guess is might be something related to internet settings. i am using adobe reader 15 so could not find "protected mode" option anywhere in adobe reader as suggested in few of the blog posts. 

    Also, we packagers do not have easy access to the citrix servers so have to have all the weapons ready before we get to troubleshoot on the server.

    Looking for your advice!

    TIA

    Thursday, March 31, 2016 1:58 PM

All replies

  • Browser Integration will be available with no additional affect if you are using AppV 5.0 SP2. Keep in mind that it should be published Globally.

    Posted AS IS with No Warranties. Mark as Answer if this answers your question, It will help other community members.

    Thursday, March 31, 2016 2:44 PM
  • Thanks Vinod!
    I am using APP-V 5.1 a and packages are published globally. I am not sure if i understand "Browser Integration will be available with no additional affect". Does that mean whatever is the settings in browser will be integrated in the package?

    Thursday, March 31, 2016 2:54 PM
  • No, What I mean is PDF files will be opened successfully in the browser.

    Posted AS IS with No Warranties. Mark as Answer if this answers your question, It will help other community members.

    Thursday, March 31, 2016 3:22 PM
  • I checked on citrix server now. The PDF file points to an URL.

    If i run this URL in IE browser normally without the app-v package, it still does not run.

    We are able to ping this server and can open this file locally but could not open it on the citrix server machine.

    This suggests it's something realted to Group Policy on the machine or IE settings which is different.

    Have to pinpoint that one particular thing. 

    Thursday, March 31, 2016 5:26 PM
  • Sorry guys, i found the cause of the problem.

    The issue was with the adobe reader package on citrix server. It did not have adobe plugin installed/available.

    And hence the problem. While I was testing with the same version English package and it had plugin available.

    It was supposed to be same config in both of the packages. Any-ways, it was an accidental find but it's good that we found before running into major issues in production.

    Thanks for help!

    Thursday, March 31, 2016 8:05 PM