none
Skype for Business - Exchange needs your credentials issue RRS feed

  • Question

  • In our environment, if a user is logged on to SfB automatically, they will receive the "Exchange needs your credentials" error.

    The workaround is to log out of SfB, delete the saved credentials (using the button on the sign in page), and enter the password again. I have disabled the 'save password' tickbox in the SfB client via GPO but SfB retains the password if the user signs out of SfB.

    I've tried many solutions in the past but have been unsuccessful in resolving this issue. Here are two of my previous posts about this issue:

    So I've given up on fixing the problem, I would just like to find a way to delete the cached SfB credentials every time a user logs in - perhaps via a script/GPO? Anyone have any suggestions on how to achieve this?

    Any help would be much appreciated. 

    Thursday, May 11, 2017 11:33 PM

All replies

  • Hi sainim,

    As I am concerned, we should delete Skype for business credentials after user sign out, instead of log in. then “Save credentials” is convenient for us to sign Skype for business again. We suggest you troubleshoot why this remind popup:

    1. After you login Skype for business, please right click SFB icon in task manager and choose “Configuration Information”
    2. Check MAPI status and EWS status

    In addition, try to rebuild outlook profile to check if the issue persist.


    Best Regards,
    Jim Xu
    TechNet Community Support


    Please remember to mark the replies as answers if they helped.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, May 12, 2017 9:07 AM
    Moderator
  • Hi Sainim,

    Did you found any issue because of this error. If not, you can simply ignore this error.


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. Thanks.

    Wednesday, May 17, 2017 11:39 AM
  • Hi Sainim,

    I have checked your previous posts and I am unsure if the information listed below is of any value to you.

    • Close/exit Skype for Business
    • Create a new outlook profile and make it active
    • Rename all .ost files to .ost.old [found here %localappdata%\microsoft\outlook]
    • Control panel > clear credential manager (if there are any entries)
    • Start up Outlook so that a new .ost is created (if cache mode is enabled)
    • Remove the folders under the sip folder found here [C:\Users\poulsona\AppData\Local\Microsoft\Office\16.0\Lync]
    • In addition to what you have already tried you could try a "gpupdate /force" via cmd 
    • Enabling Automatic logon authentication via inetcpl.cpl > Security > Internet/intranet > custom level... > Under user authentication select "automatic logon only in intranet zone".
    • Perhaps you may check this post too which takes a look at the communications certificate which might needs an update [certmgr.msc] [https://social.technet.microsoft.com/Forums/en-US/4a6edcfe-cbb1-4e01-bb7c-93016016997a/skype-not-remembering-password?forum=sfbfr]
    • Skype might still prompt asking for credentials, this appears to be happening a lot and a username/password must be entered. It seems to be specific to the account but normally it's the users full e-mail address and windows logon password - but I have also seen that it could be domain/username + windows login password to login. If it is accepted make sure you tick "remember credentials".

    Cheers,

    Axel







    Friday, May 26, 2017 10:05 AM
  • Are you in the Office 365 cloud? If so are on the vNext platform? If both are try, try using the email address for the domain\username. 

    If that doesn't resolve the issue see if the problem follows the user to a different machine or if someone can log onto that machine and have their credentials accepted. If so the issue is with the user profile on the machine.

    It's a very tricky problem to resolve. I am dealing with it here myself.


    Mark Metz

    • Proposed as answer by EdKwak Tuesday, June 5, 2018 4:21 PM
    Thursday, August 10, 2017 7:03 PM
  • I've seen this happen for several users when their windows credentials are stored with the wrong password.  Follow this video to clear those Office 365 credentials and see if it works: https://youtu.be/kjRx1U8l7sU

    Tuesday, December 5, 2017 5:52 PM
  • using email id as username and also deleting password from Password Vault worked for me

    also  deleted sip folder from  Office\16.0\Lync

    Thanks everyone for your help

    Friday, July 13, 2018 1:22 AM
  • Good job
    Thursday, August 9, 2018 9:42 AM
  • Remove stored credentials worked for me, credits on this video

    Users & Groups
    - Manage Your Credentials
    - Windows Credentials (for W8+)
    - Remove all entries related to MicrosoftOffice

    https://youtu.be/kjRx1U8l7sU?t=1m33s

    Thursday, September 13, 2018 5:04 AM
  • Following the steps in the video above did solve the issue, BUT! ONLY if Outlook was opened and logged into the Exchange account BEFORE opening Skype4B. Once done in correct order (first Outlook, then Skype4B) issue is gone :-)

    Friday, March 8, 2019 9:15 AM
  • I concur on this post, had to clear the credential cache, exit both s4b ann outlookstart outlook then start s4b.
    Monday, September 16, 2019 6:30 PM