none
Exchange ActiveSync errors- Event ID 1040- The average of the most recent heartbeat interval [535] for request [sync] used by clients is less than or equal to [540] RRS feed

  • Question

  • We have had this error for quite some time; ActiveSync seems to be working well however.

    Our setup is Server 2008R2 with Exchange 2010 and TMG 2010. All servers are running the latest SPs and updates.

    As it was suggested elsewhere, I have checked the connection timeout on the ActiveSync listener in TMG and it is already set to 1800 seconds.
    I read somewhere else that this timeout can also be changed in the IIS site properties.

    Does anyone know how to fix this? I get up to 20 of thos warning messages a day.

    The full Event Viewer warning is:

    Log Name:      Application
    Source:        MSExchange ActiveSync
    Date:          14/03/2013 15:14:27
    Event ID:      1040
    Task Category: Requests
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      ***********************
    Description:
    The average of the most recent heartbeat intervals [535] for request [Sync] used by clients is less than or equal to [540].
    Make sure that your firewall configuration is set to work correctly with Exchange ActiveSync and direct push technology. Specifically, make sure that your firewall is configured so that requests to Exchange ActiveSync do not expire before they have the opportunity to be processed.

    For more information about how to configure firewall settings when using Exchange ActiveSync, see Microsoft Knowledge Base article 905013, "Enterprise Firewall Configuration for Exchange ActiveSync Direct Push Technology" (http://go.microsoft.com/fwlink/?linkid=3052&kbid=905013).
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchange ActiveSync" />
        <EventID Qualifiers="32772">1040</EventID>
        <Level>3</Level>
        <Task>1</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2013-03-14T15:14:27.000000000Z" />
        <EventRecordID>345370</EventRecordID>
        <Channel>Application</Channel>
        <Computer>**********************</Computer>
        <Security />
      </System>
      <EventData>
        <Data>535</Data>
        <Data>Sync</Data>
        <Data>540</Data>
      </EventData>
    </Event>


    Marco S

    Monday, April 15, 2013 3:15 PM

All replies

  • I'm seeing something similar.  Did you get a resolution?

    Wednesday, November 6, 2013 4:36 PM
  • No- sorry.

    Marco S

    Wednesday, November 6, 2013 5:11 PM
  • Hello,

    Even I am getting the same Error's. I have exhange 2010 & 2013 coexitence environment. I only see these error on exchange 2013 Mailbox servers.

    The SMTP availability of the Receive connector Default Mailbox Delivery was low (0 percent) in the last 15 minutes.

    Event ID : 1040

    Soource : MSExchangeTransportDelivery


    PK


    • Edited by Kolarp Friday, August 21, 2015 9:02 AM
    Friday, August 21, 2015 9:01 AM