none
UM Auto Attendant - "Leave a voice message for this user" option is ignoring "Call answering" rules RRS feed

  • Question

  • I believe this is probably by design, but I'm looking for a workaround if so, or a fix if not. 

    I have a Unified Messaging Auto Attendant (Exchange 2016) that is set to "Leave a Voice message for this user:" as a timeout in the after hours menu. I had hoped to make use of the "Call answering rules" of this mailbox so that calls could be routed elsewhere under certain circumstances. However, when the timeout action occurs, the call answering rules are not being used. The user's regular message plays and the only option is to leave a message.

    Is there a way to make the UM route to voicemail and use the call answering rules that are set up? Or should it be using the call answering rules and my system is not set up properly?

    I believe a fix would be to transfer to an extension as a timeout, but then you have to wait for the voicemail to answer, which leaves the user wondering why they're hearing 20 seconds of ringing, so don't believe that's a good fit.

    Appreciate any information you can provide.

    Configuration for the after-hours menu option is shown below.


    • Edited by LCCSMajor Monday, October 30, 2017 7:57 PM Screenshot added
    Monday, October 30, 2017 2:02 PM

Answers

  • Unless anyone else has a better solution, here's what I went with:

    1. Set up a dummy user in Skype for Business (AD, Exchange, then SfB) exclusively for voicemail. Give this user a DID or an extension (I had to give the user a DID and then configure a dialing rule for extension). This user will have no phone and no client signed in.
    2. At the Exchange level, forward emails to the intended recipient and do not leave a copy in the inbox.
    3. Enable Unified Messaging for this user.
    4. Log into Outlook Web Access as this user and set up the call routing rules you desire to have in place.
    5. Configure the AA (above) to dial an extension you set up in step 1.

    Since there is no client or phone signed into the account, the voicemail picks up right away and the calling rules are presented. I could think of no other alternative. I don't love this solution as it eats a SfB license and it's an extra one on Exchange and in AD, but it does work.

    • Marked as answer by LCCSMajor Wednesday, November 8, 2017 9:50 PM
    Wednesday, November 8, 2017 9:50 PM

All replies

  • Yes, you're right, this works as designed. Only way will be to forward the call to extension.

    regards Holger Technical Specialist UC

    Tuesday, November 7, 2017 9:50 AM
  • Is there no workaround? To forward to an extension will cause the caller to have to listen to the # of rings the user has set. That's not a good option. Why would it not use the answering rules?

    Tuesday, November 7, 2017 1:05 PM
  • Unless anyone else has a better solution, here's what I went with:

    1. Set up a dummy user in Skype for Business (AD, Exchange, then SfB) exclusively for voicemail. Give this user a DID or an extension (I had to give the user a DID and then configure a dialing rule for extension). This user will have no phone and no client signed in.
    2. At the Exchange level, forward emails to the intended recipient and do not leave a copy in the inbox.
    3. Enable Unified Messaging for this user.
    4. Log into Outlook Web Access as this user and set up the call routing rules you desire to have in place.
    5. Configure the AA (above) to dial an extension you set up in step 1.

    Since there is no client or phone signed into the account, the voicemail picks up right away and the calling rules are presented. I could think of no other alternative. I don't love this solution as it eats a SfB license and it's an extra one on Exchange and in AD, but it does work.

    • Marked as answer by LCCSMajor Wednesday, November 8, 2017 9:50 PM
    Wednesday, November 8, 2017 9:50 PM