locked
Microsoft Word 2007 Text Form Fields: Cannot limit characters RRS feed

  • Question

  • Hi there,

    Thank you very much for taking the time to check this post out.

    I know that someone had already put a similar question up (a few years ago) and it got resolved, but there was no information as to how the fix was applied or what went wrong with the document, so that is why I am posting this problem now :)

    On page 2 of the document (Sample file ) under the headings of:

    • Identified Hazards
    • Control Method
    • Review Responsibility

    the form field will not limit the number of characters although it has been stipulated in the Text From Field Options , the result being, when I put the template under protection for data input, the spacings change or I get to the end of the line and some of the previous typed text disappears.

    Surely there should be some fix out there, or an explanation of why it doesn't work (? corrupted document?).

    I'd be most grateful for any assistance you provide.

    Cheers,

    TheShyButterfly


    Hope you have a terrific day, theShyButterfly

    • Moved by L.Hl Friday, April 10, 2015 5:24 AM
    Thursday, April 9, 2015 2:38 AM

Answers

  • I had tried the form under protection, but it still didn't lock the cells to only containing the nominated number of  characters - I wish it had only been that simple :)

    Would there be any reason why it won't do as it was told?

    Cheers,

    TheShyButterfly


    Hope you have a terrific day, theShyButterfly

                

    In a text form field, you can limit the number of (printable) characters, but you can't prevent people from pressing Enter excessively, even if document protection is enabled. As a workaround, place each text form field in a table cell whose dimensions are fixed.


    Stefan Blom, Microsoft Word MVP

    Sunday, April 12, 2015 2:11 PM
  • Thank you to all for your responses :)

    I also tried changing the font type .... as I found this article, which really made me understand how the different font types have different character widths within the same font and how that impacts on the number of character you want to limit to.

    The link is Word Tips by Allen Wyatt and there he advises that one of the most

    Extract:

    "For instance, if you don't want your field to wrap to the next line, then you need to set a maximum length guaranteed to fit on a single line. Calculating such a length can be difficult, particularly if you are using a proportional font. For this reason, some people like to set the font of their fields to a monospace font, such as Courier; it makes calculating field lengths easier."

    Also from Wikipedia, Monospaced fonts which explains how 'size' actually matters :).

    I just thought I'd share what I have found as this appears to have resolved my problem. (It just took some time to discover it ) ...

    Cheers,

    TheShyButterfly


    Hope you have a terrific day, theShyButterfly

    • Marked as answer by George123345 Tuesday, April 21, 2015 2:58 AM
    Friday, April 17, 2015 10:42 AM

All replies

  • Hi TheShyButterfly,

    Based on your description, your issue is related with the Text Form Fields which is a control in the Word. Your issue is more related with the feature of the Word, and this forum is discussing about Word Developing like Word Object Automation. I will move this thread to the more related forum.

    Reference: http://social.technet.microsoft.com/Forums/en-US/home?forum=word

    Thanks for your understanding.

    Best Regards,

    Edward


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, April 10, 2015 5:18 AM
  • I looked at your sample. You need to turn on the form protection. Click the button to "Start enforcing protection." The limitation on data length is enforced.

    Making Forms with Microsoft Word


    Charles Kenyon Madison, WI


    Friday, April 10, 2015 1:52 PM
  • "the form field will not limit the number of characters although it has been stipulated in the Text From Field Options , the result being, when I put the template under protection for data input, the spacings change or I get to the end of the line and some of the previous typed text disappears."

    Hi Charles,

    Thank you for responding to my query.

    I had tried the form under protection, but it still didn't lock the cells to only containing the nominated number of  characters - I wish it had only been that simple :)

    Would there be any reason why it won't do as it was told?

    Cheers,

    TheShyButterfly


    Hope you have a terrific day, theShyButterfly

    Friday, April 10, 2015 3:01 PM
  • Again, on my computer the sample form you submitted works to limit the number of characters in those fields.

    The sample did not have protection for filling in forms turned on. The editing restriction must be for filling in forms.

    Note, the fields in the form are "legacy form fields."


    Charles Kenyon Madison, WI

    Friday, April 10, 2015 9:47 PM
  • I had tried the form under protection, but it still didn't lock the cells to only containing the nominated number of  characters - I wish it had only been that simple :)

    Would there be any reason why it won't do as it was told?

    Cheers,

    TheShyButterfly


    Hope you have a terrific day, theShyButterfly

                

    In a text form field, you can limit the number of (printable) characters, but you can't prevent people from pressing Enter excessively, even if document protection is enabled. As a workaround, place each text form field in a table cell whose dimensions are fixed.


    Stefan Blom, Microsoft Word MVP

    Sunday, April 12, 2015 2:11 PM
  • Thank you to all for your responses :)

    I also tried changing the font type .... as I found this article, which really made me understand how the different font types have different character widths within the same font and how that impacts on the number of character you want to limit to.

    The link is Word Tips by Allen Wyatt and there he advises that one of the most

    Extract:

    "For instance, if you don't want your field to wrap to the next line, then you need to set a maximum length guaranteed to fit on a single line. Calculating such a length can be difficult, particularly if you are using a proportional font. For this reason, some people like to set the font of their fields to a monospace font, such as Courier; it makes calculating field lengths easier."

    Also from Wikipedia, Monospaced fonts which explains how 'size' actually matters :).

    I just thought I'd share what I have found as this appears to have resolved my problem. (It just took some time to discover it ) ...

    Cheers,

    TheShyButterfly


    Hope you have a terrific day, theShyButterfly

    • Marked as answer by George123345 Tuesday, April 21, 2015 2:58 AM
    Friday, April 17, 2015 10:42 AM