none
The Rpc Server Is Unavailable RRS feed

  • Question

  • Hello it's Moohy

    I am pretty displeased at how my windows 7 32 bit has been performing lately on my end... And no, it's not about speed, it's about many services not starting up, and errors popping out. here is a list of the problems I have (they all appeared at the same time)

    Such as The audio service missing

    Can't open Task manager due to pcwum.dll error

    Brightness can only be slightly modified

    Windows aero has stopped working, and has been reverted to classic

    this all happened when I tried restarting my laptop after the pcwum error appeared

    Any help will gladly be appreciated

    P.s: (I tried checking normal startup in msconfig, and loaded all services, except power, by starting them manually, to no avail)

    Sunday, August 6, 2017 12:22 PM

All replies

  • Hi,

    An RPC server unavailable is usually caused by one of two things:

    DNS resolution - the target can't be resolved

    Firewall ports blocked (either by Windows firewall, security software, or edge/perimeter firewall blocking the traffic)

    Antivirus or anti-malware security software that has some sort of "network traffic protection" feature that will prevent AD properly communicating

    If RPC errors are due to port block on firewall, router/switch misconfiguration or network connectivity issues.

    There can also be issue with NIC or cable, make sure you verify the connectivity first & at the same time disable the windows local firewall service. Use telnet to check port connectivity.

    Troubleshooting “RPC server is unavailable” error, reported in failing AD replication scenario.

    https://blogs.technet.microsoft.com/abizerh/2009/06/11/troubleshooting-rpc-server-is-unavailable-error-reported-in-failing-ad-replication-scenario/

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, August 8, 2017 2:36 AM
    Moderator
  • Thanks for your reply

    Though I wish the problem was solved, but I am not an expert (I am measurably good in computer stuff). I checked the link provided, but I don't own a DC, or know what an AD is.

    My firewall is off, (always is), Avast (my only AV) is off as well, this only happened when I restarted my laptop after I got a pcwum.dll error, preventing me from opening task manager, and I was unable to place this file from the internet to my sys32 folder (was protected) until I did a few tweaks and gave permission to myself to modify the folder (which I initially had, though I don't know what happened).

    I knew something bad would happen, since an error message ("taskmgr.exe entry point not found the procedure entry point api-ms-win-core-perfcounters-l1-1-0.PcwCreateQuery could not be located in the dynamic link library pcwum.dll.") didn't stop showing whenever I used task manager after placing the file so i recorded it just in case using my phone camera. after laptop booted again, the error appeared and i tried enabling all the related services, with no avail.

    If you could provide some commands to use to potentially fix this issue, I will for sure mark it as answer, and you will have my thanks, being the savior of this laptop and myself 

    Best regards,

    Moohy

    Thursday, August 10, 2017 8:29 PM