none
Managing proxy via GPP RRS feed

  • Question

  • Hey guys, just checking in to see how everyone else is managing a web proxy with IE10. I'm having some dramas with setting a proxy and managing exceptions to it.

    So, I'm using the RSAT on a Win8 machine and trying to configure a Preference to define my proxy and some URL's I want to except from it. Setting the proxy works OK, but things change when you need to use the Advanced options. Setting some options under Advanced then clicking OK, disables the ability to define a proxy.

    It's becoming quite an issue for me - I'm hoping some others have been through this one before me.

    Cheers

    Tuesday, June 25, 2013 7:01 AM

Answers

  • I'm not having this problem, but, I don't manage our proxy settings using this method.
    Instead, I use the Windows 7/8 defaults, which are:
    Automatically detect settings (checked)

    This causes IE (we use IE6,8,9,10) to perform WPAD, and it finds our http://wpad.in.contoso.com/proxy.pac

    Our proxy.pac file contains the jScript logic, which parses the submitted URL and returns either:
    DIRECT (which tells the browser not to proxy at all, for internal destinations)
    or
    PROXY proxy.in.contoso.com:8080

    Ihave no need to set this setting, using GPP, on Win7 and Win8 client machines, because auto-detect is the enabled default.

    previously, on WinXP, we would use GPO with traditional IEM in preference mode, to do this:
    Automatically detect settings (checked)
    Use automatic configuration script (checked)
     Address: http://wpad.in.contoso.com/proxy.pac


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)


    Thursday, July 4, 2013 7:55 AM
  • refer this thread: http://social.technet.microsoft.com/Forums/windowsserver/en-US/57b6c1a6-deb3-4b21-b489-94169c80dbe4/windows-8-and-ie10-not-accepting-proxy-settings-via-group-policy

    have you checked that the F5 F6 F7 F8 behaviour is actually enabling the settings you are populating in the GPO?

    it can be misleading, in that the proxy settings and bypass settings are stored in the GPO but with the wrong F5 F6 F7 F8 highlighting/underlining, they won't actually be effective.


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Thursday, July 4, 2013 8:07 AM

All replies

  • similar to this?

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/553f21ec-7d13-4c48-8fe6-1ae9302e658b/gpp-issue-when-using-proxy-override-for-ie10


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Tuesday, June 25, 2013 9:58 AM
  • Thanks Don. Yes, exactly like that.

    My understanding was that since the HTTP proxy was set in the Advanced area, it should stick despite not being shown under Proxy Server in LAN Settings. That doesn't seem to be the case, however, as our pilot users keep coming back to me explaining that they can no longer get online.

    Wednesday, June 26, 2013 12:47 AM
  • Has anyone else seen a similar issue? I'm trying to move away from IE8 while maintaining control over proxy exceptions (some of our webapps are dependant on being excluded from the proxy). Without being able to do this, we can't move to IE10.

    There's every possibility I'm missing something but from my searches so far, it certainly seems that others are hitting this problem as well with no solution available.

    Wednesday, July 3, 2013 11:46 PM
  • I'm not having this problem, but, I don't manage our proxy settings using this method.
    Instead, I use the Windows 7/8 defaults, which are:
    Automatically detect settings (checked)

    This causes IE (we use IE6,8,9,10) to perform WPAD, and it finds our http://wpad.in.contoso.com/proxy.pac

    Our proxy.pac file contains the jScript logic, which parses the submitted URL and returns either:
    DIRECT (which tells the browser not to proxy at all, for internal destinations)
    or
    PROXY proxy.in.contoso.com:8080

    Ihave no need to set this setting, using GPP, on Win7 and Win8 client machines, because auto-detect is the enabled default.

    previously, on WinXP, we would use GPO with traditional IEM in preference mode, to do this:
    Automatically detect settings (checked)
    Use automatic configuration script (checked)
     Address: http://wpad.in.contoso.com/proxy.pac


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)


    Thursday, July 4, 2013 7:55 AM
  • refer this thread: http://social.technet.microsoft.com/Forums/windowsserver/en-US/57b6c1a6-deb3-4b21-b489-94169c80dbe4/windows-8-and-ie10-not-accepting-proxy-settings-via-group-policy

    have you checked that the F5 F6 F7 F8 behaviour is actually enabling the settings you are populating in the GPO?

    it can be misleading, in that the proxy settings and bypass settings are stored in the GPO but with the wrong F5 F6 F7 F8 highlighting/underlining, they won't actually be effective.


    Don
    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer", where applicable.
    This helps the community, keeps the forums tidy, and recognises useful contributions. Thanks!)

    Thursday, July 4, 2013 8:07 AM