locked
Windows 8 Music App Volume lowers down when in background RRS feed

  • Question

  • I am using the in built Music App of Windows 8 to listen to my songs, what I have noticed is that even if your system's volume is 100...the music is louder if the Music App is opened on screen compared to the volume if you are listening to music in the background. The scenario is:

    1. I open Music App and start playing the songs and then press ALT+TAB to switch to another application and the volume is lowered down but the system setting still shows Vol = 100

    2. I press ALT+TAB again to open the Music App, first the music stops and I have to press play again but this music volume is louder this time!

    3. I press ALT+TAB again to switch to my other app and the volume goes down again!  

    Any idea? What is happening?


    Akshaya K Sharma

    Friday, August 3, 2012 6:34 AM

Answers

  • Killing WWAHost.exe didn't work for me.  I also tried killing the music app and restarting but the behavior persisted.

    What fixed it for me was killing the music app AND 'Windows Audio Device Graph Isolation' (audiodg.exe) then restarting the Music app (which restarted the other killed process).

    Friday, August 10, 2012 6:24 PM
  • killing of WWAhost.exe (I had two instances running somehow) seems to have resolved the issue. I'll keep an eye out on what's launching another instance. Seems like a bug to me.
    • Proposed as answer by Mackbaz Wednesday, August 8, 2012 3:11 AM
    • Unproposed as answer by Akshaya Sharma Wednesday, August 8, 2012 9:25 AM
    • Marked as answer by Leo HuangModerator Thursday, August 30, 2012 6:14 AM
    Wednesday, August 8, 2012 3:11 AM
  • Actually just restarting the Music application or the machine also helps!

    Akshaya K Sharma

    Wednesday, August 8, 2012 9:25 AM

All replies

  • I just recently noticed this in ITunes running on W8RP. Sound got turned completely off.
    Friday, August 3, 2012 7:54 AM
  • Try using windows media player.  It's better in almost every way.
    Friday, August 3, 2012 4:25 PM
  • I have the same problem, but it only starts for me, when I connect a new device. For an example if I boot up my second PC, and my first PC detects it on the network, then the volume turns down and the aforementioned situation kicks in. But even if I connect my MP3 player this will happen. Restarting the app dosn't help. Restarting the audio service dosn't help. But if I restart my PC it will work fine, until I connect some devices.

    Sure Windows Media Player is always there, but for an example on the tablets there wont be, so this is a serious issue I think.

    Edit:

    After stopping and restarting the Windows Audio Device Graph Isolation process it works again!


    Richard Forster



    Sunday, August 5, 2012 11:14 AM
  • I'm getting this too. Just seemed to happen right after installing the office 2013 preview. It seems quite intentional since the volume fades and doesn't just cut out. Any ideas on how to completely prevent this. Seems kind of silly. Music has no visual dependency which would make having the application open demand higher volume.
    • Proposed as answer by Mackbaz Wednesday, August 8, 2012 3:10 AM
    • Unproposed as answer by Mackbaz Wednesday, August 8, 2012 3:11 AM
    Wednesday, August 8, 2012 2:52 AM
  • killing of WWAhost.exe (I had two instances running somehow) seems to have resolved the issue. I'll keep an eye out on what's launching another instance. Seems like a bug to me.
    • Proposed as answer by Mackbaz Wednesday, August 8, 2012 3:11 AM
    • Unproposed as answer by Akshaya Sharma Wednesday, August 8, 2012 9:25 AM
    • Marked as answer by Leo HuangModerator Thursday, August 30, 2012 6:14 AM
    Wednesday, August 8, 2012 3:11 AM
  • Actually just restarting the Music application or the machine also helps!

    Akshaya K Sharma

    Wednesday, August 8, 2012 9:25 AM
  • Killing WWAHost.exe didn't work for me.  I also tried killing the music app and restarting but the behavior persisted.

    What fixed it for me was killing the music app AND 'Windows Audio Device Graph Isolation' (audiodg.exe) then restarting the Music app (which restarted the other killed process).

    Friday, August 10, 2012 6:24 PM
  • I have the same issue. Killing audiodg.exe and WWAHost.exe fixes it, thanks for the tip. It's definitely a bug!
    Friday, August 17, 2012 11:43 PM
  • Killing WWAHost.exe didn't work for me.  I also tried killing the music app and restarting but the behavior persisted.

    What fixed it for me was killing the music app AND 'Windows Audio Device Graph Isolation' (audiodg.exe) then restarting the Music app (which restarted the other killed process).


    This worked for me as well, but come on.  With Windows 8 released to the public in just a few days, how many people will blame it on a bad user experience.  Fix this MS!
    Wednesday, October 24, 2012 2:50 AM
  • Killing WWAHost.exe didn't work for me.  I also tried killing the music app and restarting but the behavior persisted.

    What fixed it for me was killing the music app AND 'Windows Audio Device Graph Isolation' (audiodg.exe) then restarting the Music app (which restarted the other killed process).


    This worked for me as well, but come on.  With Windows 8 released to the public in just a few days, how many people will blame it on a bad user experience.  Fix this MS!

    For me it looks like that the latest version of the Music app, available in the Store is now working fine. At least I did not have any issues no matter what I was doing. I realized that even after I leave my PC and the screens shut down after some time the volume goes down, not this issue has been resolved as well. Maybe it's just me having luck with it in the last two days, but it seems to be ready for the public release.

    Richard Forster

    Wednesday, October 24, 2012 6:32 AM
  • Microsoft should fix this as it's such a small problem and will probably not require much change, but users are going to jump on the hate wagon this once they've noticed it. It does get noticeable and irritating when it does happen, not to mention I need to turn up my volume, making anything else loud.

    Anyways on to the actual problem, this started after I installed Office 2013. Killing the mentioned processes or restarting the app doesn't do anything to alleviate the problem.
    Saturday, October 27, 2012 9:14 AM
  • I had the very same problem, but, in my case, Steam was causing the problem.

    I turned Steam off, and *bam* (literally, the volume was 100...) the problem solved.

    I would recommend turning of some "suspicious" applications which might be using audio.

    • Proposed as answer by Fumegavila Sunday, October 28, 2012 2:12 AM
    Sunday, October 28, 2012 1:21 AM
  • I had the very same problem, but, in my case, Steam was causing the problem.

    I turned Steam off, and *bam* (literally, the volume was 100...) the problem solved.

    I would recommend turning of some "suspicious" applications which might be using audio.

    Hello Eon.

    I've (now had) the exact same problem caused by the exact same application (Steam). As soon as I closed Steam, the volume stopped fading when the app is out of focus.

    Thanks for sharing the solution.

    Regards.

    • Proposed as answer by Dig The Noise Saturday, November 3, 2012 6:30 AM
    • Unproposed as answer by Dig The Noise Saturday, November 3, 2012 6:31 AM
    Sunday, October 28, 2012 2:11 AM
  • Yep Steam was the culprit for me too.

    Thanks guys

    Sunday, October 28, 2012 5:33 AM
  • So what do we need to do with that?

    I'm kinda tired of reopening Steam errytime.

    Sunday, October 28, 2012 2:05 PM
  • Yup, Steam for me too.  really odd error.  Microsoft and valve need to have a chat.
    Sunday, October 28, 2012 3:38 PM
  • i just noticed that it lowers when i voice chat via steam.

    And yes, the option ''do nothing'' under sound communications its activated

    Sunday, October 28, 2012 8:25 PM
  • Awesome this was really getting under my skin.  Simply closing steam and restarting it while Tune In was playing music solved the issue completely.  Thanks Eon good catch.
    Monday, October 29, 2012 10:52 PM
  • Yup steam seemed to cause the problem for me too :D Good call.
    • Proposed as answer by Anatolie Darii Tuesday, October 30, 2012 8:01 PM
    • Unproposed as answer by Anatolie Darii Tuesday, October 30, 2012 8:01 PM
    Tuesday, October 30, 2012 2:28 AM
  • Really annoying indeed, however i found a pretty easy solution.

    The reason why the music volume goes down is because Steam by default has activated the option "Automatically transmit my voice whenever I speak". So the solution is to:

    1) Go to Steam > Settings > Voice tab and check the "Use a push-to-talk key to transmit voice".

    2) Restart Steam and Audio app and you're done!

    • Proposed as answer by Anatolie Darii Tuesday, October 30, 2012 8:28 PM
    Tuesday, October 30, 2012 8:04 PM
  • I think windows automatically decreases sound when certain apps run because when I have skype app running the music player sound decreases as well. 
    Wednesday, October 31, 2012 2:19 AM
  • what kind of a respose is that if people are using the app it is because they have reson to if you don't know how to sort the problem then why post

    Live life wile you can

    Wednesday, October 31, 2012 11:27 AM
  • nice thank you that works a treat

    Live life wile you can

    Wednesday, October 31, 2012 11:29 AM
  • The steam restart works for me but as soon as I join a game it decreases the music again.
    Thursday, November 1, 2012 7:42 AM
  • I had this problem with Steam and something else in Windows 7.  Moral of the story is as follows

    1)Windows key + x

    2)control panel

    3)Hardware and sound

    4)Sound

    5)Communications

    6)Do Nothing

    7)Apply or OK

    8)Victory Achieved

    • Proposed as answer by smerffx Saturday, November 3, 2012 5:27 PM
    Saturday, November 3, 2012 5:27 PM
  • I had this problem with Steam and something else in Windows 7.  Moral of the story is as follows

    1)Windows key + x

    2)control panel

    3)Hardware and sound

    4)Sound

    5)Communications

    6)Do Nothing

    7)Apply or OK

    8)Victory Achieved

    Smerffx thanks that solved it for me. I can play music and have Steam open now.
    • Proposed as answer by kiwidj Wednesday, November 28, 2012 7:42 AM
    Sunday, November 11, 2012 3:01 PM
  • I had the very same problem, but, in my case, Steam was causing the problem.

    I turned Steam off, and *bam* (literally, the volume was 100...) the problem solved.

    I would recommend turning of some "suspicious" applications which might be using audio.

    Same for me. WWAHost was open multiple times, this was not the problem. The problem was steam.

    Assumption is the mother of all f*k-ups

    • Proposed as answer by Kymbo Monday, December 17, 2012 9:40 AM
    Monday, November 26, 2012 2:19 PM
  • Thanks Smerffx / JDizzles88 - your process achieved Victory for me also..!
    • Edited by kiwidj Wednesday, November 28, 2012 7:43 AM
    Wednesday, November 28, 2012 7:42 AM
  • That was it! Thank you.
    Saturday, December 1, 2012 6:23 PM
  • Hi!

    I had the same problem with the Music app. included in Windows 8,

    I solved it by doing this:

    1)Windows key + x

    2)control panel

    3)Hardware and sound

    4)Sound

    5)Device (I don't know the actual name, as I have right now the interface in Spanish)

    6) Advanced options

    7) Disable the check "Allow applications to take exclusive control over this device" (again, It's a free translation).

    8) Restart the application and... it works ;)

    Hope it helps :D


    Wednesday, December 19, 2012 5:33 PM
  • If you go into control panel>Sound then select your device (speakers, headphones, you need to do this for each device), go to properties, then advanced tab.  Uncheck the exclusive mode option(s), problem fixed!  Windows 8 gives programs the ability to complete control of your sounds, there fore auto mixing them for you, ie lowering your music while your playing a game, etc.  Take off the the option and it stops, it's a setting. :).
    • Proposed as answer by tlpe548b Sunday, December 23, 2012 12:33 PM
    Sunday, December 23, 2012 12:32 PM
  • actually the audiodg.exe is the solution for me.  I just killed it while playing the music, the player stopped.  Then i hit the play button again and everything is fine. 
    Wednesday, December 26, 2012 2:44 PM
  • I have this problem but WWAhost.exe is not running on my machine...
    Monday, December 31, 2012 9:42 AM
  • Wow haha thanks i turned off steam and my radio app started working properly, but how am i gonna play steam games and listen to music?

    Tuesday, January 1, 2013 8:45 PM
  • So when will this "conflict" with steam be fixed? getting very annoying now.
    Monday, January 7, 2013 9:12 PM
  • If you go into control panel>Sound then select your device (speakers, headphones, you need to do this for each device), go to properties, then advanced tab.  Uncheck the exclusive mode option(s), problem fixed!  Windows 8 gives programs the ability to complete control of your sounds, there fore auto mixing them for you, ie lowering your music while your playing a game, etc.  Take off the the option and it stops, it's a setting. :).

    All my system sounds were freakishly quiet - and I was having to turn up my amp to obscene levels (above 50%). I also had the problem with the music app that brought me here.

    I tried shutting down steam, and I got a volume boost. I removed "exclusive control" from my 7.1 card, and instantly, my sound exploded to life like the dawn of a supernova. Then I went to each of my 20ish sound devices, and removed the "exclusive control" mode from all of them, and I'm once again winning at life. Thanks!

    Thursday, January 10, 2013 10:13 PM
  • tlpe548b 's solution worked. Check a few posts up.

    You need to uncheck Allow applications to take exclusive control of this device

    in the Exclusive Mode area of the Advanced properties

    in the Properties popup of all your playback devices and recording devices

    from the right click menu of the sound icon in your task bar.

    (Also available from the Sound option in Control Panel)


    Thursday, January 10, 2013 10:21 PM
  • If you go into control panel>Sound then select your device (speakers, headphones, you need to do this for each device), go to properties, then advanced tab.  Uncheck the exclusive mode option(s), problem fixed!  Windows 8 gives programs the ability to complete control of your sounds, there fore auto mixing them for you, ie lowering your music while your playing a game, etc.  Take off the the option and it stops, it's a setting. :).

    for some reason this doesn't work for me :( .. i'm not a rookie .. I know my way around computers .. and I've tried all this stuff .. only thing left is close steam ..

    EDIT:  SCUMBAG STEAM!! .. CLOSED IT AND IT WORKED .. RE-OPENED IT . AND (THANKS TO THE EXCLUSIVE THINGY) IT DIDNT TOOK CONTROL OF MY AUDIO AGAIN :) .. MANY THANKS TO ALL OF YOU!!

    • Edited by jesusantana Saturday, January 19, 2013 6:48 PM update
    Saturday, January 19, 2013 6:45 PM
  • Thanks man, that was it.

    Friday, February 1, 2013 9:55 PM