locked
Exchange 2003 to 2010 migration - ActiveSync stops working for Exchange 2003 users RRS feed

  • Question

  • Hello,

    I am performing a migration from Exchange 2003 (single server) to Exchange 2010 (two member MB, CAS & Hub roles co-located).

    The current Exchange 2003 server does not have SSL installed and is using HTTP (not HTTPS) for OWA, ActiveSync and all other services.

    On the Exchange 2010 side, we have configured the CAS array as required with SSL certificates. Everything is working fine. The SSL certificate has the legacy FQDN (legacy.domain.com) included in it.

    The issue happens when we configure forms based authentication and install SSL certificate on the Exchange 2003 server.

    1. We install the SSL certificate on the IIS default web site. Then under the /Exchange virtual directory, I change the security settings to require SSL.

    2. Then I turn on the forms based authentication. All the directories are configured for BASIC and Windows Integrated authentication.

    However, when we make the above two changes, the ActiveSync stops working. My understanding was that if we do not enable "require SSL" on the /OMA site, then we will be fine.
    None of the mobile devices have the SSL certificate installed. However we are using public certificate.

    Can someone please advise what will be the correct steps to ensure that when we do the cutover to Exchange 2010 for all client facing services (IIS, SMTP) and start mailbox migration, the users whose mailboxes are still on Exchange 2003 can still access email using ActiveSync on their mobile devices. We have 300 devices.

    SinghP80

    Friday, July 12, 2013 2:02 PM

All replies

  • Okay, the legacy URL doesn't apply to Exchange 2003 ActiveSync users because Exchange 2010 proxies ActiveSync traffic for Exchange 2003 mailboxes, so you can remove that from the equation.

    Does this apply to you?

    http://support.microsoft.com/default.aspx?kbid=937031


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Saturday, July 13, 2013 1:18 AM