Applying recent Windows updates appears to prevent HTML help files from displaying correctly when accessed remotely (UNC & network drive) RRS feed

  • Question

  • Hi,

    This appears to be an issue since applying the recent Windows updates as per below:

    Windows Server 2016: KB4103720 / KB5103723

    Windows Server 2012 R2 KB 4103725 

    The contents display as expected when opening them as a local resource, but when opening from a remote local e.g. UNC path or network drive, the content is not displayed and is replaced with:

    This page can’t be displayed
    Make sure the web address //ieframe.dll/dnserrordiagoff.htm# is correct 
    Look for the page with your search engine
    Refresh the page in a few minutes

    The CHM files aren't blocked, and were working until the updates were applied.

    All previous known fixes to resolve similar issues with display of HTML help files (MaxAllowedZone and UrlAllowList) have been applied to no avail.

    After uninstalling update KB4103720 (on a test Windows 2016 server) and a reboot, with no other changes made, HTML help works again as a network resource afterwards.

    I haven't been able to confirm with reference the other 2 KB updates as these are production servers for the company I work for.

    • Edited by Dr.Beaker Friday, May 18, 2018 9:39 PM Formatting
    Friday, May 18, 2018 3:20 PM

All replies

  • Hi,
    Based on the complexity and the specific situation, we need do more researches. If we have any updates or any thoughts about this issue, we will keep you posted as soon as possible. Your kind understanding is appreciated. If you have further information during this period, you could post it on the forum, which help us understand and analyze this issue comprehensively.
    Sorry for the inconvenience and thank you for your understanding and patience.
    Best Regards,


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Monday, May 21, 2018 2:57 AM
  • Same problem - getting annoying now. Looking for an intermediate solution. Tech. section wants to distribute the help file on all PCs, except we change it nearly every day and have over 2000 users :-(

    Any ideas to an intermediate solution (not sure they will let us remove the update)

    Thursday, May 31, 2018 10:56 AM
  • We are experiencing the same issue on our Windows 10 end-user. Do you have any resolution yet ?
    Wednesday, June 13, 2018 2:50 PM
  • Hello,

    We do not have installed KB4103720 and KB5103723 but we have the same problem.

    Could it be another update? We have an Citrix Farm with Windows server 2016 environment.

    greetz cliff vaessens

    Tuesday, June 19, 2018 10:30 AM
  • Remember updates are now cumulative,so if you have June updates installed, it would show it's kb number not the one from May. However the updates from May would be included in the June update.

    Tuesday, June 19, 2018 6:07 PM
  • Hi,

    same problem here on 2012 R2 RDP Session hosts. As our user have no access to local drive, there is currently no work around.
    Any outlook to get that fixed again?


    Monday, July 16, 2018 8:21 PM
  • it's the same for us on windows 7 computers.

    the user told me the chm files are working just fine with windows 10. But I tested with my own windows 10 laptop from a different site with different GPO and settings and in my case, I have no errors but the right frame is totally blank, no errors. just a security warning at the start of the chm file.

    If the file is copied locally on the hard disk on my both test computers (win 7 and win 10) it works just fine.

    Based on the user feedback it was working until around June and since august, we have the same behavior.

    The file is also often updated and it's not a good solution to copy the file locally for each user.

    Thursday, August 23, 2018 1:18 PM
  • Hope this helps

    Microsoft recently released a security patch that makes it impossible to view CHM files that are stored on a network drive (as opposed to CHM files stored on your own computer). The help file will appear, but instead of the topic text you will see an error message "this page cannot be displayed".

    The security patch and its effects are fully described on Microsoft's web site at

    If you trust all the computers on your LAN or intranet (and the people using them), you can lower the restrictions on the Local Intranet zone to allow CHM files to be displayed with the following steps:

    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate and then click the following subkey:
    If this registry subkey does not exist, create it.
    3. Right-click the ItssRestrictions subkey, point to New, and then click DWORD Value.
    4. Type MaxAllowedZone, and then press Enter.
    5. Right-click the MaxAllowedZone value, and then click Modify.
    6. In the Value data box, type 1, and then click OK.
    7. Quit Registry Editor.

    If this solution does not work for you, please see for alternatives.

    W.Maxx MCITP MCSE MCSA MCP 2k8 2k3 2k nt4 AD, Exchange, DNS, IBM iSeries RIM blackberry

    Friday, August 24, 2018 1:56 PM
  • nope, nothing from these old KBs helps for the current problems, we have these settings in place to get it work in the last years, but the problem now is a new one, starting with May update this year
    We have an case with MS open and waiting for an answer since some weeks.


    • Edited by EG IBM Friday, August 24, 2018 2:23 PM
    Friday, August 24, 2018 2:22 PM
  • This does not solve the issue of the more recent updates. Maybe it is useful for those who are encountering the problems from when those KB were written.

    This Tech Guy

    Friday, August 24, 2018 7:13 PM
  • Please let us know when they send an answer.

    This Tech Guy

    Friday, August 24, 2018 7:15 PM
  • Ah, I understand. I am curious for solution and the 'why' this would happen too.

    W.Maxx MCITP MCSE MCSA MCP 2k8 2k3 2k nt4 AD, Exchange, DNS, IBM iSeries RIM blackberry

    Sunday, August 26, 2018 11:22 AM
  • Any update on this? Did someone manage to fix this issue yet?
    Thursday, October 4, 2018 9:09 AM
  • problem was solved with for W10
    and with 2018-09 Preview of Monthly Quality Rollup for Windows Server 2008 R2 for x64-based Systems (KB4457139)"
    also the W7 preview fixed it.


    Thursday, October 4, 2018 9:30 AM
  • Great!

    W.Maxx MCITP MCSE MCSA MCP 2k8 2k3 2k nt4 AD, Exchange, DNS, IBM iSeries RIM blackberry

    • Proposed as answer by MaxxSound Monday, October 15, 2018 7:24 PM
    Thursday, October 4, 2018 11:21 AM
  • The issue persists for my Windows 7 even after installing KB4457139 through Windows Updates. Any ideas what else one can try? The Server is a 2012 R2. Do you know if they have a fix for such a setup? Client Win7 and Server 2012 R2?


    This Tech Guy

    Thursday, October 4, 2018 3:27 PM
  • KB4457139 solved it on my Win7
    but of course you still need these keys from the old KBs

    Windows Registry Editor Version 5.00


    Thursday, October 4, 2018 3:45 PM
  • Thank you, but I just tried those as well still with no success. 

    This Tech Guy

    Thursday, October 4, 2018 8:02 PM
  • This also not works in my case
    Wednesday, November 28, 2018 7:56 PM