none
Scale and Layout setting to 100% for all users RRS feed

  • Question

  • I need to set the scale and layout font, text to 100% for all users on windows 10 because it affects one of our main program we use for our company. I tried it with GPO and deployed a registry update to the HKCU and HKCM  LogPixels =96 but did not work. The workstation took the registry but still shows 125% as the font and text size. ANy help would be appreciated. Thanks.
    Friday, June 23, 2017 2:13 PM

All replies

  • Hi my3cents,

    Always the custom scale factor will be applied until you sign out.

    Also in the right pane of the Desktop key, double click/tap on the Win8DpiScaling DWORD to modify it. Please check the link below about OPTION FOUR.

    https://www.tenforums.com/tutorials/5990-change-dpi-scaling-level-displays-windows-10-a.html

    Please Note: Since the website is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Meanwhile, you could create a new GPO for the users needing this font size and linked it to their OU. Please check the sharing in the link below about using Group Policy to Set Windows Font DPI size. It suits for Windows 7.

    https://social.technet.microsoft.com/Forums/windows/en-US/c20c4c47-092d-4daa-b4a8-154b3852e13d/using-group-policy-to-set-windows-font-dpi-size?forum=w7itproui

    Hope it will be helpful to you


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, June 26, 2017 3:16 AM
    Moderator
  • Thanks for replying. I have gpo for both logpixels =96 and win8dpiscaling=0. The workstation updated the policy, i see both dwords correctly in the registry but under scale and layout, it's still say 125%. I'm working with windows 10.
    Tuesday, June 27, 2017 4:43 PM
  • Hi my3cents,

    Thank you for your update.

    Could you change the scale and layout font for this program before? What's the system version?


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, June 29, 2017 9:06 AM
    Moderator
  • Did you find a fix? I have the same problem. We are using a 4K monitor and a primary program looks like garbage until you set the DPI scaling back to 100% instead of 150%.  Need a way to have new users login and use the app at 100% without having to make changes.
    Thursday, February 8, 2018 7:51 PM
  • Any solution for setting the default DPI scaling for all users?
    Thursday, June 14, 2018 12:48 PM
  • Anyone else come to a solution? Our school district is also having a conflict between a new testing program we use and the resolution scaling for our new laptops.

    if anyone reading through knows of a solution - people are still looking for one

    Tuesday, August 28, 2018 5:00 PM
  • Guys

    After search in web, I don't find any solution.

    And i make my solution:

    $perfis = (Get-ChildItem Registry::HKEY_USERS\ | Where-Object {$_.Name -match "S-1"} | ForEach-Object {Get-ItemProperty "Registry::$_\Control Panel\Desktop" -Name "Win8DpiScaling" -ErrorAction SilentlyContinue}).PSPath
    foreach ($_ in $monitores) {Set-ItemProperty -Path "Registry::$_" -Name "Win8DpiScaling" -Value 0}
    
    $monitores = (Get-ChildItem Registry::HKEY_USERS\ | Where-Object {$_.Name -match "S-1"} | ForEach-Object {Get-ChildItem "Registry::$_\Control Panel\Desktop\PerMonitorSettings" -ErrorAction SilentlyContinue}).PSPath
    foreach ($_ in $monitores) {Set-ItemProperty -Path "Registry::$_" -Name "DpiValue" -Value 0}

    =D

    Monday, October 1, 2018 11:38 AM
  • Guys

    After search in web, I don't find any solution.

    And i make my solution:

    $perfis = (Get-ChildItem Registry::HKEY_USERS\ | Where-Object {$_.Name -match "S-1"} | ForEach-Object {Get-ItemProperty "Registry::$_\Control Panel\Desktop" -Name "Win8DpiScaling" -ErrorAction SilentlyContinue}).PSPath
    foreach ($_ in $monitores) {Set-ItemProperty -Path "Registry::$_" -Name "Win8DpiScaling" -Value 0}
    
    $monitores = (Get-ChildItem Registry::HKEY_USERS\ | Where-Object {$_.Name -match "S-1"} | ForEach-Object {Get-ChildItem "Registry::$_\Control Panel\Desktop\PerMonitorSettings" -ErrorAction SilentlyContinue}).PSPath
    foreach ($_ in $monitores) {Set-ItemProperty -Path "Registry::$_" -Name "DpiValue" -Value 0}

    =D

    Thank you for this.  Maybe I was blind, but this is the first info I've found anywhere that suggests you can turn off display scaling by creating the below DWORD value and setting it to 0.

    HKCU\Control Panel\Desktop\Win8DpiScaling

    In my case, I needed the setting to be applied to all new users who login, so I loaded the following hive file in regedit under HKLM as "ntuser"

    C:\Users\Default\NTUSER.DAT

    Browsed to HKLM\ntuser\Control Panel\Desktop

    Created DWORD Win8DpiScaling=0

    Unloaded the hive, rebooted, logged in as a new user, and DPI scaling was finally off.

    Thanks again for your post!


    Wednesday, July 24, 2019 3:17 PM