Libraries in new experience mode do not show sync button


  • I'm working with a client setting up a new SharePoint Online site structure. I've created a few sites specifically for document storage based on the Document Center template. Document Libraries created in these sites are shown in "new experience" mode by default. For some reason, the "Sync" action is not shown on these libraries. In a normal "shared documents" library part of a new team site; the option does appear. 

    So at first I though it might be some compatibility issue. But when I switch the library to classic mode, there is a sync button and it works perfectly fine and similar to the sync button in "new experience" libraries. So I can put the library in classic mode, press the button to enable sync and put it back in new experience mode again and everything just works fine. So why the heck is the button not there in new experience mode then!?

    Tuesday, February 28, 2017 8:51 AM

All replies

  • Hi,

    The sync button should show in both modern and classic UI in library.

    Are these libraries created by “library” template?

    Are there any custom solutions in this site? For example, custom master page, custom code in page or others.

    Please try to create a new site collection without any changes, then create a new library, to test whether the issue occurs.

    If the issue still occurs in the new site, please provide a screenshot about the new experience view of problematical library.


    Dean Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Wednesday, March 1, 2017 7:58 AM
  • Odd right, I thought so too.

    What the libraries have in common is that they were created on a Document Center subsite of a team site collection. On the team site itself, it is working ok. 

    To answer your questions: 

    • The libraries were created with the default Library template, nothing fancy. 
    • There are no custom solution in play
    • When I create a new team site, add a document center subsite and then create a library on it; the same thing happens. It does not happen for the default shared documents library created as part of a new team site; in that case it works just fine.

    Here's a couple of screenshots:

    Classic view: sync button visible and enabled

    New experience view: same lib, no sync button at all

    Default shared documents lib on team site: sync button visible 

    Wednesday, March 1, 2017 9:00 AM
  • I have come across this exact issue with no resolution of a fix at this stage. If you get anywhere please let me know!
    Friday, March 10, 2017 1:17 PM
  • At this point of time what I feel this behavior happens in between team site and project/publishing sites with classic and new experience view. We may have to try switching between views and testing on different site templates. .

    MS might be working on it I guess.

    thanks and regards,

    Mahesh Neelannavar

    Saturday, March 11, 2017 5:11 AM
  • I have an open support ticket which has been escalated to the server team. Any resolution will probably be rolled out across tenants, I'll let you know if there's any mentionable progress. 
    Monday, March 13, 2017 7:54 AM