SSRS 2008 - Unable to connect to remote server


  • Win2k3 R2 SP2/SQL Server 2008 instance with SSRS/Visual Studio 2008

    I installed SQL 2008 and SSRS with native mode default configuration.
    All SQL 2008 services are running under "NT Authority\Network Service" account.

    When i try to deploy a new report, I get the "Unable to connect to remote server" error.

    The deploy operation creates empty folders on the web server (hosted by the SQL Server 2008 service)

    for e.g.
    my instance name is <machinename>$sql2008. i configured the WebService URL and the Reports Manager URL to port 85

    the deploy from VS creates ssrs2008Test folder and a Shared Data Sources folder in the following virtual directory
      - Report Manager URL: http://<machinename>:85/Reports_SQL2008/
      - Web Service URL:

    however these folders are empty w/ no .rdl or .rds file. and i get the
    "Unable to connect to remote server"  error in Visual Studio 2008 when i deploy it.

    is there something else i have to tweak in either the SQL Server/SSRS Configuration Manager or the Windows Server Settings(like port settings or group policy) to get the reports to work?


    Thursday, August 28, 2008 8:28 PM


All replies

  • Are you able to access these URLs from IE.

    Thursday, August 28, 2008 10:14 PM

    Thursday, August 28, 2008 10:16 PM
  • Check this out :


    Might help..



    Girija Shankar


    • Proposed as answer by syhussaini Wednesday, September 28, 2011 7:32 AM
    Thursday, August 28, 2008 10:31 PM
  • nope i still havent gotten it to deploy. here's my config settings snippet for SQL 2008 Reporting Services.The Virtual Directory looks okay to me. i'm able to access (from IE) the sub folder for my test project that gets created. (via the SSRS Report Manager app)


         <AccountName>NT AUTHORITY\NETWORK SERVICE</AccountName>
         <AccountName>NT AUTHORITY\NETWORK SERVICE</AccountName>

    Thursday, August 28, 2008 11:06 PM
  • I am getting the exact same error too. My site was set to port 82 and my folder and data source get created but not the report. I can navigate to the Report Manager but can not even manually upload an rdl either, i just get a page cannot be displayed.


    Thursday, August 28, 2008 11:25 PM
  • Do you see any errors in the report server log file when this problem occurs.

    Also what is the value of the "SecureConnectionLevel" property in the rsreportserver.config file.


    Friday, August 29, 2008 7:50 AM
  • SecureConnectionLevel = 2


    From logFile:


    appdomainmanager!DefaultDomain!740!08/29/2008-08:00:30:: i INFO: Appdomain:6 ReportServer_SQL2008_0-3-128644956308203194 started.
    appdomainmanager!ReportServer_0-3!740!08/29/2008-08:00:31:: i INFO: RS authentication mode is 5; effective ASP.NET authentication mode is Windows. vdir=/ReportServer_SQL2008.
    httpruntime!ReportServer_0-3!740!08/29/2008-08:00:31:: i INFO: Report Builder manifest file C:\Program Files\Microsoft SQL Server\MSRS10.SQL2008\Reporting Services\ReportServer\ReportBuilder\ReportBuilder_2_0_0_0\MSReportBuilder.exe.manifest not found.
    appdomainmanager!DefaultDomain!740!08/29/2008-08:00:31:: i INFO: Appdomain:6 ReportServer_SQL2008_0-3-128644956308203194 initialized (#2).
    webserver!ReportServer_0-3!740!08/29/2008-08:00:37:: i INFO: Reporting Web Server started
    resourceutilities!ReportServer_0-3!740!08/29/2008-08:00:37:: i INFO: Reporting Services starting SKU: Developer
    resourceutilities!ReportServer_0-3!740!08/29/2008-08:00:37:: i INFO: Evaluation copy: 0 days left
    resourceutilities!ReportServer_0-3!740!08/29/2008-08:00:37:: i INFO: Running on 1 physical processors, 4 logical processors
    runningjobs!ReportServer_0-3!740!08/29/2008-08:00:37:: i INFO: Running Requests Scavenger timer enabled: Next Event: 60 seconds.  Cycle: 60 seconds
    runningjobs!ReportServer_0-3!740!08/29/2008-08:00:37:: i INFO: Running Requests DB timer enabled: Next Event: 60 seconds.  Cycle: 60 seconds
    runningjobs!ReportServer_0-3!740!08/29/2008-08:00:37:: i INFO: Memory stats update timer enabled: Next Event: 60 seconds.  Cycle: 60 seconds
    library!ReportServer_0-3!1588!08/29/2008-08:00:38:: Call to GetItemTypeAction(/ssrs2008Test).
    library!ReportServer_0-3!1588!08/29/2008-08:00:39:: i INFO: Catalog SQL Server Edition = Developer
    crypto!ReportServer_0-3!1588!08/29/2008-08:00:39:: i INFO: Initializing crypto as user: NT AUTHORITY\NETWORK SERVICE
    crypto!ReportServer_0-3!1588!08/29/2008-08:00:39:: i INFO: Exporting public key
    crypto!ReportServer_0-3!1588!08/29/2008-08:00:39:: i INFO: Performing sku validation
    crypto!ReportServer_0-3!1588!08/29/2008-08:00:39:: i INFO: Importing existing encryption key
    library!ReportServer_0-3!740!08/29/2008-08:00:39:: Call to GetItemTypeAction(/Data Sources).
    library!ReportServer_0-3!1588!08/29/2008-08:00:39:: Call to GetItemTypeAction(/Data Sources/masterDB).
    library!ReportServer_0-3!740!08/29/2008-08:00:40:: Call to GetItemTypeAction(/ssrs2008Test/sp_who2).




    Friday, August 29, 2008 3:05 PM

    Try changing the SecureConnectionLevel to 0 and see if it works.
    Friday, August 29, 2008 5:08 PM
  • Bingo! that fixed it. thank you very much.


    Friday, August 29, 2008 6:35 PM
  • Good to know that it worked. Please mark the thread as answered.

    Friday, August 29, 2008 8:08 PM
  • That you for this sweet, sweet config setting.  It has made four days of trying everything complete my week with a working environment between SSRS and Sharepoint.  Thank you for posting this. 
    Friday, December 4, 2009 10:22 PM
  • Hallelluya!!!  I was about to shoot my brains out on this very problem!  Spent 8hrs all day "wracking" my brain on this and un-installing/ re-installing SSRS and RSAddonX64.   Geez wish it was better documented.  Anyway- my Report Server/2008 w/integrated Sharepoint sites are up and running and screaming thanks to this.
    Thank you !    Wish there was a tip jar so I could give Neeraja a free lunch ticket ! : )

    Here's the default path where that file is located (assuming you accept the SQL2008 default install defaults):

    C:\Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\ReportServer\rsreportserver.config
    Monday, January 4, 2010 6:38 AM
  • Thanks you very much... it's working for me....
    Wednesday, February 24, 2010 5:34 AM
  • Thanks a lot it is very useful!!



    Wednesday, March 24, 2010 6:34 AM
  • Changed the SecureConnectionLevel to 0 after trying everything else and that worked for me.   I had mine connected as network service before swithcing to local system and that might be the root cause.

    Thanks Neeraja

    Eric Ashihundu


    Sunday, April 24, 2011 12:28 AM
  • It works for me too.  thanks Neeraja 

    Wednesday, June 8, 2011 9:48 AM
  • THanks for your inputs
    Analyst (Technology Specialist)
    Wednesday, September 28, 2011 7:32 AM
  • Thank you Neeraja!!!!
    • Edited by TarugoKing Thursday, October 11, 2012 9:16 PM
    Thursday, October 11, 2012 9:15 PM
  • It is already 0 :-(


    Tuesday, November 5, 2013 11:02 AM

    Try changing the SecureConnectionLevel to 0 and see if it works.
    It was already set to 0. It does not work for me.
    Monday, March 10, 2014 11:38 PM
  • Hi,

    I know thread was post several years, but can u tell me how you solved it.

    I got the same error when installing reporting service 2012 on windows 10

    i can deploy the reports, data sources. and secureconnectionlevel is set to 0

    can you tell me how to solve it


    Thursday, February 8, 2018 5:59 AM