none
Can dpm 2019 backup Exchange 2013? RRS feed

  • Question

  • is possible backup with DPM 2019 some old solution, ShP 2013 Exchange 2013 ? This product is not in support matrix but after upgrade client, backup  works.... I must install DPM 2019 to protect vmware 6.7...

    Falcon

    Friday, March 29, 2019 10:56 PM

All replies

  • I make an in place Upgrade from the older Version
    and everything works fine for the Moment.<o:p></o:p>

    I can back up my Hyper-V Host with 2012 R2 and all
    Machines on it. I can back up my SharePoint 2013 as Virtual Machine on the
    Hyper-V Cluster 2016. Barmetal is working. It looks good now.<o:p></o:p>

    For the in place Upgrad I repair again the Backup
    Store. Now we will see how long it works.

    Röndi<o:p></o:p>


     

    Roendi

    Friday, April 5, 2019 7:44 AM
  • Unfortunately, now there is some sort of ReFS exeption...

    An unexpected error caused a failure for process 'msdpm'.  Restart the DPM process 'msdpm'.
    
    Problem Details:
    <FatalServiceError><__System><ID>19</ID><Seq>93781</Seq><TimeCreated>4/14/2019 9:30:30 PM</TimeCreated><Source>DpmThreadPool.cs</Source><Line>163</Line><HasError>True</HasError></__System><ExceptionType>KeyNotFoundException</ExceptionType><ExceptionMessage>The given key was not present in the dictionary.</ExceptionMessage><ExceptionDetails>System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.
       at System.ThrowHelper.ThrowKeyNotFoundException()
       at System.Collections.Generic.Dictionary`2.get_Item(TKey key)
       at Microsoft.Internal.EnterpriseStorage.Dls.StorageManager.ReFSQueueDepthManager.SignalQueueDepth(ReFSInstrumentation key)
       at Microsoft.Internal.EnterpriseStorage.Dls.StorageManager.ReFSQueueDepthManager.ManageQueueDepth.Dispose(Boolean A_0)
       at Microsoft.Internal.EnterpriseStorage.Dls.StorageManager.ReFSQueueDepthManager.ManageQueueDepth.Dispose()
       at Microsoft.Internal.EnterpriseStorage.Dls.StorageManager.RefsDuplicateExtentcontext.CallBackDuplicateExtents(Object stateInfo)
       at Microsoft.Internal.EnterpriseStorage.Dls.EngineUICommon.DpmThreadPool.Function(Object state)
       at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
       at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
       at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
       at System.Threading.ThreadPoolWorkQueue.Dispatch()</ExceptionDetails></FatalServiceError>
    
    
    The message resource is present but the message was not found in the message table
    

    Monday, April 15, 2019 6:08 AM
  • Update Rollup 7 has been released for DPM 2016.

    Update Rollup 7 for System Center 2016 Data Protection Manager
    https://support.microsoft.com/en-us/help/4494084/update-rollup-7-for-system-center-2016-data-protection-manager


    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, April 23, 2019 7:36 PM
  • Thanks for the update Leon, will this soon be available for 2019 too?

    Fixing the constant VHD mount errors would be splendid!

    Tuesday, April 23, 2019 9:04 PM
  • I have no information about this, but hopefully it will be fixed soon, I believe the first update rollup for System Center 2019 will be in the early autumn if not sooner.

    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, April 23, 2019 9:31 PM
  • Has anyone managed to install DPM 2016 UR7?

    We just get the error message "RunDpmPatch.exe has stopped working" shortly after starting the update.  Tried multiple downloads on different DPM servers

    Wednesday, April 24, 2019 5:18 AM
  • Yes, I didn't encounter any issues at least.

    1. Open up a Command Prompt (Admin).

    2. Change directory to where you downloaded the DPM 2016 UR7.

    3. Run the biggest file within the Command Prompt.
    (Detectoid for System Center 2016 - Data Protection Manager Server-all-dataprotectionmanager2016-kb4494084_1f4b075ba94cadf136e4535da6f57d10d59d0a44)

    If you run it without the Command Prompt, make sure to run it as administrator.


    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, April 24, 2019 5:37 AM
  • Stupid question but this update won’t apply to v1807 correct?
    Thursday, April 25, 2019 6:05 PM
  • Stupid question but this update won’t apply to v1807 correct?

    No it won't, DPM 2016 is a Long-Term Servicing Channel (LTSC) release, while DPM 1807 is a Semi-Annual Channel (SAC) release.

    More information about these two different releases here:

    Overview of System Center release options
    https://docs.microsoft.com/en-us/system-center/ltsc-and-sac-overview


    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, April 25, 2019 6:21 PM
  • I have absolutely the same slowness issue. We all blame the DPM but have you tried to copy some big file (20-30GB) directly to the MBS drive? I noticed same write speed as the one during the backups. It starts fast and after several seconds it slows down to 5-15MB/sec...

    My DPM (Already UR7) is VM on 4-node HV cluster. I have dedicated storage iSCSI to Hyper-V nodes, and 16TB pass-through disks. I presented same way another NTFS formatted drive and did some tests:

    5 TB LUN NTFS - ~250-300 MB/sec (cluster disk on node) / ~220-250 MB/sec (pass-through to DPM)

    16 TB LUN REFS ~250-300 MB/sec (cluster disk on node) but ~10-50 MB/sec in pass-through mode !

    I think there is something wrong of how DPM server manage REFS...



    Thursday, April 25, 2019 11:46 PM
  • Neven, you're right; but I say who cares. If not for DPM I wouldn't be forced to REFS.

    If they choose this they haven't tried this?

    Why can't it store the VHDXs on NTFS?

    Friday, April 26, 2019 6:35 AM
  • We have the same issue with 2016.

    Reinstalled everything from scratch and it was working perfectly for a couple of months, but now performance has deteriorated to the point where it’s taking 1 week+ to complete jobs that were previously taking two days.

    Did upgrading to 2019 fix this performance deterioration issues once and for all for any of you?

    Its going to mean a fair amount of upheavel to rebuild (again), so want to ensure that its not another false dawn!  

    Thursday, May 9, 2019 10:57 AM
  • Don't bother. DPM2019 suffers from even more issues. Since upgrade the "VHD couldn't be mounted" appeared and there isn't a UR or hotfix as there would haven been with 2016/UR7.

    The ReFS issue hasn't been fixed either.

    Thursday, May 9, 2019 11:01 AM
  • DPM 2019 on win2016 or win2019 suffers from the same Refs issue. The only thing that is resolving the issue is to reset your disk with your dpm data and rebuild it with dpmsync. You’ll loose all your Recovery points
    • Edited by mvds Thursday, May 9, 2019 11:06 AM
    Thursday, May 9, 2019 11:05 AM
  • I agree. I see the same vhd mount errors, in dpm2016 it is fixed with UR7, they didnt fix it for 2019. I wonder if these products get tested AT ALL
    • Edited by mvds Thursday, May 9, 2019 11:08 AM
    Thursday, May 9, 2019 11:08 AM
  • Oh, that doesn't sound too promising then!

    We are also having to rebuild every 3 months or so. How are you guys managing? 

    I see various people saying that adding more memory alleviates the symptoms, but from all standard  metrics our server is only using half of the memory available, so reluctant to spend money upgrading.

    Thursday, May 9, 2019 12:06 PM
  • DO NOT move to server 2019 and DPM 2019. I had a functional 2016/2016 install that I finally got to a space where I didn't have to babysit it constantly. I tragically wiped that out in favor of 2019/2019 with the desire to support my server 2019 workloads and what a mistake that was. 

    In one month I have already had to blow out my DPM storage disk because backups ground to a halt but worse than that is the constant alert storm of failed backups due to "The VHD could not be mounted or unmounted".

    My God Microsoft did you fork the DPM code for 2019 from DPM 2016 RTM? Let me guess, if my backup destination was Azure storage your software would probably work flawlessly? This whole DPM thing is absurd.


    -Jason

    Thursday, May 9, 2019 1:25 PM
  • My Server has 64 GB Ram. For sure this is not the Problem. REFS is the Problem. I recreate the Disk now on the Server 2019 with DPM 2019 and for sure it stop working again after a view Weeks.

    My Chef love MS so I need to do that. 


    Roendi

    Thursday, May 9, 2019 1:30 PM
  • Guys, at the moment the only official way to solve this problem is to install DPM 2016 or CB on WS 2012 R2 with legacy storage (NTFS disks). The issue is OS dependant, is caused by ReFS fragmentation and affects "only" DPM deployments configured with Modern Backup Storage (and so ReFS).

    MS is working to solve the issue on WS 2019 with an update for ReFS. As I know there are no plans to solve the issue on WS 2016 but when ReFS updates will be released it'll be possible to upgrade from DPM and OS in the right order to reach the desired functional level. 

     

    Thursday, May 9, 2019 1:36 PM
  • Hi Alberto,

    That fix has been promised since 2017 (for Windows 2016), I don't have high hopes on it. The easiest fix would be to allow to use NTFS volumes when running DPM2016-2019 on Windows 2016-2019, but they administratively block it, it's not a technical issue because when you do an inplace upgrade of DPM 2012R2 to 2016 you can still keep using the NTFS volumes...

    It's just scandalous that this bug is still around and doesn't get the attention from the Windows team. If you cannot fix it in at least two years, just allow us to go back to what worked in the first place, even that is not possible.

    I hope someone at MS has at least the decency to get to a solution because we are suffering, big time! 

    I guess the message they are sending us is as follows: go cloud or go dead. At this time, I like neither of them.

    Marc


    • Edited by mvds Thursday, May 9, 2019 1:52 PM
    Thursday, May 9, 2019 1:49 PM
  • I see it on the same way. No hope for this fix. 

    Roendi

    Thursday, May 9, 2019 1:52 PM
  • I agree with Marc.  I had an open ticket with Dell 8 months ago and they said this and that change blah blah.  Nothing has been seen. Rather its causing more headaches for us.  There is no hope for DPM at this point and the rate at which MS is fixing all the pending issues they have. 

    Ishan

    Thursday, May 9, 2019 1:54 PM
  • Hi Marc, I managed this problem in a MS Premier Support incident. They said the fix is in the roadmap for WS 2019 but there wasn't an ETA. So, for us, the only fast and definitive way to solve was leave MBS and go back to legacy storage.

    I absolutely agree with you on the "lack of flexibility" when you have a fresh installation of DPM on WS 2016/2019. As you said there are no real technical reasons against the use of legacy storage in Protection Groups, it's absolutely a choice of the DPM team that blocked this functionality. In my opinion they are going to pay this choice. A lot of people that wrote in this thread said they are frustrated of wasting time managing DPM. I'm not sure they are available to support this situation forever and "they could discover that there are alternative solutions to DPM ..."

    Thursday, May 9, 2019 2:49 PM