none
code 43 error RRS feed

  • Question

  • I have a samsung r519, os windows 7.  I have connected a USB Targus mouse to my usb hubs but i get error code 43, windows has stopped the device from working.

     

    I have tried troubleshooting this but it says my device drivers are up to date.  It is showing in device manager as an unknown device.

    I have tried uninstalling and re-installing the device but this has not resolved the issue.

     

    I also tried to remove the upper and lower registry keys, when i tried to delete the upper registry keys it said i could not do this but then they were removed from the list.  Could not locate the lower registry keys.  When i restarted the computer after deleting the upper registry it comes up saying it failed to install the device properly.

     

    I have tried a different mouse but get the same error, it is the same with all my 3 USB ports.

     

    Can anyone help to fix this please.

    Monday, October 17, 2011 9:21 AM

All replies

  • I had the same problem with code 43 only it was a built-in webcam on a dell laptop. 

    For some reason Windows 7 stopped the cam one day and reported it as code 43. 

    The solution is to turn off the power to the computer and remove all the power sources either battery or A/C plug so that the computer powers down completely . If doing this on a laptop remove both A/C and battery power sources. Then unplug the USB device that reported code 43 from the motherboard. Reboot the computer and let it come up to full operation. The Device Manager will show the USB device is gone. With the computer up and running plug the USB device back into the motherboard. Windows 7 will then re-install the drivers for the USB device and it will run properly again. I had to tear half of my laptop apart to accomplish unplugging the webcam but, it became operational again in less than 2 minutes from me plugging it back in.

    Hope this helps! 

    • Proposed as answer by warrior2761 Thursday, November 17, 2011 6:27 AM
    Thursday, November 17, 2011 6:20 AM