none
Desktop Wallpaper Group Policy doesn't work for Win 10 clients

    Question

  • Hii,
    I have win 7 computers now upgrading to win 10.
    I have installed win 10 on some PCs. We have a GPO (Domain controller win server 2008 R2) to set Desktop wallpaper of client PCs (We keep replacing the .bmp file for wallpaper which is used by that GPO, So wallpaper changes on client PCs by GPO.

    Win 7 PC gets the wallpaper as it log-in to the network. I change the wallpaper in GPO, Win 7 get the updated wallpaper on next logon.
    However Win 10 client gets the wallpaper only on first logon(when a user logs in for the first time to a PC) and then it never changes, That means GPO is applied only on first logon on win 10 client.
    If I delete the user profile from the Win 10 PC then login with the same user, It gets the updated wallpaper then same thing never changes.
    Is there any changes in win 10 logon script than win 7, What could be the issue.
    Please help!!
    Thanks!


    • Edited by Canny Con Tuesday, April 26, 2016 6:52 AM
    Tuesday, April 26, 2016 6:52 AM

Answers

  • Thank you! Wendy Jian,

    I figured it out and here is what I did:

    There is different behavior on Windows 7 and Windows 10 on desktop wallpaper. In Windows 7, when we log into the system, the cached wallpaper file will re-generated automatically.

    But in Windows 10, if the wallpaper path didn’t change, the cached wallpaper will not re-generate.

    After I deleted below file and log off/log on I can see the desktop wallpaper automatically changed on Windows 10.

    %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Themes\TranscodedWallpaper

    So I applied this deletion operation to the domain controller as a log off  script, the script which is as below.

    (I created a .bat file and the content is:

    del %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Themes\TranscodedWallpaper)

    • Marked as answer by Canny Con Wednesday, April 27, 2016 9:35 AM
    Wednesday, April 27, 2016 9:35 AM

All replies

  • Hi,
    Before going further,I would suggest you go to check if the correct wallpaper is set in the registry on Windows10 computer under:
    HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System\Wallpaper
    or
    HKCU\Control Panel\Desktop\Wallpaper

    Regards,
    Wendy


    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, April 27, 2016 7:53 AM
    Moderator
  • Thank you! Wendy Jian,

    I figured it out and here is what I did:

    There is different behavior on Windows 7 and Windows 10 on desktop wallpaper. In Windows 7, when we log into the system, the cached wallpaper file will re-generated automatically.

    But in Windows 10, if the wallpaper path didn’t change, the cached wallpaper will not re-generate.

    After I deleted below file and log off/log on I can see the desktop wallpaper automatically changed on Windows 10.

    %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Themes\TranscodedWallpaper

    So I applied this deletion operation to the domain controller as a log off  script, the script which is as below.

    (I created a .bat file and the content is:

    del %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Themes\TranscodedWallpaper)

    • Marked as answer by Canny Con Wednesday, April 27, 2016 9:35 AM
    Wednesday, April 27, 2016 9:35 AM
  • Hi,
    I am glad that the issue has gone and appreciate your share. It will be greatly helpful to others wo has the same question.
    Thank you for your effort again.
    Regards,
    Wendy

    Please remember to mark the replies as answers if they help and un-mark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, April 28, 2016 1:21 AM
    Moderator
  • Hi

    We're having Win 10 Client PCs [Upgraded from Win 8.1 Pro] and domain GPO wallpaper is not reflecting on some PCs. I've tried HKCU>Control Panel>Desktop>Wallpaper but it is not working.

    Could you please explain how to do the below stuff on AD Server 2012 R2...

    So I applied this deletion operation to the domain controller as a log off  script, the script which is as below.

    (I created a .bat file and the content is:

    del %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Themes\TranscodedWallpaper)

    Thanks in advance.

    Saravanan Veeraiyan

    Friday, October 14, 2016 5:29 AM
  • del /F/S/Q %USERPROFILE%\AppData\Roaming\Microsoft\Windows\Themes\

    Wednesday, November 23, 2016 12:47 PM
  • Thanks for this very helpful. We just needed to change the image once. For us we just needed to change the name of the image used for the desktop background. For example if your desktop image path was \\server\image.jpg change this to \\server\image1.jpg this changes the name and updates the registry so no need for scripts
    Friday, November 10, 2017 3:43 PM
  • @MikeT1111   I follow what you suggested but instead of the wallpaper image i set ..BUT client mostly windows 10  display black and when you log off it the image you set will appear.

    What are other workaround here?

    Thank you

    Friday, February 09, 2018 4:29 AM
  • The path is correct and instead of displaying the new image it will display only BLACK.

    Any other workaround here?

    Thank you.

    Friday, February 09, 2018 4:30 AM