locked
Power Icon is not in my system tray and the option is grayed-out when I try to customize it. RRS feed

  • Question

  • When I click "Customize" for my system tray icons in Windows 7, then "Turn system icons on or off", I can turn on or off all the System Icons except "Power".  It is set to "Off" and grayed-out.

    I followed the directions found in this KB article http://support.microsoft.com/kb/945011/en-us which says to remove two keys from the registry and restart explorer.exe.  It didn't work.

    I am running Windows 7 Premium 64-bit on a desktop computer.  The icon is available on my laptop by default (which makes sense), but I want to turn it on for my desktop.  I want to quickly be able to change power schemes when downloading a file, listening to music, or watching a movie - without having to go through the control panel.

    Also, "Win+X" doesn't open the mobility center.  I don't know if this is related, but being able to put my desktop in presenting mode would be a suitable alternative to the problem.

    Thanks to anyone who can help.

    Tuesday, June 8, 2010 7:13 AM

All replies

  • I would also like to do this for the same reason. I am using my desktop so no I don't have a battery but I would like to be able to easily switch to my customized 'high performance' power scheme when downloading a large file, defragmenting or backing up data overnight because I have that power scheme set not to auto-sleep. ...or Microsoft could fix Windows so that it actually knows not to sleep when there is activity aka when it detects data transfers or processor use. Every other OS out today including Linux seems to do this properly.
    Sunday, January 2, 2011 9:37 PM
  • You're on the right track with that KB article, but it's related to a different registry key.  Use these instructions (it says it's for Vista, but 7 uses the same registry key)

    http://helpdeskgeek.com/windows-xp-tips/sound-or-volume-tray-icon-missing-in-windows-vista/

     

     


    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Sunday, January 2, 2011 10:14 PM