locked
Excel Services does not work when empty root site collection RRS feed

  • Question

  • Hi,

     

    The scenario is:

    - I have one site collection at http://sharepoint/sites/site1 .

    - http://sharepoint/ is empty (no site collection).

    Excel Services does not work on this scenario.

    The error on the server is:

     

    An internal error occurred.
       at Microsoft.Office.Excel.Server.MossHost.MossHost.Microsoft.Office.Excel.Server.Host.IEwaHost.IsSecureConnection()
       at Microsoft.Office.Excel.WebUI.EwaCUIDataSource.EnsureDocument()
       at Microsoft.Web.CommandUI.CUIDataSource.RunQuery(UIQuery query)
       at Microsoft.Office.Excel.WebUI.EwaRibbon.QueryRibbonDataSource(CultureInfo uiCulture, String clientID, Boolean denormalizeImareUri)
       at Microsoft.Office.Excel.WebUI.EwaStringsHandler.ProcessRequest(HttpContext context)

     

    On the client, it just gets stuck on loading animation.

     

    Is there any way to fix this, without creating a site collection at the root? Also, can I create an totally empty page at root?

    Thanks.

     


    Thursday, June 30, 2011 11:56 PM

Answers

All replies

  • You can just create a site using the Blank template at the root.
    http://sharepoint.nauplius.net
    Friday, July 1, 2011 12:59 AM
  • Hi,

    I just ran into this issue on a demo image I patched to SP1. Can I ask, did you see this behaviour on the RTM, a specific CU or SP1 + June CU?


    Alex Burton
    www.epmsource.com | Twitter
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Tuesday, July 5, 2011 10:09 AM
  • Hi,

    While I'm not 100% sure, I would say it started with SP1.

     

    Tuesday, July 5, 2011 1:30 PM
  • I can confirm that this is absolutely caused by the SP1 upgrade as SP1 broke all my Excel Web Apps functionality.  After following the advice here to create a blank site in the root, it now works again.  Thanks for posting this, but MS needs to fix this.
    Saturday, July 16, 2011 2:56 AM
  • This same issue exists in MOSS 2007 + Excel Services and SharePoint 2010 + Feb 2011 CU.
    http://sharepoint.nauplius.net
    Saturday, July 16, 2011 4:15 AM
  • This post just saved me hours of frustration! I just upgraded to SP1 and Excel Services stopped working. I added a blank site at the root and problem solved!! Thanks so much!

    Nick

    Wednesday, August 24, 2011 2:46 PM
  • Creating a blank site at the root is the only solution at the moment.  I attempted many different ways, but the Excel Services Application would always throw this warning until the blank site was created at the root.

    Thursday, October 13, 2011 1:10 PM
  • Am I glad I found this thread? You bet I am. Spent hours searching for a reason why I couldn't get the Excel services to work. By the way, the Office integration is affected as well. At least I can use libraries I added to Office via the Connect to Office button now. They failed before. Very glad, very grateful. Thanks

    Henrik

    Friday, December 16, 2011 9:02 PM
  • Brilliant. This thread saved my life. I was searching for almost 2 days until I found this thread. My excel just didnt want to open in the browser until I created a blank site on the root. Now it works! Thanks.
    Thursday, December 29, 2011 2:35 PM
  • Hey - had this issue today. Great help - BUT - we have an app where we want/need to have xyz.org/sitename instead of xyz.org/sites/sitename .. It seems that this workaround forces you to not only create the site but to also have the root path as explicit and not wildcard.

    anyone have any fixes for the fix?

    Tuesday, January 3, 2012 9:41 PM
  • This was an issue that was fixed as part of the October Cumulative update. The patch can be downloaded from here:

     

    Description of the Excel Services in SharePoint Server 2010 hotfix package (xlsrvwfe-x-none.msp): October 25, 2011
    http://support.microsoft.com/kb/2596582

    Monday, January 9, 2012 5:03 PM
  • SP2010 + SP1, same problem. Solved by creating a site root.
    Tuesday, January 10, 2012 2:53 PM
  • This was an issue that was fixed as part of the October Cumulative update. The patch can be downloaded from here:

     

    Description of the Excel Services in SharePoint Server 2010 hotfix package (xlsrvwfe-x-none.msp): October 25, 2011
    http://support.microsoft.com/kb/2596582

    Ok, CU works. Thanks Tom.

    Tuesday, January 10, 2012 3:12 PM
  • I cant tell you how glad I was to find this thread. The only difference between my working sharepoint 2010 test site and my new sharepoint 2010 site was SP1. I spent a day and half going through settings in Central Admin and was just about to rebuild the whole thing when I found this thread. Hotifx downloaded and installed and low and behold, excel services now opens all my files, powerpivot red crosses are gone. Thank you all.
    Thursday, May 10, 2012 12:18 PM
  • Tryed that, not working...
    Wednesday, August 1, 2012 11:41 PM
  • I also found this hotfix, when I run it, informs "There are no products affected this package installed on this system"

    I installed the last cumulative hotfix KB2598373 with the same result. Excel hangs loading.

    Wednesday, August 1, 2012 11:45 PM
  • I installed the SP1 then last june CU... and it fails. 
    Wednesday, August 1, 2012 11:47 PM
  • for me its a new server, this is the second time that I rebuild it from scratch, I'm installing all the products in english, and the applying spanish language packs.
    Wednesday, August 1, 2012 11:49 PM
  • I'll rebuild it again testing on every step... in my case it hangs informing that's loading.
    Wednesday, August 1, 2012 11:52 PM
  • This worked for me. Had the same problem and it wouldnt work until i ran this hotfix. Use the hotfix!

    This was an issue that was fixed as part of the October Cumulative update. The patch can be downloaded from here:

    Description of the Excel Services in SharePoint Server 2010 hotfix package (xlsrvwfe-x-none.msp): October 25, 2011
    http://support.microsoft.com/kb/2596582

    Thursday, August 2, 2012 3:40 PM
  • Wednesday, April 3, 2013 8:40 AM