locked
Accept All Changes and Stop Tracking removes content from document RRS feed

  • Question

  • We have documents that are in heavy use of the track changes feature.

    It was noticed by someone that when they selected "Accept All Changes and Stop Tracking", content from the document would be removed (tables, in particular).  However, if they choose to "Delete All Comments" first, then select "Accept All Changes and Stop Tracking", the tables are not removed.

    What I know:

    • Witnessed on Windows 7 x64 Enterprise and Windows 10 x64 Enterprise
    • Witnessed on Microsoft Office 2010, 2013, and 2016
    • Track Changes shows that the table and table contents were insertions
    • There is a comment on the table title

    What I've tried:

    • I can right click on the change, accept it manually.  Accepting all changes and stop tracking still removes the tables.
    • I can delete the comment manually.  Accepting all changes and stop tracking still removes the tables.
    • If I copy the entire contents of the document over to a blank Word doc, the missing tables are not present in the paste.

    There is one article online that points to these exact symptoms - no root cause.  :(

    Thanks in advance.

    Tuesday, January 23, 2018 1:55 AM

All replies

  • The linked article suspected a type of corruption.

    Is this happening with only one document or with multiple documents based on a single template, or is it multiple documents based on multiple templates?


    Charles Kenyon Madison, WI

    Tuesday, January 23, 2018 1:21 PM
  • This is happening across multiple documents, though not all.  I will find out if they are using a common template to generate these documents.

    I did notice the notes about the corruption on that post.  Is there a recommended action if this is the case?

    Tuesday, January 23, 2018 4:43 PM
  • A common remedy for a corrupted document is to go to the end and add an empty paragraph by pressing the enter key. Then copy everything but that new last paragraph and paste into a new document.

    Charles Kenyon Madison, WI

    Tuesday, January 23, 2018 9:01 PM
  • Looks like that is not taking.  I added a new paragraph, copied everything but the new paragraph, pasted in a new document.  The tables still do not come over in the paste.

    I tried a few variations of this, adding text in the new paragraph - same result.

    I tried adding text into the table that disappears, more text to the title and after the table.  When I copy the problematic piece of the document, it pastes to the new document as expected.  When I copy over the entire contents of the document, the tables go missing again.

    Wednesday, January 24, 2018 3:22 PM
  • It turns out that certain tracked changes will not copy using this method. Sorry.

    Charles Kenyon Madison, WI

    Wednesday, January 24, 2018 4:19 PM
  • Thank you anyway.  This one is not a simple problem.
    Wednesday, January 24, 2018 4:23 PM
  • I don't remember if someone from Microsoft ever followed up on the old thread in the Community, but probably not, because if they had, I would have posted the follow-up in that thread.

    It may be time to raise the issue again with Microsoft. Can you share a document where this (suspected) bug can be reproduced?


    Stefan Blom, Microsoft Word MVP

    Wednesday, January 31, 2018 8:17 PM
  • I unfortunately cannot share the documents in question.
    Wednesday, January 31, 2018 9:49 PM