none
Issues Having Multiple Calendars (a 5x8 and a 6x11 calendar) RRS feed

  • Question

  • I am currently building/maintaining/updating a schedule that has 2 calendars for it: The design phase consists of your standard 8 hour/day, 5 day week calendar while the production calendar consists of a 11 hour/day, 6 days per week (M-Sat, no breaks for simplicity).

    I set up a test schedule to pinpoint the issue that I am having with 2 calendars labeled "5 days per week" and "6 day days per week". I made 3 groupings of two tasks each labeled "5 day" and "6 day" with the corresponding calendars and the same start dates in each grouping.

    Group 1: I set the duration to 1 day but the "6 day" is about a quarter less than the task labeled "5 day"

    Group 2: I set the duration to "5 day" to 1d and the duration of "6 day" to 1.13 d and the bars are the same size.

    Group 3: I set the duration to 4 days starting on a Thursday. "5 day" finishes on Tuesday (as expected) while the "6 day" finishes on Sunday (a non working day) even though it should finish on Monday.

    When I try to adjust my calendars in Project > Change Working Time, the durations change, thus changing the start/finish dates. I have tried using different task types, changing the global hours/day, hours/week, days/month, creating new calendars, essentially everything I can think of but nothing seems to work.  

    Does anyone have any ideas on what is going on?

    Friday, May 19, 2017 1:35 PM

All replies

  • BawbTheBuilder,

    The first thing you need to realize is that Project only allows one definition for a "day". This definition is used to calculate the Duration. So right off the bat, having multiple calendars in a given plan will skew the duration of any task that does not follow the standard definition of an 8 hour day, or whatever you have defined a "day" to be in File > Options > Schedule group. The solution to this problem is to either not display duration in days but in hours, or create a new custom field that calculates a duration based on the task calendar.

    The second thing to realize is that if you are showing the timescale in days, Project will by default round bars to whole days. This setting is found under Format > Format group > Layout. To effectively see what is happening, you should do two things, set your timescale to show hours and set the File > Options > General group > Date Format to a date format that includes the time.

    The screen shots below show my emulation of the example you describe. For clarity I set the Project calendar to "24 hours".

    Hope this helps.

    John

    Friday, May 19, 2017 3:04 PM