none
How to install SSL on PWA(ProjectWebApp) site and access as a Secure Site(https) RRS feed

  • Question

  • Hello,

    I was trying to install Self-Signed certificate on PWA site, but after create and Install Self-Signed SSL certificate on SharePoint - 80 site and trying to access as https://servername/pwa it shows me blank page. It seems like it hits the server site but not able access pwa directory. But I just assuming, I dont know exact reason.

    If any one know how we can access PWA as a secure site, please tell me the steps.

    Thanks in advance.


    anurag9179

    Thursday, September 24, 2015 6:34 AM

Answers

  • Hello Friends,

    Thanks for reply.

    I solved this question by myself but with the help of one site 

    http://sharepoint.stackexchange.com/questions/111163/an-operation-failed-because-the-following-certificate-has-validation-errors/111206#111206?newreg=dfbca510e3fb45d58a8d9dfa5d6eb45a

    Go to your SharePoint site web.config and add the following line within
    system.net tag:

    <settings>
    <servicePointManager
     checkCertificateName=”false”
     checkCertificateRevocationList=”false”
    />
    </settings>

    anurag9179

    • Marked as answer by Anurag J Wednesday, October 14, 2015 1:12 PM
    Wednesday, October 14, 2015 1:12 PM

All replies

  • Hi Anurag,

      You need to consider that Secure site is on Port 443 so when you are creating your PWA make sure the application port is mentioned and you selected Secure Option. 

    Regards,

    Faizan.


    Regards, Syed Faizan ur Rehman, CBPM®,PRINCE2®, MCTS

    Monday, September 28, 2015 6:25 AM
  • Hi,

    Couple of things to check:

    - do you have an AAM entry for the web application hosting your PWA in place for https://servername

    - in IIS website bindings, is there a binding for https://servername for the correct website

    Also, as Faizan mentioned, make sure port 443 is open through the firewall etc.

    Hope this helps

    Paul

    Wednesday, September 30, 2015 3:57 PM
  • Hello Friends,

    Thanks for reply.

    I solved this question by myself but with the help of one site 

    http://sharepoint.stackexchange.com/questions/111163/an-operation-failed-because-the-following-certificate-has-validation-errors/111206#111206?newreg=dfbca510e3fb45d58a8d9dfa5d6eb45a

    Go to your SharePoint site web.config and add the following line within
    system.net tag:

    <settings>
    <servicePointManager
     checkCertificateName=”false”
     checkCertificateRevocationList=”false”
    />
    </settings>

    anurag9179

    • Marked as answer by Anurag J Wednesday, October 14, 2015 1:12 PM
    Wednesday, October 14, 2015 1:12 PM