locked
Ghost typing the letter G RRS feed

  • Question

  • We have a 2016 standard server to which a few employees connect to for Terminal Services. Only one client using Windows 10 has suddenly developed an odd problem. The letter "g" keeps being printing. It doesn't happen on the computer itself, just in TS. I removed all peripherals thinking maybe there was some signal being transmitted from there, but still happens. Any ideas?
    Saturday, March 9, 2019 5:35 PM

Answers

  • I have the same issue. After troubleshooting quite a bit, I discovered that the problem was linked to a headset I'm using. This headset is connected to my laptop with a 4-pole 3.5mm audio cable. When I unplug the headset, the letter G ghost typing stops immediately.

    My laptop is a Lenovo X1 Carbon 6th Gen.


    Mac

    • Marked as answer by cavaughan Tuesday, March 26, 2019 6:12 PM
    Friday, March 22, 2019 1:16 PM

All replies

  • Hi,

    >Only one client using Windows 10 has suddenly developed an odd problem. The letter "g" keeps being printing.
    If problem only happens when specific client system connect to terminal server. Please create a new user account or using other working user credential, then, establish remote session on the problematic Windows 10, confirm that if problem happens again, it would be helpful to identify whether problem happens on specific user credential, or, specific client system.

    Besides, if you establish remote session via MSTSC, please un-select Printer redirection and save the change, then, establish remote session and check the result.

    If possible, have a full disk scanning using anti-virus and protection software on both problematic client system and Windows Server system.

    If problem persists, I want to confirm with you:
    1. Is such problem happens on redirected printer? Or remote printer which is connected to Windows Server 2016?
    2. Which operation will trigger such printing problem? Such as open specific application, print using specific application? And etc.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, March 11, 2019 8:05 AM
  • Thanks for the detailed response. Turns out I disabled sharing of smart cards, as I recall, fixed the problem.

    HOWEVER! Just now the employee called me over and it's doing it again! I installed a free rdp client and it works fine.

    Disabling redirected printers didn't work, btw. And just so you know, it's not a printer issue, it's a typing issue. The letter "g" is being TYPED randomly.

    • Proposed as answer by Kiodos Monday, March 11, 2019 5:52 PM
    • Edited by cavaughan Monday, March 11, 2019 7:00 PM
    Monday, March 11, 2019 5:40 PM
  • Hi,

    Thank you for taking the time to share details. Your share might be helpful for other people who has similar problem. 

    If there is anything else we can do for you, please feel free to post on the forum.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, March 13, 2019 9:11 AM
  • I have removed checks for sharing of anything, but still same thing. The letter "g" just gets typed in randomly.
    Thursday, March 14, 2019 5:35 PM
  • I'm seeing the same issue on my own computer.

    I am running Windows 10 1803, just installed the March patches today.  I discovered at about 1:00pm today that anytime I use the terminal services client (RDP) it types the letter "g" about every 5 seconds, consistently.  I've tried several remote servers and all of them are showing the same result when I connect.

    I also use Citrix for accessing some environments, and it is not showing same behavior.
    I am also not seeing the same behavior on my local system.

    Let me know if you were able to find anything.  I'll continue poking around and will hopefully find a solution soon.

    Thursday, March 14, 2019 6:48 PM
  • I noticed this started happening after a Lenovo system update was installed.  I was looking for a way to roll it back and saw another update was available.  After installing that update and rebooting a couple times, I'm no longer seeing the issue.
    Friday, March 15, 2019 2:43 PM
  • I have the same issue. After troubleshooting quite a bit, I discovered that the problem was linked to a headset I'm using. This headset is connected to my laptop with a 4-pole 3.5mm audio cable. When I unplug the headset, the letter G ghost typing stops immediately.

    My laptop is a Lenovo X1 Carbon 6th Gen.


    Mac

    • Marked as answer by cavaughan Tuesday, March 26, 2019 6:12 PM
    Friday, March 22, 2019 1:16 PM
  • I have the same issue. After troubleshooting quite a bit, I discovered that the problem was linked to a headset I'm using. This headset is connected to my laptop with a 4-pole 3.5mm audio cable. When I unplug the headset, the letter G ghost typing stops immediately.

    My laptop is a Lenovo X1 Carbon 6th Gen.


    Mac

    Hey Mac,

    YOU ARE THE MAN.

    I have the same laptop and I literally tried to fix it for 5-6 hours.

    Also have you found out why it is happening?

    Again, thanks a lot!

    Monday, March 25, 2019 8:12 AM
  • Yep, Mac send to have figured it out. Crazy, but it seems so long as the headphones are not plugged in when initiating the session, then everything's ok. Or since the user has a port replicator, having the headphones plugged into that doesn't cause the g issue.
    Tuesday, March 26, 2019 6:12 PM
  • Hi,

    Thank you for taking the time to share details. Your share might be helpful for other people who has similar problem. 
     
    If there is anything else we can do for you, please feel free to let us know.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, April 3, 2019 7:13 AM
  • Thank you!  This was driving me NUTS!  Three hours wasted today.  I had removed all the peripherals to test except, of course, for my headphones.  Never crossed my mind to try that.  

    Tuesday, April 9, 2019 6:58 PM
  • Thank-you!  Unplugging my headphones on my X1 Yoga also worked right away.

    You can imagine while trying to do SQL I was about to throw my laptop out the door.

    Thursday, April 18, 2019 10:22 PM
  • I had exactly the same problem today (X1 Carbon Gen 6 getting letter G all the time when using RDP) and I found that by unplugging headset from the laptop the issue went away - very strange - many thanks for finding the cause.
    Tuesday, April 23, 2019 2:19 AM
  • Thanks!! unplugging headset fixed the problem.
    Thursday, April 25, 2019 2:18 PM
  • unplugging headset will fix the problem, KUDOS to Mac (who found the fix Posted on March 22, 2019).
    Thursday, April 25, 2019 2:20 PM
  • Found another error this fixes.

    Whenever watching YouTube videos, they will unpause after about 5 secs with the headphones plugged in. Very annoying!

    Sunday, April 28, 2019 3:24 PM
  • I had exactly the same problem today (X1 Carbon Gen 6 getting letter G all the time when using RDP) and I found that by unplugging headset from the laptop the issue went away - very strange - many thanks for finding the cause.

    The same with my Lenovo X1 Carbon 6 Gen!

    As for me it is super critical to have headset (3.5mm 4-pole jack) attached almost all time during day, I had to find another solution which helped in my case:

    1. Uninstall Realtek Sound Device (with driver files removal)
    2. Reboot and let Windows install standard drivers from Windows Update
    3. In case driver installed by Windows has version 6.0.1.8642 - uninstall it again with driver files removal check-box enabled
    4. After step 3 - in my case windows installed Realtek driver version 6.0.1.8551 (dated 08/10/2018) that doesn't have this issue!

    So looks like this issue is Realtek Driver version related.

    Thursday, May 2, 2019 4:40 AM
  • Google search the same problem led me here. I finally figured out which service was causing the issue. It is the realtek audio service. If I stop it, the problem goes away.

    AndewKv is right, it's a realtek driver+software issue. Hope they will fix it in the newer version

    Sunday, May 5, 2019 2:02 AM
  • Google search the same problem led me here. I finally figured out which service was causing the issue. It is the realtek audio service. If I stop it, the problem goes away.

    AndewKv is right, it's a realtek driver+software issue. Hope they will fix it in the newer version

    Stopping the Realtek audio service worked for me!  Awesome.  Audio still works, so who knows what the purpose of that service is.

    Lenovo X1 Carbon 6th Gen here too.  Is it only the X1 carbon affected by this?

    Friday, June 7, 2019 12:35 AM
  • Lenovo X1 Carbon 6th Gen here too
    Monday, June 10, 2019 1:17 AM
  • Rollback driver seemed to work without problem also. 

    Gives version 6.0.1.8551. 

    Thursday, August 15, 2019 8:15 AM
  • Unbelievable, but it was fixed in the latest version of the Audio Driver: 6.0.8777.

    You can find in the release notes:

    [Problem fixes] - Fixed Mic not disabled by FN hotkey - Removed the debug mode in Fortemedia's code. - Fixed remote session Types "G" with Headset Attached

    Woohoo! )) I have checked it after registering this issue within Lenovo Support on May 3, 2019. ;)

    Wednesday, October 16, 2019 9:53 AM