none
Lync 2013 not saving conversation history RRS feed

  • Question

  • My Lync 2013 has stopped saving my conversation history in both Lync and Outlook since 04/07. It was working fine since then with no issues. My box is checked under my personal settings to save the history.  Any ideas?
    Thursday, April 17, 2014 2:26 AM

Answers

  • Please check that you didn’t run out of your mailbox.

    Check if other user can save conversation history on your computer.

    Check if your account can save conversation history on computer worked for other accounts.


    Lisa Zheng
    TechNet Community Support

    Friday, April 18, 2014 9:04 AM
    Moderator

All replies

  • Hi,

    Lync Client uses MAPI connection to save the chat session in the history folder and show you the presence of the users within Outlook.

    check if MAPI connection is ok by holding CTRL and right click on the Lync icon in the system tray and select "Configuration Information"

    also make sure you didn't do any changes to the Conversations history folder in outlook

    you might want to check this article: http://social.technet.microsoft.com/Forums/lync/en-US/d274b731-271b-4933-9bde-2f5ca49ba416/lync-2010-conversation-history-not-save-in-outlook-2010?forum=ocspresenceim


    __________________________________

    If you find this helpful

    please click "Vote as Helpful" if it answered your question please click "Mark as Answer"

    Mostafa Eltohamy

    Blog: http://Lyncdude.com  Twitter:   LinkedIn:   XING:


    Thursday, April 17, 2014 5:21 AM
  • The Conversation History is saved using the MAPI Connection between Lync Client and Outlook Client.

    Please check the Lync Configuration Information. The MAPI Status and EWS Status should be OK.

    Also you can refer below link

    http://exchangeserverinfo.net/2013/02/lync-unable-to-save-conversation-history-in-outlook/


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question, please click "Mark As Answer" Mai Ali | My blog: Technical

    Thursday, April 17, 2014 11:36 AM

  • Exchange Server 2007 SP1 and above must be deployed in conjunction with Lync Server 2013 in order to enable IM messages to be stored in the Exchange store. Specifically:

    Lync 2013 Compatibility
    http://technet.microsoft.com/en-us/library/gg412817.aspx

    The following features are available only through EWS (not MAPI*):

    - Read or delete items in the Conversation History folder
    - Read or delete voice mail items
    - Display extended free/busy information and meeting subject and location

    Hence, ensure that Exchange Web Services, EWS is properly configured and working correctly in your environment.

    Please share with us if this helps. Thanks.

    * Lync 2010 Integration
    http://technet.microsoft.com/en-us/library/gg398806(v=ocs.14).aspx

    Thursday, April 17, 2014 2:12 PM
    Moderator
  • MaPI Connection is set to OK and no changes were made in the conversation history folder.  This has been working fine with no issues just stopped on 04/07 with no new conversations being saved.
    Friday, April 18, 2014 3:17 AM
  • Please check that you didn’t run out of your mailbox.

    Check if other user can save conversation history on your computer.

    Check if your account can save conversation history on computer worked for other accounts.


    Lisa Zheng
    TechNet Community Support

    Friday, April 18, 2014 9:04 AM
    Moderator
  • how is this marked as an answer? 

    for some reason you Community support people jump the gun way to fast & mark your answers as correct without verification from the OP

    please unmark as this is not an answer & is only steps...i know it doesnt work since i have a similar issue, 

    & opened a new thread

    Wednesday, May 21, 2014 8:22 PM
  • how is this marked as an answer? 

    for some reason you Community support people jump the gun way to fast & mark your answers as correct without verification from the OP

    please unmark as this is not an answer & is only steps...i know it doesnt work since i have a similar issue, 

    & opened a new thread

    So i figured this out.

    the History spooler folder in the appdata folder is where the convos are stored prior to being sent to exchange.

    my issue was that anytime a file in there was over 1mb, it stoppeed processing them.

    after removing the 1mb file(s) the convo history started working again

    though I did need to log the user in & out a bunch of times, as logging into lync only processed 10 files at a time.

    • Proposed as answer by Steve_Lindsey Wednesday, August 6, 2014 7:50 PM
    Wednesday, August 6, 2014 7:50 PM
  • I'm faced this problem while Monday Aug 4 recently.

    Workaround 100% working as below step.

    - Rejoin domain.

    - After restarted, Remove old Lync Certificate in mmc.  In management console Add-snap in Certificate > choose current users > Personal > Remove items Issued by Communications Server.

    - Ms Office key under HKUsers > <<UID>> > Software > Microsoft, delete Office key. ( make sure no Ms Office program is running )

    - Clear Lync cache. \%AppData%\..\Local\Microsoft\Office\15.0\Lync\, remove SIP Address.

    - Run gpupdate /force in command prompt.

    - Start Ms Office Outlook then only start Lync 2013

    Friday, August 8, 2014 2:14 AM
  • I'm faced this problem while Monday Aug 4 recently.

    Workaround 100% working as below step.

    - Rejoin domain.

    - After restarted, Remove old Lync Certificate in mmc.  In management console Add-snap in Certificate > choose current users > Personal > Remove items Issued by Communications Server.

    - Ms Office key under HKUsers > <<UID>> > Software > Microsoft, delete Office key. ( make sure no Ms Office program is running )

    - Clear Lync cache. \%AppData%\..\Local\Microsoft\Office\15.0\Lync\, remove SIP Address.

    - Run gpupdate /force in command prompt.

    - Start Ms Office Outlook then only start Lync 2013

    you should try my solution above. its alot less work & works 99.99% of the time.

    the reason yours worked is because you deleted the sip folder (which is where the history spooler folder is) so essentially you deleted any convo files over 1mb. 

    Friday, August 8, 2014 2:24 PM
  • This fixed my issue completely.  I signed up just to tell everyone this.

    \AppData\Local\Microsoft\Office\15.0\Lync\sip_XXXXXXXXXXXXXXX\History Spooler

    I went into that folder and deleted everything that I saw (it had about 400 history files).  Once I did that, logging began operating normally.

    Friday, December 19, 2014 7:15 PM
  •  1mb. 

    So as an update.....

    I ran into a similar issue the other day, & the solution listed above did not work. What the issue turned out to be was the user had over 1000 folders in Outlook. 

    We had to make a custom throttle policy for the user which had the EWSFindCountLimit increased (we used 2000) & then once we set his mailbox to use that policy the conversation history began working again


    • Edited by Steve_Lindsey Thursday, February 26, 2015 9:19 PM
    • Proposed as answer by Steve_Lindsey Thursday, February 26, 2015 9:19 PM
    Thursday, February 26, 2015 9:18 PM
  • since I had some important conversations in mine here is how I saved them.

    renamed \AppData\Local\Microsoft\Office\15.0\Lync\sip_XXXXXXXXXXXXXXX\History Spooler to .OLD

    restarted Lync and \AppData\Local\Microsoft\Office\15.0\Lync\sip_XXXXXXXXXXXXXXX\History Spooler was recreated

    copied and pasted the .hist files and they started heading to outlook 10 at a time each time I closed a conversation window - only 182 more to go :)

    hope this helps

    • Proposed as answer by Aleksi älli Tuesday, March 17, 2015 9:16 AM
    Sunday, March 1, 2015 7:15 PM
  • I have user with quite normal mailbox, with mostly default folders and she's having problem with files larger than 1mb too. Rest of the conversation history is showing up in her mailbox "Conversation History" folder just fine.
    Thursday, May 14, 2015 8:30 AM
  • Please change the registry settings on the PC

    HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Lync]
    "TrustModelData"="%domainname%"

    Domain name should be your primary smtp domain address

    for eg mohideen@contoso.com

    domain name should be contoso.com

    • Proposed as answer by Noor Mohideen Thursday, June 11, 2015 11:46 AM
    Thursday, June 11, 2015 11:46 AM
  • Below resolution worked for me 

    OS Win7 Enterprise

    Make sure to close Outlook and Lync completely , even lync.exe from task manager

    Try going under

    C:\Users\username\AppData\Local\Microsoft\Office\15.0\Lync

    Delete what is in here also

     

    C:\Users\username\AppData\Roaming\Microsoft\Office\15.0\Lync

    And same delete here

    Then reboot


    • Edited by rbk84 Thursday, June 25, 2015 12:57 PM add info
    Thursday, June 25, 2015 12:53 PM
  • Really this is not the answer.

    For your information,correct Answer is provided by

    Avatar of Steve_Lindsey

    Steve_Lindse

    removing the 1mb file(s) the convo history started working again.

    But i dont understand this logic, is it because lync only supports chat history only upto 1 mb?



    Sushant Jangale Collaborative Environment Group

    Tuesday, October 13, 2015 9:14 AM
  • Really this is not the answer.

    For your information,correct Answer is provided by

    Avatar of Steve_Lindsey

    Steve_Lindse

    removing the 1mb file(s) the convo history started working again.

    But i dont understand this logic, is it because lync only supports chat history only upto 1 mb?



    Sushant Jangale Collaborative Environment Group

    from my experience it appears so. Any time i have seen a 1mb+ file in the history spooler folder. it has never been processed & always sits in there.
    Tuesday, October 13, 2015 12:52 PM
  • Didn't worked
    Thursday, March 17, 2016 6:53 AM
  • Was not able to find "TrustModelData"="%domainname%" :-( 
    Thursday, March 17, 2016 6:54 AM
  • Absolutely, positively worked!
    Wednesday, May 11, 2016 12:46 PM
  • Ok But why press control? its just right click.. btw i see the problem, what's the solution?
    Thursday, July 7, 2016 10:09 PM
  • We used this registry modification to fix the same issue where Conversation history was no longer passing the files from the C:\Users\__\AppData\Local\Microsoft\Office\15.0\Lync\sip_.com\History Spooler folder into the outlook 2010 conversation History folder.

    Our sip domain sign address and smtp domain are different.  I'm uncertain why it stopped working, it could have been an update, CU or autodiscover change that could have caused it, still investigating.

    EWS was not fully initialized and after the registry edit, it is OK.


    Wednesday, August 9, 2017 4:57 AM