locked
Cannot synchronise mail in Outlook app if app is downloaded AFTER enrolment into Intune on iOS RRS feed

  • Question

  • Hi there,

    After an iOS device is enrolled into Intune (via the Company Portal app) users are asked to download the Outlook app in order to get mail and calendar. This is primarily because we want to use the MAM controls.

    However, when this happens Outlook asks the user to authenticate but mail sync never appears to start and we're greeted with a blank screen.

    Outlook works fine when not enrolled in MDM. It still works fine when downloaded BEFORE enrolment into MDM. It only fails to sync when downloaded AFTER MDM enrolment either via the Company Portal or directly from the App Store.

    Outlook was added to Intune as a managed app. And MAM controls are in place (all fairly standard).

    Any ideas why Outlook is being 'broken' in this way?

    Monday, May 16, 2016 9:11 AM

Answers

  • I was having a similar issue with Android devices last week.  When not enrolled the Outlook app was connecting to activesync absolutely fine and downloading all the messages but when enrolled into Intune and then installing the Outlook app, no emails whatsoever showing.  In the end after enrolling and configuring the exchange account I actually left the device for about 24 hours, and then when I checked the emails were all there.  I assume it had just taken ages to fully sync.

    Just out of interest, have you tried just leaving it for a period of time?  What does your setup look like as well?  Are you using exchange online or on-prem (with connector?), do you have Intune standalone or Hybrid?

    Cheers, Tony.

    Monday, May 16, 2016 10:14 AM

All replies

  • I was having a similar issue with Android devices last week.  When not enrolled the Outlook app was connecting to activesync absolutely fine and downloading all the messages but when enrolled into Intune and then installing the Outlook app, no emails whatsoever showing.  In the end after enrolling and configuring the exchange account I actually left the device for about 24 hours, and then when I checked the emails were all there.  I assume it had just taken ages to fully sync.

    Just out of interest, have you tried just leaving it for a period of time?  What does your setup look like as well?  Are you using exchange online or on-prem (with connector?), do you have Intune standalone or Hybrid?

    Cheers, Tony.

    Monday, May 16, 2016 10:14 AM
  • Do you push out the Outlook app via Intune? Are you using 0365 or On-Premise exchange? Have you configured MAM in Intune (for MAM with enrollment, or in Azure Portal (for MAM without enrollment) ? 

    I have been doing this a lot and dont have any issues. As long as the device is enrolled and the MAM policy in Intune is setup up, either the iOS device installes the Outlook App or takes over management of the Outlook app. 



    Regards,

    Jan Ketil Skanke

    Senior Consultant - Lumagate AS

    Partner-TSP Enterprise Mobility - Microsoft

    Blog: http://jankesblog.com

    Note: If my respons helps you solve your issue, please mark as answered

    Monday, May 23, 2016 9:59 AM