none
Outlook 2010 keeps using one CPU core for 100% RRS feed

  • Question

  • Hi,

    After starting Outlook 2010 (windows 7) the outlook.exe proces always keeps using 25% CPU (on a CPU with 4 cores). This also happens when starting outlook in safe mode. I am not sure why outlook is busy (while I am doing nothing with it).

    Sometimes, when I close outlook the communicator.exe proces starts using 25% cpu instead so these symptoms might have to do with each other. This doesn't happen all the time (the communicator symptom), but I noticed it a few times.

    It would be nice if outlook could go back to normal CPU usage, because it will probably make my laptop a bit more silent (outlook's CPU usage makes the cooling fan work overtime).

    Kind regards,

    Arjan Hummel


    • Edited by HummelAJ Tuesday, August 14, 2012 8:15 AM be more clear about communicator symptom
    • Moved by Zi FengModerator Wednesday, August 15, 2012 9:14 AM Office issue (From:Clients)
    • Moved by Tony Chen CHN Monday, August 20, 2012 1:40 AM (From:Outlook IT Pro Discussions)
    Tuesday, August 14, 2012 7:55 AM

Answers

  • I (finally) managed to solve this problem! While monitoring handles with Process Explorer I noticed that communicator.exe would open up a handle to my Outlook .ost file just before it would start consuming 25% CPU. So this made me look into all the settings regarding this file in Outlook. To make a long story short: I disabled offline usage for this data file and this made my problem go away. I am still using cached exchange mode and I am not sure what is the difference between the two, but I am glad this resolved my problem. Both Outlook and Communicator show normal CPU usage now.

    If you want to change things in regard to your Outlook data file, the Outlook help function can be of help. Especially this article: 

    Move an offline Outlook Data File (.ost)
    • Marked as answer by HummelAJ Friday, September 21, 2012 8:49 AM
    • Edited by HummelAJ Friday, September 21, 2012 8:56 AM Mentioned Outlook help article
    Friday, September 21, 2012 8:48 AM

All replies

  • Hi,

    One machine problem or muliple points problem?

    Please try to run Windows clean boot without network for further troubleshooting.

    http://support.microsoft.com/kb/331796

    http://support.microsoft.com/kb/929135

    And you also may try to start Os with safe mode.

    Feel free to post back.

    Tony Chen

    TechNet Community Support

    Wednesday, August 15, 2012 9:18 AM
  • This is a one machine problem: a company laptop HP ProBook 6550b with Windows 7 Enterprise SP1 installed.

    I tried the suggestions in KB929135, but with no change in behaviour. So, all startup items are disabled. All non Microsoft services are disabled with the exception of several McAfee related services which cannot be disabled due to company policy.

    Also, I removed an internet calendar subscription in Outlook because I read in some post that this could be the root cause of the symptoms I am having. But with no luck.

    Despite all of these changes, the (CPU) behaviour is still the same as can be seen in the screenshot provided. I also noticed that the amount of private working set memory is pretty erratic (yellow graphic in the outlook.exe:4720 properties window). Not sure what that means, maybe it's normal.

    With all the above changes made I also tried to start Outlook in safe mode. Again, no change in behaviour.

    Are there any further troubleshooting steps to take to pinpoint the root cause of this symptom?

    Arjan

    CPU behaviour Outlook

    Thursday, August 16, 2012 9:20 AM
  • Hello,

    Check out the links below. It may help you.

    http://www.drewgreen.net/wordpress/2010/10/10/outlook-2010high-cpu-usage/

    http://social.technet.microsoft.com/Forums/is/outlook/thread/66348fbc-2624-4124-8572-d8cddeb3caf1

    Thursday, August 16, 2012 11:26 AM
  • I already found those links a while ago. Unfortunately, they don't help me. Just now I experienced the symptom that when Outlook is closed, the issue seems to move to communicator.exe. See provided screenshot. Same CPU usage, same erratic memory behaviour. Also, in the threads tab it seems to have to do with mso.dll.

    Communicator.exe threads

     
    Thursday, August 16, 2012 12:25 PM
  • Based on my knowledge, the file Mso.dll is general Office functionality common to all applications, for example, toolbars, file open/save UI, etc.

    Thus, please remove all of toolbars to check the result.

    In addtion, could you tell me the result after you performing Windows clean boot steps. Is the problem still there?

    Thanks.

    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Friday, August 17, 2012 3:14 AM
  • Based on my knowledge, the file Mso.dll is general Office functionality common to all applications, for example, toolbars, file open/save UI, etc.

    Thus, please remove all of toolbars to check the result.

    In addtion, could you tell me the result after you performing Windows clean boot steps. Is the problem still there?

    Thanks.

    Cheers,
    Tony Chen
    Forum Support
    ________________________________________
    Come back and mark the replies as answers if they help and unmark them if they provide no help.
    If you have any feedback on our support, please contact tnmff@microsoft.com.

    Just to be clear: with windows clean boot you mean the msconfig steps in the knowledge base articles you mentioned? If so: the results are during a clean boot even in combination with outlook safe mode. 

    Or do you mean to start windows itself in another (safe) mode?

    I disabled all the toolbars (right-click -> customize the ribbon -> deselect everything). Only the "file" tab is visible after that. However, symptoms remain.

    Friday, August 17, 2012 6:55 AM
  • Hi,

    Firstly, please double confirm the OC is up to date since we find a some performance issue in the previous version.

    If the issue till persists, please try temporarily uninstall OC and see if the issue still persists.

    Thanks,

    Simon Wu

    Exchange Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, August 20, 2012 9:38 AM
    Moderator
  • Hi,

    Firstly, please double confirm the OC is up to date since we find a some performance issue in the previous version.

    If the issue till persists, please try temporarily uninstall OC and see if the issue still persists.

    Thanks,

    Simon Wu

    Exchange Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    I think OC is up-to-date. The version I use is 2007 R2 3.5.6907.253. I installed updates mentioned on this Technet page.

    I tried to uninstall OC, but it did not help. Also, I tried to do a repair of the Office installation (while having OC still uninstalled). Again: no succes. I reinstalled OC because I use it a lot for my work. The reinstallation of OC also didn't do anything as far as the symptoms are concerned.

    I hope there is some troubleshooting left (other than reinstalling software/os). Any further assistance with these symptoms is appreciated.

    Regards,

    Arjan Hummel


    • Edited by HummelAJ Thursday, August 23, 2012 7:39 AM Updated OC version
    Tuesday, August 21, 2012 11:09 AM
  • Just tried a repair of the Office installation, but without any luck. The symptom remains. It's always a mso.dll thread that is responsible for the CPU usage. Specific:

    mso.dll!Ordinal7019+0x8db

    There are multiple threads like this (I count 10 right now), but only two of them seem to use the CPU a lot.


    Thursday, August 30, 2012 10:02 AM
  • Arjan,

    Have you made ​​progress, I think exactly the same problem ?

    gr, Iwan

    Tuesday, September 18, 2012 12:50 PM
  • Hi Iwan,

    No I did not make any progress so far. The issue still exists. I am wondering: what kind of hardware do you have the issue on. I use a HP ProBook 6550b laptop. Maybe we can find some corresponding factor to this issue. Do you also see the issue moving to communicator.exe after closing Outlook?

    Regards,

    Arjan Hummel

    Tuesday, September 18, 2012 1:59 PM
  • Arjan,

    My problem occurs in a virtual environment based on Citrix XenServer with guest OS Windows 2008 R2. One of the components we have in common is the mcafee virus scanner? We do not use Office Communicator.

    gr, Iwan

    Tuesday, September 18, 2012 2:49 PM
  • Arjan,

    We found our problem. When outlook starts the CPU usage is normal. When we hit the new email button, still normal. At the moment we start typing the body of a new email the CPU start spiking to 100% and does not stop until outlook is closed.

    If “Detect Language automatically” is disabled outlook behaves normal.

    New Email, Review, Language, set proofing language and disable Detect Language automatically

    Gr, Iwan


    • Edited by IwanH Thursday, September 20, 2012 10:11 AM
    • Proposed as answer by IwanH Thursday, September 20, 2012 10:12 AM
    • Unproposed as answer by HummelAJ Thursday, September 20, 2012 11:44 AM
    Thursday, September 20, 2012 10:11 AM
  • Arjan,

    We found our problem. When outlook starts the CPU usage is normal. When we hit the new email button, still normal. At the moment we start typing the body of a new email the CPU start spiking to 100% and does not stop until outlook is closed.

    If “Detect Language automatically” is disabled outlook behaves normal.

    New Email, Review, Language, set proofing language and disable Detect Language automatically

    Gr, Iwan


    Good to hear you have solved your problem. However this doesn't fix it for me. I don't have to be writing an e-mail. Starting Outlook is enough for me. After a few seconds the CPU usage goes up and stays (in my case) at 25%. Or 100% on 1 cpu/core if I set the affinity for the outlook.exe proces to only 1 cpu/core though task manager.

    Thursday, September 20, 2012 11:44 AM
  • I (finally) managed to solve this problem! While monitoring handles with Process Explorer I noticed that communicator.exe would open up a handle to my Outlook .ost file just before it would start consuming 25% CPU. So this made me look into all the settings regarding this file in Outlook. To make a long story short: I disabled offline usage for this data file and this made my problem go away. I am still using cached exchange mode and I am not sure what is the difference between the two, but I am glad this resolved my problem. Both Outlook and Communicator show normal CPU usage now.

    If you want to change things in regard to your Outlook data file, the Outlook help function can be of help. Especially this article: 

    Move an offline Outlook Data File (.ost)
    • Marked as answer by HummelAJ Friday, September 21, 2012 8:49 AM
    • Edited by HummelAJ Friday, September 21, 2012 8:56 AM Mentioned Outlook help article
    Friday, September 21, 2012 8:48 AM