none
DPM has detected a checksum mismatch during data transfer over the network RRS feed

  • Question

  • Hi,

    Im using DPM 2010 to backup SQL servers.

    All the databases are backuped up but one database.

    I recieve this error

    Affected area: Servername\DB1
    Occurred since: 2010-06-24 14:18:52
    Description: The replica of SQL Server 2008 database Servername\DB1 on Servername is inconsistent with the protected data source. All protection activities for data source will fail until the replica is synchronized with consistency check. You can recover data from existing recovery points, but new recovery points cannot be created until the replica is consistent.

    For SharePoint farm, recovery points will continue getting created with the databases that are consistent. To backup inconsistent databases, run a consistency check on the farm. (ID 3106)
     DPM has detected a checksum mismatch during data transfer over the network (ID 30087 Details: Internal error code: 0x809909B2)
     More information
    Recommended action: Retry the operation. If the problem persists, contact your network administrator to diagnose possible network issues.
     Synchronize with consistency check.
     Run a synchronization job with consistency check...
    Resolution: To dismiss the alert, click below
     Inactivate alert

     Any suggestions?

    Thursday, June 24, 2010 12:47 PM

Answers

  • On both the DPM and PS, turn off chimney to see if that helps.

    1) From administrative command prompt run:

      netsh int tcp set global chimney=disabled

    2) Play with bandwidth throttling setting for that PS and see if that makes any difference.

    3) Try enabling on-the-wire compression under the Optimize performance for that PG see if that makes any difference.


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by Laith IT Monday, July 12, 2010 6:26 AM
    Thursday, July 8, 2010 8:59 PM
    Moderator

All replies

  •  

     

    Hi,

    Is the database in question on a seperate server than the ones being backed up fine ?

    If the SQL server is running in a Windows 2008 Hyper-V guest, we have seen synthetic NIC cause crc errors, you can try installing a legacy NIC and disable the synthetic.

    During Beta, we had one customer report this problem on Windows 2008 and and after upgrading to Windows 2008 R2, the problem disappeared.  We had another customer report that DPM servers DNS entry got corrupted/deleted. After fixing this network issue DPM did not show the checksum error again.
     

    Basically - DPM is just the messenger, the corruption is real, so look for external causes.

     


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, June 24, 2010 3:50 PM
    Moderator
  • Hi,

     

    The database in question is on the same server.

    They have about 12 another databases (10-60GB) on the same SQL database which are being backed up normaly.

    The server is HP phisical so its not running i Hyper-V guest.

    The server is Windows 2008 SP2.

     

    Any suggestions where shall i start to troubleshoot?

     

    Thanks,

    LA.

    Friday, June 25, 2010 6:22 AM
  • Hey,

    1. Could you try to do a backup of that SQL database locally and see if it succeeds.

    2. I'm thinking also in the line of NIC drivers / firmware / ToE although it is on the same server

    Just my 2 cents

    Cheers,

    Mike Resseler


    Visit System Center User Group Belgium @ http://scug.be and http://scug.be/blogs/scdpm
    Friday, June 25, 2010 7:01 AM
    Moderator
  • Hi LA.

     

    You can try putting that problematic SQL DB into it's own PG so you can do backups in a more controlled setting and take a network trace of the failure for that single database.   I also remember one other weird case in DPM 2007 that if the PG was set for retention period of 1 day, it would cause that error and increasing retention to >1 day fixed it.   We never did figure that one out.

    let us know if you solve this.


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, June 25, 2010 2:15 PM
    Moderator
  • Can you re-open the thread if the original issue is not resolved.
    Thanks, Praveen D [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, July 2, 2010 6:49 AM
  • Hi,

    I put the database on seperate PG.

    The replica ran the first time and the DPM showed the status of backup while it didnt took any backup.

    I tried to run synchronization but the replica inconsistant came back.

    i checked the event log and all it said is:-

    I/O is frozen on database DataRawDB. No user action is required. However, if I/O is not resumed promptly, you could cancel the backup.

    I/O was resumed on database DataRawDB. No user action is required.

    Database backed up. Database: DataRawDB, creation date(time): 2010/06/22(17:44:17), pages dumped: 2233201, first LSN: 1696:21131:37, last LSN: 1696:21147:1, number of dump devices: 1, device information: (FILE=1, TYPE=VIRTUAL_DEVICE: {'{390E75CF-CD5D-4A80-9BB9-1ED6A752116D}1'}). This is an informational message only. No user action is required.

    No error.

    I will try to run a backup from the SQL and see what will happen.

    Regards,

    LA.

    Tuesday, July 6, 2010 9:18 AM
  • I run data integrity check, full backup to the database. Everything went well.

    Still have the same error!

     

    Any suggestions?

    Thursday, July 8, 2010 10:41 AM
  • On both the DPM and PS, turn off chimney to see if that helps.

    1) From administrative command prompt run:

      netsh int tcp set global chimney=disabled

    2) Play with bandwidth throttling setting for that PS and see if that makes any difference.

    3) Try enabling on-the-wire compression under the Optimize performance for that PG see if that makes any difference.


    Regards, Mike J [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by Laith IT Monday, July 12, 2010 6:26 AM
    Thursday, July 8, 2010 8:59 PM
    Moderator
  • Assign the DPM account as a backup user for this database and Enabling on-the-wire compression solved the problem.

     

    Thanks Mike.

    Monday, July 12, 2010 6:26 AM