none
MIM 2016 The Microsoft Identity Manager server database could not be successfully populated. RRS feed

  • Question

  • I am receiving The Microsoft Identity Manager server database could not be successfully populated. when installing the Service and Portal.

    In the event logs I get:

    Product: Microsoft Identity Manager Service and Portal -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action DeployAndPopulateDatabase, location: C:\Windows\Installer\MSIABAE.tmp, command: installApp=FIM action=DeployAndPopulateDatabase databaseName=FIMService namespaceName="fim" datFilesInstallDir="C:\Program Files\Microsoft Forefront Identity Manager\2010\Service\Data\BL" sqlserverName=IDM01 FIMServiceAccountDomain=Domain FIMServiceAccountName=MIMService SyncServiceAccountDomain=Domain SyncServiceAccountName=MIMSync RunningUserDomain=Domain RunningUserName=DAuser RunningUserEmail= CreateDatabase=True 

    Both the Service account and the Domain Admin account have mailboxes and email addresses on their AD objects.

    I have modified the model DB size as seen in another post about this issue.

    Are there any other logs that I can look at to see what is going on?

    Thanks for any assistance.


    Thursday, August 20, 2015 4:21 PM

Answers

  • I was able to resolve this by removing SQL 2014 and redeploying. I was good after that. Don't know what happened with the original installation of SQL, but that did it.
    • Marked as answer by CHFAHelpDesk Monday, August 31, 2015 4:01 PM
    Monday, August 31, 2015 4:01 PM

All replies

  • Both accounts need to be SysAdmin during installation

    Nosh Mernacaj, Identity Management Specialist

    Thursday, August 20, 2015 4:29 PM
  • I forgot to mention that both the accounts have the sysadmin server role on the SQL server.
    Thursday, August 20, 2015 4:48 PM
  • Also, I can see during the installation that the DB is created. I get this in the SQL logs:

    2015-08-20 09:31:35.25 spid76      Starting up database 'FIMService'.
    2015-08-20 09:31:35.95 spid77      Setting database option COMPATIBILITY_LEVEL to 100 for database 'FIMService'.
    2015-08-20 09:31:36.00 spid77      Setting database option ANSI_NULLS to ON for database 'FIMService'.
    2015-08-20 09:31:36.00 spid77      Setting database option ANSI_PADDING to ON for database 'FIMService'.
    2015-08-20 09:31:36.00 spid77      Setting database option ANSI_WARNINGS to ON for database 'FIMService'.
    2015-08-20 09:31:36.00 spid77      Setting database option ARITHABORT to ON for database 'FIMService'.
    2015-08-20 09:31:36.00 spid77      Setting database option CONCAT_NULL_YIELDS_NULL to ON for database 'FIMService'.
    2015-08-20 09:31:36.00 spid77      Setting database option NUMERIC_ROUNDABORT to OFF for database 'FIMService'.
    2015-08-20 09:31:36.00 spid77      Setting database option QUOTED_IDENTIFIER to ON for database 'FIMService'.
    2015-08-20 09:31:36.00 spid77      Setting database option ANSI_NULL_DEFAULT to ON for database 'FIMService'.
    2015-08-20 09:31:36.00 spid77      Setting database option CURSOR_DEFAULT to LOCAL for database 'FIMService'.
    2015-08-20 09:31:36.00 spid77      Setting database option RECOVERY to FULL for database 'FIMService'.
    2015-08-20 09:31:36.00 spid77      Setting database option CURSOR_CLOSE_ON_COMMIT to OFF for database 'FIMService'.
    2015-08-20 09:31:36.00 spid77      Setting database option AUTO_CREATE_STATISTICS to ON for database 'FIMService'.
    2015-08-20 09:31:36.00 spid77      Setting database option AUTO_SHRINK to OFF for database 'FIMService'.
    2015-08-20 09:31:36.00 spid77      Setting database option AUTO_UPDATE_STATISTICS to ON for database 'FIMService'.
    2015-08-20 09:31:36.00 spid77      Setting database option RECURSIVE_TRIGGERS to OFF for database 'FIMService'.
    2015-08-20 09:31:36.01 spid77      Setting database option AUTO_CLOSE to OFF for database 'FIMService'.
    2015-08-20 09:31:36.01 spid77      Setting database option ALLOW_SNAPSHOT_ISOLATION to OFF for database 'FIMService'.
    2015-08-20 09:31:36.01 spid77      Setting database option READ_COMMITTED_SNAPSHOT to ON for database 'FIMService'.
    2015-08-20 09:31:36.05 spid77      Starting up database 'FIMService'.
    2015-08-20 09:31:36.15 spid28s     Could not start Service Broker for database id: 19. A problem is preventing SQL Server from starting Service Broker. Check the SQL Server error log for additional messages.
    2015-08-20 09:31:36.15 spid28s     Error: 9645, Severity: 16, State: 3.
    2015-08-20 09:31:36.15 spid28s     An error occurred in the service broker manager, Error: 3602, State: 124.
    2015-08-20 09:31:39.12 spid77      Setting database option AUTO_UPDATE_STATISTICS_ASYNC to OFF for database 'FIMService'.
    2015-08-20 09:31:39.12 spid77      Setting database option PAGE_VERIFY to NONE for database 'FIMService'.
    2015-08-20 09:31:39.12 spid77      Setting database option DATE_CORRELATION_OPTIMIZATION to OFF for database 'FIMService'.
    2015-08-20 09:31:39.12 spid77      Setting database option ENABLE_BROKER to ON for database 'FIMService'.
    2015-08-20 09:31:39.12 spid77      Setting database option PARAMETERIZATION to SIMPLE for database 'FIMService'.
    2015-08-20 09:31:39.13 spid77      Setting database option TRUSTWORTHY to OFF for database 'FIMService'.
    2015-08-20 09:31:39.13 spid77      Setting database option DB_CHAINING to OFF for database 'FIMService'.
    2015-08-20 09:31:39.14 spid77      Setting database option HONOR_BROKER_PRIORITY to OFF for database 'FIMService'.

    Thursday, August 20, 2015 4:51 PM
  • I was able to resolve this by removing SQL 2014 and redeploying. I was good after that. Don't know what happened with the original installation of SQL, but that did it.
    • Marked as answer by CHFAHelpDesk Monday, August 31, 2015 4:01 PM
    Monday, August 31, 2015 4:01 PM