locked
Exchange 2010 Managed Folder Assistant does not work as documented RRS feed

  • Question

  • My company is deploying Exchange 2010 SP1 with some of our workstations still on XP with Outlook 2007 but some users have already installed Outlook 2010. In both Outlook clients and in OWA, we found this problem.

    Our deployment plan includes using personal archive with a default policy to move aged messages to archive. We moved two mailboxes, enabled archive and applied a default policy. Although the archive feature is enabled, it does not show immediately. We found that by the next day each mailbox client personal archive was visible, and messages were moved to the archive. But what we also noticed was management menus for policy and retention items were not in the context menus or the folder properties. After the second morning, the policy management was enabled on each client (policy tab on folder properties and context menu for policy tag was enabled). We looked at both OWA and Office Outlook 2010 clients.

    Exchange 2010 TechNet lib http://technet.microsoft.com/en-us/library/bb123958.aspx Configure the Managed Folder Assistant describes differences between Exchange 2010 SP1 and Exchange 2010 RTM:

    Before performing the procedures in this topic, it's important that you understand how the Managed Folder Assistant works in Microsoft Exchange Server 2010 Service Pack 1 (SP1) and in the release to manufacturing (RTM) version of Exchange 2010:

    ·     Exchange 2010 SP1   In Exchange 2010 SP1, the Managed Folder Assistant is a throttle-based assistant. Throttle-based assistants are always running and don't need to be scheduled. The system resources they can consume are throttled. You can configure the Managed Folder Assistant to process all mailboxes on a Mailbox server within a certain period (known as a work cycle).

    ·     Exchange 2010 RTM   In Exchange 2010 RTM, the Managed Folder Assistant is a schedule-based assistant. Schedule-based assistants run based on the schedule specified for the assistant.

    This text partially documents the Start-ManagedFolderAssistant cmdlet but this seems to have little effect toward resolving this issue.  I tested this command thoroughly to see if it will force the settings. I removed default policy from a mailbox, ran this command, closed Outlook 2010, waited over an hour before starting the Outlook again. There are only five mailboxes on a server built for thousands but there doesn’t seem to be a way to force Exchange 2010 full enable the features and polices quickly. And yes, the management account I used has Organizational and Recipient Management roles.

    Can someone to provide a document that describes how this feature works in SP1 and a method to get around the partial feature deployment problem?

    Thursday, May 19, 2011 6:49 PM

Answers

  • Hi
       I just do test on exchange 2010 Sp1(10 mailbox) , Managed Folder Mailbox Policies is assign to mailbox. Then I enter Start-ManagedFolderAssistant.  It takes effect in three minutes.
       Can you run stop-ManagedFolderAssistant and Start-ManagedFolderAssistant to test it?
       I also read the link which you offer and read this paragraph:
        Running the Managed Folder Assistant is a resource-intensive process, especially when it's run for the first time. The first time the Managed Folder Assistant runs, it typically processes a large number of items. This can be a resource-intensive process for the Mailbox server and the network. It can also result in Microsoft Outlook clients consuming large amounts of time and network resources while synchronizing with the server. Be sure to plan carefully to avoid overloading resources.
       You should run the Managed Folder Assistant only when your server can tolerate the extra load. This is usually during off-peak hours. You should also run the Managed Folder Assistant often enough to meet your organization's message retention requirements.
       Maybe the network and your server also affect the speed. I can’t find other article about ManagedFolderAssistant.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Terence Yu Thursday, May 26, 2011 3:40 AM
    Friday, May 20, 2011 7:55 AM