none
DPM console Crash RRS feed

  • Question

  • Hi everyone.

    Im running DPM 2016 on server 2016 with SQL 2012

    This was an upgrade from DPM 2012r2

    Im trying to add a server to a protection group, it gets right to the end of the wizard, where you click to update the protection group.  It says it was success and then the console immediately crashes.  When i go to the protection group, the server is not there, so it hasnt worked.

    In event viewer im getting this

    Log Name:      Application
    Source:        MSDPM
    Date:          16/04/2018 15:38:22
    Event ID:      999
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      COOPER.hatton.internal
    Description:
    The description for Event ID 999 from source MSDPM cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event:

    An unexpected error caused a failure for process 'msdpm'.  Restart the DPM process 'msdpm'.

    Problem Details:
    <FatalServiceError><__System><ID>19</ID><Seq>505899</Seq><TimeCreated>16/04/2018 14:38:22</TimeCreated><Source>DpmThreadPool.cs</Source><Line>163</Line><HasError>True</HasError></__System><ExceptionType>ArgumentException</ExceptionType><ExceptionMessage>Replica Set already present with properties not matching input requirements</ExceptionMessage><ExceptionDetails>System.ArgumentException: Replica Set already present with properties not matching input requirements
       at Microsoft.Internal.EnterpriseStorage.Dls.StoragePoolManager.StoragePoolManager.CheckIfExistingVolumesMatch(Guid volumeSetId, VolumeInput[] volumeRequirements)
       at Microsoft.Internal.EnterpriseStorage.Dls.StoragePoolManager.StoragePoolManager.AllocateVolumesLocal(Guid volumeSetId, VolumeInput[] volumeRequirements, String replicaAreaSetName)
       at Microsoft.Internal.EnterpriseStorage.Dls.StoragePoolManager.StoragePoolManager.AllocateVolumes(Guid volumeSetId, VolumeInput[] volumeRequirements, String replicaAreaSetName)
       at Microsoft.Internal.EnterpriseStorage.Dls.Rhl.ReplicaAreaSetManagerHelper.AllocateVolumes(String replicaAreaSetName, VolumeInput[] volumeArrayInput, Int32&amp; replicaVolumeOutId, Int32&amp; shadowCopyVolumeOutId)
       at Microsoft.Internal.EnterpriseStorage.Dls.Rhl.ReplicaAreaSetManager.Allocate(Guid dataSourceId, List`1 dataSourcesOnReplica, String storageNodeServerName, String replicaAreaSetName, String replicaMountPointName, UInt64 replicaSize, String shadowCopyMountPointName, UInt64 shadowCopySize, String replicaGuid, String shadowCopyGuid, Boolean formatRequested, Boolean isCustom, Boolean isDiskMigration)
       at Microsoft.Internal.EnterpriseStorage.Dls.StorageManager.DiskManager.AllocateStorage(String containerId, Guid storageId, StorageParams storageParams)
       at Microsoft.Internal.EnterpriseStorage.Dls.StorageManager.StorageManager.AllocateStorage(String containerId, Guid storageId, StorageType storageType, StorageParams storageParams)
       at Microsoft.Internal.EnterpriseStorage.Dls.Intent.DataSourceTranslator.PerformReplicaAllocation(Boolean isCustom, ProtectedObjectType[] protectedObjects)
       at Microsoft.Internal.EnterpriseStorage.Dls.Intent.DataSourceTranslator.ValidateAndPerformReplicaAction(ProtectedObjectType[] protectedObjects, Boolean isReplicaProtectionTypeChanged, Dictionary`2 reallocateStorageMap)
       at Microsoft.Internal.EnterpriseStorage.Dls.Intent.ProtectedGroupTranslator.ValidateAndPerformReplicaAction()
       at Microsoft.Internal.EnterpriseStorage.Dls.Intent.ProtectedGroupTranslator.PrepareForTranslation()
       at Microsoft.Internal.EnterpriseStorage.Dls.Intent.ProtectedGroupTranslator.TranslateGroup(IMCatalogType IMCatalogXmlPassed, String intentCatalogXml)
       at Microsoft.Internal.EnterpriseStorage.Dls.Engine.CIntentServices.ConfigureProtectedGroup(UInt16* bstrIMCatalogXml)
       at Microsoft.Internal.EnterpriseStorage.Dls.Engine.CCoreServices.ConfigureProtectedGroup(CCoreServices* , UInt16* bstrIMCatalogXml, tagSAFEARRAY** exceptionResult)</ExceptionDetails></FatalServiceError>


    Can anyone help me with this, ive not had much luck finding answers on the web, and i need to get this server protected.

    Ive ran dpm-sync as i read that can sometimes fix the issue, but it hasnt made any difference.

    help!!

    -Vicky Tofield

    IT Technician

    Sir Christopher Hatton Academy



    Tuesday, April 17, 2018 8:28 AM

All replies

  • Hello,

    Did you installed the latest update rollup for DPM 2016? 

    https://support.microsoft.com/en-us/help/4043316/update-rollup-4-for-system-center-2016-data-protection-manager


    Microsoft Certified Professional

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered "Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    Tuesday, April 17, 2018 5:06 PM
  • Hi,

    yes its on the latest rollup

    -Vicky

    Wednesday, April 18, 2018 7:55 AM
  • Hi, I see the following error in the event: >Replica Set already present with properties not matching input requirements</ExceptionMessage> Is this happening with only server that you are trying to add in DPM for backup, or is it also happening with other servers as well. Are you trying to setup the protection for the server for the first time? Also reproduce the issue and try to post the MSDPM error logs here. 

    ------------------------------------------------

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. This posting is provided "AS IS" with no warranties, and confers no rights.



    Thursday, April 19, 2018 3:47 AM
  • Hi,

    thanks for your reply

    yeah i noticed that replica message too, but ive not had much luck finding out what is causing it.

    It happens with any server i try to add, i tried adding a server that doesnt need backing up just to see if it was an issue with the initial server that does need backing up, but its doing the same thing.

    the server im trying to add is a new server yes.

    here is a onedrive link to the MSDPM error log immediatley after the error occurred

    https://1drv.ms/u/s!AqjY5k2tJdFm4AML1fDDmmdICae9

    Tuesday, April 24, 2018 7:53 AM
  • Hi tofieldv,


    Just some heads up, this was already an issue in DPM2016 UR2, as of then you had to contact Microsoft for a private fix.
    See article here: https://stackingitblog.com/2017/05/09/dpm-2016-ur2-mmc-console-crashes-event-id-999/

    It appears that the issue still exists in UR4.

    Kind regards,
    Leon


    Please remember to mark the replies as answers if they help.

    Thursday, May 3, 2018 10:10 PM
  • Update Rollup 5 was released for DPM 2016, which fixes some console crashes.

    https://support.microsoft.com/en-us/help/4090835/update-rollup-5-for-system-center-2016-data-protection-manager


    Microsoft Certified Professional

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered "Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    Friday, May 4, 2018 8:32 AM
  • Hi,

    console crashing is mostely related to some mistakes between DB and Disk.

    run "DpmSync -sync" from DPM bin folder.

    Take care, afterwards, every Replica is inconsistent and need a CC check, but this should help.


    Michael Seidl (MVP)

    SYSCTR Senior Consultant, Blogger, CEO

    Blog | Twitter | Facebook | LinkedIn | Xing | Youtube

    Note: Posts are provided "AS IS" without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Friday, May 4, 2018 9:38 AM
  • I know this is an old thread but I thought I'd add my findings for posterity.

    I had the same fault and ended up creating a new protection group. The error (as above) indicated that the replica may have already existed and I was trying to recreate it? Not sure, as there is nothing I found online which helped explain it.

    I put together an SQL script to give me an indication of where the problem lay. This told me some basic details for each protected server. The interesting thing was that the offending server appeared 4 times, whereas all the others only appeared once. I think the fault was down to some over-zealous removal and reinstallation of protected servers/agents. DPM needs gentle treatment sometimes. You need to let things simmer down.

    USE DPMDB
    SELECT NetbiosName,
    OSType,
    OSVersion,
    Deleted,
    MarkedForDeletion,
    Enabled,
    ServerAttributes,
    IsServerOS,
    ApprovedPatchByAdmin,
    LastRefreshTime,
    tbl_AM_Server.ServerId
    FROM tbl_AM_InstalledAgent
    INNER JOIN tbl_AM_Server ON tbl_AM_InstalledAgent.ServerId = tbl_AM_Server.ServerId
    order BY tbl_AM_Server.NetbiosName

    Note: you don't need all the fields in this script, but some of them helped me with other issues too. At least it will confirm there is a problem with the offending server.

    So I moved the existing datasources over to the new Protection Group. It took a long time as there were 25+ VMs and each one needed a consistency check after being 'moved'. After this it all worked fine, although I suspect there are still underlying DB issues and I'm really not brave enough to tackle them.



    • Edited by AndyChips Tuesday, March 12, 2019 3:07 PM
    Tuesday, March 12, 2019 3:03 PM