none
Cannot enable Windows Defender Application Guard RRS feed

  • Question

  • Hi,

    I'm running a copy of Windows 10 Pro Build 1903 x64 and cannot enable WDAG. It is greyed out and the context menu claims it is not supported on this device configuration.

    I use a Ryzen 3600 which supports all of the requirements as listed by https://docs.microsoft.com/en-us/windows/security/threat-protection/windows-defender-application-guard/install-wd-app-guard. I also have 16GB of RAM and more than 100GB free storage on my main drive. This is a fresh installation only a few days old.

    In fact, Hyper-V is installed and working correctly. Other features based on it, such as Windows Sandbox, work correctly.

    If I forcefully install the feature via Powershell, it does not work: the menu option in Edge does not appear.

    Are there any steps I can take to detect the issue here?

    Thank you and best regards,
    Tobias Zimmermann

    Friday, October 4, 2019 12:52 PM

All replies

  • Hello Tobias,

    If you like, you might double check using the tutorial below to see if something may have been missed to enable WDAG.

    https://www.tenforums.com/tutorials/83607-turn-off-windows-defender-application-guard-windows-10-a.html


    Friday, October 4, 2019 3:54 PM
  • Hi Shawn,

    thank you for your reply. I took a look at the tutorial you linked, but unfortunately it does not resolve my problem. "Option one" is exactly what I was trying to do. The tutorial suggests that if the setting is greyed out, virtualization is disabled. It is, however, very much enabled (and working for other applications!).

    The Isolated Browsing settings in "Option two" do not show on my PC at all (presumably because my system believes I do not meet the prerequisites).

    Friday, October 4, 2019 4:38 PM
  • Hi

    If you see Windows Defender Application Guard is grayed out, your PC doesn’t support this feature.

    You may not have a PC with Intel VT-x or AMD-V hardware, or you may need to enable Intel VT-X in your computer’s BIOS. The option will also be grayed out if you have less than 8 GB of RAM(16GB on your device is enough).

    Have a nice day!

    Best regards

    Kiki Shi


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 7, 2019 8:33 AM
  • Hi,

    I am very happy to help you. Would you mind letting me know the update of the problem?  If you think the answer is helpful, please mark it as a reply, which will help more users get valid information.

    Have a nice day=.=

    Best regards,

    Kiki Shi


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 8, 2019 2:15 AM