locked
SCOM 2007 R2 and Exchange 2010 RRS feed

  • Question

  • We just implement the Exchange 2010 MP on our SCOM 2007 R2 server and we are getting a lot of alerts saying the following and we don't know how to override or correct them.

     

    Alerts are from "TCP Connectivity with Autodiscover - Autodiscover failure Resolution"

    The exception: 'Microsoft.Exchange.Monitoring.AutodiscoverTaskException: The Autodiscover response isn't valid. Field = 'AutoDiscoverResponseXML', autodiscoverData = '<Null>'.

    Any help would be appreciated

    Friday, September 24, 2010 1:27 AM

Answers

All replies

  • First thing that comes to mind is: Does Autodiscover work from the outside and inside? You can test Autodiscover from the Outside from here:

    Exchange Server Remote Connectivity Analyzer
    https://www.testexchangeconnectivity.com/
    (There's a link from Tools in the EMC as well.)

    And of course, you can test Autodiscover on the inside from within Outlook 2007 / 2010.

    If not, Jaap Wesselius, Exchange MVP, is always worth reading:
    Exchange 2010 Autodiscover (Part 1)
    http://www.msexchange.org/articles_tutorials/exchange-server-2010/management-administration/exchange-autodiscover.html

    Exchange Autodiscover (Part 2)
    http://www.msexchange.org/articles_tutorials/exchange-server-2010/management-administration/exchange-autodiscover-part2.html

    Having said this, several people appear to have some issues with Exchange 2010 MP. We did with Remote PowerShell, and after having applied Exchange 2010 SP1, especially with ECP. A new MP is supposed to be in the works and released "very soon" (according to the thread below).

    Exchange 2010--Struggling With Noisy Discoveries and Modified Properties
    http://social.technet.microsoft.com/Forums/en/operationsmanagermgmtpacks/thread/5876e894-039c-43ed-8263-59be991410f7

    See also:
    Exchange 2010 SP1 and SCOM 2007 R2 Bug?
    http://social.technet.microsoft.com/Forums/en/exchange2010/thread/fba4731a-c714-4206-990b-358d411170cb

    If Autodiscover is configured correctly, and you still get these errors, you should override the monitor, not the rule., as this "could make the correlation engine work harder, so it made sense to kill the monitor causing the state changes that are then evaluated by the correlation engine."

    KHI: IMAP4 connectivity transaction failures
    http://social.technet.microsoft.com/Forums/en/operationsmanagermgmtpacks/thread/6617bc3c-2c05-4cfd-9304-590999d9b1bb


    MCTS: Messaging | MCSE: S+M | Small Business Specialist
    Friday, September 24, 2010 8:36 AM
  • Thanks for the information.

     

    After reading all your information, I am still unclear on what I need to do.     Are you thinking the autodiscover address is wrong?   Should I override the default value?

    Friday, September 24, 2010 9:47 AM
  • No, you should not necessarily override the default value for internal Autodiscover, though I usually do. This depends on you general configuration of your Exchange server(s). But there are no defaults for your external Autodiscover; this needs to be configured with a valid URL and certificate, all of which is described in Wesselius' articles (and a lot of other sites).

    My main point is: You should first trust, then verify SCOM 2007. First you need to make sure that Autodiscover is working, then see if it is necessary to override / disable the monitor.

    I have had no problems with Autodiscover neither in Exchange 2010 RTM nor Exchange 2010 SP1 with SCOM 2007 R2; this applies to my test environment and production. However, there appear to be some issues with the Exchange 2010 MP and CAS services.


    MCTS: Messaging | MCSE: S+M | Small Business Specialist
    Friday, September 24, 2010 1:28 PM
  • Hi,

    Please check if any troubleshooting method on the following article will help:

    TCP Connectivity with Autodiscover - Autodiscover failure:

    http://technet.microsoft.com/en-us/library/ff360052(EXCHG.140).aspx

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, September 27, 2010 7:11 AM
  • Autodiscover is working seems like it is an issue with the management, does anyone have any helpful links to how one would tweak or override default values.
    Thursday, September 30, 2010 9:15 PM
  • Hi,

    As Jon mentioned, please check if the following article will help: 

    Exchange 2010 Autodiscover (Part 1)
    http://www.msexchange.org/articles_tutorials/exchange-server-2010/management-administration/exchange-autodiscover.html

    Exchange Autodiscover (Part 2)
    http://www.msexchange.org/articles_tutorials/exchange-server-2010/management-administration/exchange-autodiscover-part2.html

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, October 6, 2010 8:56 AM
  • I got some feedback from MS as this an issue with the management pack and should be correct when applying Exchange 2010 Service Pack 1 to our environment.     Can anyone confirm this ?
    Wednesday, October 6, 2010 3:57 PM
  • No, not at all. On the contrary. My main profession is being an Exchange 2007 / 2010 implementor and administrator. Exchange 2010 SP1 adds a lot of new functionality and better OWA performance / feature set. My main impression with Exchange 2010 SP1 is that a Rollup or two would be fine (don't get me wrong: I'm very impressed by Exchange 2010 SP1). I only had one single issue with the Exchange 2010 MP prior to Exchange 2010 SP1, and that was Remote PowerShell (which I could not get to work through an Kemp LoadMaster). With SP1, SCOM 2007 R2 issues with:

    * Remote PowerShell (still)
    * ECP (no issue prior to SP1)
    * IMAP and POP3 (no issue prior to SP1)
    * DAG is not monitored (no issue prior to SP1)

    But I have not had any issues with Autodiscover, neither in my test environment, nor in two SCOM 2007 R2 deployments. An updated Exchange 2010 MP is supposed to be in the works.

     


    MCTS: Messaging | MCSE: S+M | Small Business Specialist
    Wednesday, October 6, 2010 10:17 PM
  • Ha... excuse the laughter, but those articles never help. They all say exactly the same thing: look in the event log, the Ops Console, or self support in the solutions centre. Did someone just copy and paste the same set of resolutions to every single Operations Manager page in Technet?
    Thursday, January 27, 2011 12:08 AM
  • Hallo @ all,

    does anybody know a possibility to change/customize any property of the synthetic transitions, which are executed by the SCOM Agent?

    Test-OutlookConnectivity -RpcTestType:Server -TrustAnySSLCert:$true

    Test-OutlookConnectivity -Protocol:Tcp -GetDefaultsFromAutoDiscover:$true -TrustAnySSLCert:$true

    Test-WebServicesConnectivity -TrustAnySSLCertificate:$true -LightMode:$true

    Test-PopConnectivity -MonitoringContext:$true -ConnectionType:2 -TrustAnySSLCertificate:$true -LightMode:$true

    Test-EcpConnectivity -TestType:External -MonitoringContext:$true -TrustAnySSLCertificate:$true -LightMode:$true

    Test-EcpConnectivity -TestType:Internal -TrustAnySSLCertificate:$true -LightMode:$true

    Test-OwaConnectivity -TestType:External -TrustAnySSLCertificate:$true -LightMode:$true

    Test-OwaConnectivity -TestType:Internal -TrustAnySSLCertificate:$true -LightMode:$true

    Test-ImapConnectivity - ConnectionType:2 -TrustAnySSLCertificate:$true -LightMode:$true


    With overrides I see just the option of disabel, change the intervall and repeat threshold.

    Best Regards,

    Mike

    Monday, March 21, 2011 2:25 PM