none
Power Query: Invalid credentials RRS feed

  • Question

  • Hi folks,

    Can anyone help me debug this use case?  The API call works fine in browsers Edge and Chrome but PQ throws Invalid Credentials.  Many thanks.

    http://ondemand.websol.barchart.com/getEquityOptions.csv?apikey=ac18dcd0119cd78beb42c9a9633cdbb6&underlying_symbols=IBM&fields=volatility,delta,gamma,theta,vega,rho,bid,bidSize,bidDate,ask,askSize,askDate,premium,settlement,lastTradeDate,openInterest

    Friday, October 28, 2016 6:46 PM

Answers

  • PQ stores credentials. Have you tried deleting these stored credentials? I don't recall where to find this - left hand menu, half way down, options maybe.

    Self Service BI Expert using Power Pivot http://exceleratorbi.com.au

    • Marked as answer by Nin Sute Saturday, October 29, 2016 9:54 AM
    Saturday, October 29, 2016 6:19 AM

All replies

  • PQ stores credentials. Have you tried deleting these stored credentials? I don't recall where to find this - left hand menu, half way down, options maybe.

    Self Service BI Expert using Power Pivot http://exceleratorbi.com.au

    • Marked as answer by Nin Sute Saturday, October 29, 2016 9:54 AM
    Saturday, October 29, 2016 6:19 AM
  • Thank you, Matt, for pointing me in the right direction.  FYI, the options can also be accessed from Data/Get & Transform/New Query.  Nothing specific about credentials but ignoring privacy levels seems to fix the problem.  Now I'm irked because I cannot recreate the problem even after deleting all sources and resetting privacy levels.  But I'm on my way so thanks again!
    Saturday, October 29, 2016 9:58 AM