locked
MOSS 2007 MSContentEditor.dwp missing RRS feed

  • Question

  • Hi All,

     I am getting below error on stsadm -ompreupgrade 

    Issue : Missing server file or server configuration issues Server side files are referenced in the content databases, but are not installed on the server. Without these files, the sites may not function completely or the content may not render correctly. Also, upgrade or post upgrade issues may occur if these files are not available in the new version environment.The following web part(s) are referenced by the content, but they are not installed on the web server
    • Id = eecac43f-6bd8-a40d-8841-1912ef50db63, Type = Unknown, Reference = 1, Status = Missing
    • Id = a21e5d41-9cab-1dd6-934f-fe972fd40238, Type = Unknown, Reference = 1, Status = Missing
    • Id = e6377261-6920-bbfe-501f-fda7a61db10f, Type = Unknown, Reference = 3, Status = Missing
    The following setup file(s) are referenced by the content, but they are not installed on the web server
    • Path = [C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\1033\MPS\..\sts\lists\wplib\dwp\MSContentEditor.dwp], Reference = [1], Status = [Missing]
    • Path = [C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\1033\MPS\..\sts\lists\wplib\dwp\MSImage.dwp], Reference = [1], Status = [Missing]
    • Path = [C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\1033\MPS\..\sts\lists\wplib\dwp\MSMembers.dwp], Reference = [1], Status = [Missing]
    • Path = [C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\1033\MPS\..\sts\lists\wplib\dwp\MSPageViewer.dwp], Reference = [1], Status = [Missing]
    • Path = [C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\1033\MPS\..\sts\lists\wplib\dwp\MSXml.dwp], Reference = [1], Status = [Missing]
    • Path = [C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\1033\SPS\DMFramesetTopFrame.aspx], Reference = [1], Status = [Missing]
    • Path = [C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\1033\SPS\moreinfo.aspx], Reference = [1], Status = [Missing]
    • Path = [C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\1033\SPS\search.aspx], Reference = [1], Status = [Missing]
    • Path = [C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\Template\1033\SPSSITES\Lists\siteslst\Summary.aspx], Reference = [1], Status = [Missing]

    Kindly provide me the steps to resolve it. 


    Thanks and regards,
    Anandha Babu M.
    http://sharepointpassion.wordpress.com

    Thursday, May 31, 2012 10:16 AM

Answers

  • Hi Anandha,

    The setup file (MSContentEditor.dwp, MSImage.dwp…) are related to the Basic Web Parts Feature. You may follow these steps:

    1. Manually add the web parts by hand from the Web Part Gallery.

    - Site Settings > Web Part gallery

    - Click "New" and browse to which ever parts you want to add.

    2. Modify the Onet.xml of the site definition to include the Basic

    Web Part feature This is a more global change in that every site

    collection created will get all the web parts from that feature.

    - Lookup the Basic Web Part Feature GUID and copy it

    ...\12\TEMPLATE\FEATURES\BasicWebParts\Feature.xml

    - Navigate to site definition Onet.xml file:

    ...\12\TEMPLATE\SiteTemplates\SPSPERS\XML

    - Under the <SiteFeatures> tag, add a new entry and paste in the

    Basic Web Part Feature GUID

    <Feature ID="12345678-1234-1234-1234-123456789123"/> <!--

    Basic WebParts-->

    Please refer to this document for more information.


    Lambda Zhao

    TechNet Community Support

    Friday, June 1, 2012 3:36 AM