none
2012 R2 SP1 Upgrade Procedure RRS feed

  • Question

  • Okay, so I see that they posted 2012 R2 SP1 via the team blog and I have downloaded both items that are available.  When I tried to update my workstation that has the admin console on it, it says that administrator permissions are needed to install it (even though I am admin on the machine).  I opened an Admin Command Prompt and navigated to the MSI for the update and it says that 2012 SP2 needs to be installed.  I went through the SP2 admin console setup and it updated the file versions from 5.0.7958.1604 (2012 R2 CU5) to 5.0.8239.1000 (SP2 based on the install that completed) and then went back to the MSI file for 2012 R2 SP1 and tried to run it from an admin command prompt and it says 2012 SP2 needs to be installed (even though it was just installed). 

    I know it was only released about 2 hours ago but was waiting for this before I started migrating to a new infrastructure I have.As

    As a test, I tried to run the "upgrade" option from the HTA on my parent server and it says I need admin permissions (which I have) and went through the same test of trying to run the MSI from an admin command prompt and it is telling me that SP2 needs to be installed first.

    Any ideas?  Seems like they are not making this that easy this time.

     
    Thursday, May 14, 2015 4:48 PM

Answers

All replies

  • Just installing it now.

    This is EVAL only so obviously this is in a lab only.

    To upgrade an existing site then you need to use 'SC2012_SP2_Configmgr_SCEP.exe" and choose the upgrade option.


    Thursday, May 14, 2015 5:33 PM
  • Well, the naming convention is pretty misleading.  I didn't see the "Things to Know" option that explains that.  So non-eval users need to wait until the non-eval bits are available then?  That kind of sucks.  Little frustrating today.
    Thursday, May 14, 2015 5:44 PM
  • Final release is next week, you can install the ConfigMgr console on a client via the SP2 media from the menu, works fine.
    Thursday, May 14, 2015 5:52 PM
  • So based on what I am reading and naming conventions of everything, are they trying to bring the code bases together?  2012 R2 SP1 includes SP2 media for 2012 which brings the bits to SP1 and 2012 users get SP2 and the bits for R2 SP1?  Am I making sense?  Like I said, the downloadable EXE file naming convention and the "Things to know" section kind of imply this.  Just trying to make sure I don't jack up what I have already in place when the non-eval bits are available.  In the need to know, for new installs it says run the SP2 install and then run the R2 SP1 update.  If I go to the non-R2 SP2 eval, the EXE download is the same name and size.  Like I said, just trying to make sure I have the right upgrade path mapped out.
    Thursday, May 14, 2015 6:02 PM
  • Yvette from the team blog posted this which includes updated information on the upgrade posted today even though the date is from December of 2014 https://technet.microsoft.com/en-us/library/jj822981.aspx#BKMK_UpgradeVersions

    Thanks

    • Marked as answer by Fritzy05 Thursday, May 14, 2015 6:25 PM
    Thursday, May 14, 2015 6:25 PM
  • http://anoopcnair.com/2015/05/05/sccm-2012-sp2-and-configmgr-2012-r2-sp1-new-improvements-and-updates/

    The media might change by next week who knows. if it's the same then if you are on R2 you use the upgrade feature from the SP2 media to upgrade the site, the other exe is only used for totally new installations.

    Thursday, May 14, 2015 6:25 PM
  • Here's a summary of when to use each: http://t.co/Vdn5tbvsmw


    Jason | http://blog.configmgrftw.com | @jasonsandys

    Friday, May 15, 2015 2:05 AM
  • Thanks for the follow-up and comments. Looks like I wasn't the only one initially confused by the process. I was able to get my infrastructure updated today and it is looking good. Thanks again!
    Friday, May 15, 2015 6:32 PM
  • Well, I'm still a little confused about all this.  Apparently the build numbers are the same for SCCM 2012 SP2 and SCCM 2012 R2 SP1 (5.00.8239.1000), but after running the upgrade option on my R2 CAS server, it now reports as if it was a SCCM 2012 SP2 and here is where I get confused, shouldn't it report as SCCM 2012 R2 SP1 ??

    I know the build numbers are the same, but I wonder how should it be reporting? SCCM SP2 or SCCM R2 SP1??

    Am I missing any functionality or is this just expected?

    Thanks in advance for your clarification guys, this is just getting me crazy :P


    Performance, Security & Design

    Friday, May 22, 2015 10:09 PM