locked
Presence shows offline RRS feed

  • Question

  • Hi Guys,

    Hope you can help.

    We use Skype for Business on-premise.

    We had a Domain controller that crashed since this strange issue started to appear.

    Luckily we had backup dc's, so the domain is still in tact. One domain only.

    When we create a new user on Skype for Business, other users already enabled on the Skype for Business server, cant see the new user's presence. It just says "Offline" and "Offline IM's can still be sent".

    Now remember this is only for the "New Enabled" Skype for Business user.

    All the previous enabled users can see each others presence like normal.The only work around I could find, was to go in the skype for business client to "options", then "alerts" and set the "Contacts not using Skype for business" option to "Allow anyone to contact me". By default its on "Allow invites, but block all other communications". After that the new user's presence can be seen when searching for it in skype for business client.

    1) Why is the client seeing other users as "not skype for business clients" hence blocking the presence?

    2) Is there some registry setting i can enforce with a GPO to enable the skype for business clients to by default enable "Allow anyone to contact me"?

    The Skype for Business server only hosts 1 sip domain on server 2012 R2. It is a standard edition. Ive already done skype for business updates without any success.

    Regards

    Monday, November 21, 2016 2:52 PM

All replies

  • Hi

    It is likely that when you restored your DC something has got corrupted. I would first start looking into your AD to make sure it is healthy, replicating and has no stale objects using tools such as dcdiag and replmon. If the problem didn;t exist before the DC issue, then this is the most likely place to start looking.

    I am guessing some attributes aren't being populated in AD, or are, just not on all DCs (due to replication at a guess) 


    Note: Please remember to `Mark as Answered` a post that answers your question and/or `Vote as Helpful` posts that have helped you. This will help others find answers to similar problems. For more Skype for Business help visit: http://www.skype4b.uk Please note that answers are based on my experience and opinion only and do not necessarily represent the views of my employer.

    • Proposed as answer by Alice-Wang Tuesday, November 22, 2016 7:50 AM
    Monday, November 21, 2016 6:40 PM
  • Hi Alice,

    Ive check and AD is replicating 100%. I also took an old active user and matched it with a new skype user on adsie. All attributes regarding rtc/skype is present without any differences.

    Ill try a few more tests then Ill have no option, but to make a backup of the current server and redo Skype for Business and restore the data.

    I also did im/presence traces and don't see any errors regarding the new users presence being blocked or denied.

    Regards

    Tuesday, November 22, 2016 10:11 AM
  • It shouldn't do it all the time.

    But I find that it often happens after I make a change to someone in AD.

    Try this on the Lync Server.

    1. Delete the address book files
    2. Run Update-CsUserDatabase to sync the latest AD data to the Lync DB.
    3. Run Update-CsAddressBook to write the changes to new address book.

    Wednesday, November 23, 2016 12:38 AM