none
Adding Features fail Win 8 RRS feed

  • Question

  • adding features to windows 8, something went wrong error, i'm trying to upgrade to Windows 8 media centre, it fails every time, tried everything, microsoft techies didnt solve it either!

    Thursday, January 31, 2013 4:37 PM

All replies

  • Hi, could you please specify, what exactly fails? Are you taking about failing activation?
    If you are talking about failing activation process that you perform with Windows Activation wizard, try the following at the elevated command prompt:

    1. Execute the command sequence below:

    C:\Windows\system32\>slmgr/upk
    C:\Windows\system32\>slmgr/cpky
    C:\Windows\system32\>slui 3

    2. When you get an error from Windows Activation, close the wizard, wait for some time, and repeat the command sequence in step 1.

    Licensing manager commands

    The commands above do the following:

    • slmgr/upk --- uninstalls currently used product key
    • slmgr/cpky --- performs additional cleanup procedure and removes currently used (or just uninstalled) product key from the system registry
    • slui 3 --- starts Windows Activation wizard that allows you to specify WMC product key and activate Windows 8 PRO with a new key to obtain the Media Center pack.

    Well this is the world we live in And these are the hands we're given...


    Thursday, January 31, 2013 7:40 PM
  • I had the same issue.

    It said that it failed to upgrade to WMC.

    But when the machine restarted it said that my PC had recently been upgraded.

    Then WMC worked.

    Thursday, January 31, 2013 10:48 PM

  • Hi,

    Please also check the log file and see if there is any related error:

    %LocalAppData%\Microsoft\Windows\Windows Anytime Upgrade\Upgrade.log

    Thanks.


    Nicholas Li
    TechNet Community Support

    • Proposed as answer by Exotic Hadron Monday, February 4, 2013 5:07 PM
    Monday, February 4, 2013 8:25 AM
    Moderator
  • I am having the same problem though the commands listed above didn't help.

    Here are the error lines from upgrade.log -

    2014-01-21 18:41:17, Error                 WAU    DoTransmogrify failed due to error 0x800f0805.
    2014-01-21 18:41:17, Error                 WAU    UpgradeSKU failed. Exiting.
    2014-01-21 18:41:17, Error                 WAU    The worker process exited unexpectedly
    2014-01-21 18:41:17, Error                 WAU    Something went wrong
    2014-01-21 18:41:17, Error                 WAU    Close this wizard and try again.

    Tuesday, January 21, 2014 7:45 AM