none
Export not going to SQL Table RRS feed

  • Question

  • Experts,

    I am trying to push data into SQL table.

    I created Outbound Synch rule, MPR, Set and Workflow. I can see ERE in user and record in CS of SQL MA.

    However during export, zero export and no error.

    Not able understand why exporting not going.

    Any suggestions please.

    Thanks,

    Mann

    Thursday, April 17, 2014 6:43 PM

Answers

  • Ok, re-check this:

    You need to make sure the 'create resource in external system' checkbox is checked, and furthermore that there is an 'initial flow' attribute for your anchor.  This thread has a lot of good information (although they are using classic sync rules).

    http://social.technet.microsoft.com/Forums/en-US/1aa13147-e16c-4e99-a7da-76e3c9e8c10d/how-do-we-sync-fim-to-an-external-sql-?forum=ilm2

    David Wind's post about 3/5 of the way down explains the sync rule configuration that should work:

    Sync Rules called 'SQL user outbound'

    • data flow direction: outbound
    • scope: person - SQL MA - person
    • relationship: displayname - displayname
    • Outbound Sync:
    • displayname -> displayname
    • employeeID -> employeeID
    • sn -> surname
    • csObjectID -> dn (initial flow only)

    After that, please invoke full import/synchronization from FIM MA. Then you should see Outbound Synchronization - Provisioning Adds on your SQL agent. If so, please check one of them, go into Lineage->Metaverse Object Properties -> Connectors-> pick FIM MA connector and enter Properties -> Preview -> Generate Full Synch Preview.

    Now check "Connector updates" and find the connector for your SQL agent. Then you would find what is stopping your exports - in my example attributes from SQL have higher precedence so I also have got "applied" without exports, but after changing precedence of attributes it worked fine:


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    • Marked as answer by Mann.Cool Friday, April 18, 2014 8:23 AM
    Friday, April 18, 2014 7:18 AM

All replies

  • Make sure you have Synchronization Rules Provisiong Enabled in Options


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    Thursday, April 17, 2014 7:14 PM
  • Thanks Dominik!

    This option is already enabled. I am able to provision to AD and exchange.

    -Mann

    Friday, April 18, 2014 5:38 AM
  • Ok, second place to check - in Synchronization Rule verify that on "Relationship" tab you have Create resource in external system checked:


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    Friday, April 18, 2014 6:46 AM
  • Yes Dominik, this is also selected.

    More than that ERE status gets applied as well.

    -Mann

    Friday, April 18, 2014 7:03 AM
  • Have you made the initial discovery import on the SQL MA?
    Friday, April 18, 2014 7:17 AM
  • Ok, re-check this:

    You need to make sure the 'create resource in external system' checkbox is checked, and furthermore that there is an 'initial flow' attribute for your anchor.  This thread has a lot of good information (although they are using classic sync rules).

    http://social.technet.microsoft.com/Forums/en-US/1aa13147-e16c-4e99-a7da-76e3c9e8c10d/how-do-we-sync-fim-to-an-external-sql-?forum=ilm2

    David Wind's post about 3/5 of the way down explains the sync rule configuration that should work:

    Sync Rules called 'SQL user outbound'

    • data flow direction: outbound
    • scope: person - SQL MA - person
    • relationship: displayname - displayname
    • Outbound Sync:
    • displayname -> displayname
    • employeeID -> employeeID
    • sn -> surname
    • csObjectID -> dn (initial flow only)

    After that, please invoke full import/synchronization from FIM MA. Then you should see Outbound Synchronization - Provisioning Adds on your SQL agent. If so, please check one of them, go into Lineage->Metaverse Object Properties -> Connectors-> pick FIM MA connector and enter Properties -> Preview -> Generate Full Synch Preview.

    Now check "Connector updates" and find the connector for your SQL agent. Then you would find what is stopping your exports - in my example attributes from SQL have higher precedence so I also have got "applied" without exports, but after changing precedence of attributes it worked fine:


    If you found my post helpful, please give it a Helpful vote. If it answered your question, remember to mark it as an Answer.

    • Marked as answer by Mann.Cool Friday, April 18, 2014 8:23 AM
    Friday, April 18, 2014 7:18 AM
  • Thanks Dominik!

    I will check this.

    Just one thing, I see DN attribute in OSR although my table does not have any such column.

    Do I necessary choose this and select 'initial flow' for this.

    My anchor is employee_id column and I have marked initial for this on employeeid.

    -Mann

    Friday, April 18, 2014 7:24 AM
  • Thanks Dominik!

    I recreated everything and applied checked suggested. Its working currently but I am not sure what worked finally.

    Thanks Again for your help.

    -Mann

    Friday, April 18, 2014 8:27 AM