locked
Protection Disabled on New Document from Template when Comments Allowed RRS feed

  • Question

  • Hi All,

    My search-fu has failed me. Here's the issue:

    I have a great number of documents being built off of a single template. When I set the following editing restrictions shown below (allow commenting and selected passages), start protection and save the template, new documents based on the template do not have document protection turned on. Any assistance or guidance would be great.

    Thanks

    [Image of Protection Settings]

    Tuesday, July 24, 2012 4:04 PM

All replies

  • Hi,

    Just to check whether the steps you add protection to the template is correct.

    Following the steps:

    • Add protection to parts of a template:
      1. Open the template that you want to help protect.
      2. Select the content controls or the group of controls to which you want to restrict changes.
      3. On the Developer tab, in the Controls group, click Properties.
      4. In the Content Control Properties dialog box, under Locking, select either or both the Content control cannot be deleted or Contents cannot be edited check boxes.
      5. Use the Contents cannot be edited option when you want to protect text if it is included. For example, if you often include a disclaimer, you can help ensure that the text stays the same, and you can delete the disclaimer for forms that don't require it.

    Note: The Contents cannot be edited option is not available for all controls.

    • Add protection to all of the content in a template
      1. Open the template that you want to help protect from changes.
      2. Make sure you are not in design mode by clicking Design Mode in the Controls group.
      3. On the Developer tab, in the Protect group, click Protect Document, and then click Restrict Formatting and Editing.
      4. In the Protect Document task pane, under Editing restrictions, select the Allow only this type of editing in the document check box.
      5. In the list of editing restrictions, select the restrictions that you want.
      6. Under Start enforcement, click Yes, Start Enforcing Protection.
      7. To assign a password to the document so that only reviewers who know the password can remove the protection, type a password in the Enter new password (optional) box, and then confirm the password.

    Note: If you choose not to use a password, readers can change your editing restrictions.

    Quote from:

    http://office.microsoft.com/en-us/word-help/add-protection-to-a-template-HA010030757.aspx


    Jaynet Zhang

    TechNet Community Support


    Wednesday, July 25, 2012 7:48 AM
  • Thanks for the inquiry.

    The document does not have any controls which need protection. So, I don't believe the first group of steps is needed. In fact, the "Properties" button is grey-out, and there are no controls to select (which I assume would enable it).

    The second group of steps is exactly the steps we've followed. The issue occurs when I choose "Comments" in the drop down menu below "Allow only this type of editing in the document:" (as shown in the screenshot). I then click "Yes, Start Enforcing Protection", enter a password, save the template and close Word. Next, whether I double click the template or use the File->New dialog to create a file based on the template, the new "Untitled" document is not protected. The protection settings are still part of the file; I can view them by opening the "Restrict Formatting and Editing" pane. Regardless, the document's content is capable of being edited, which is bad.

    As a side note, I have noticed that this random-act-of-unlocking only occurs when the "Allow only this type of editing in the document:" is set to "Comments." The other three options result in the new document, based on the template, maintaining the restricted editing.

    Thanks again. Hopefully, there is a resolution to this.

    • Marked as answer by Jaynet Zhang Friday, July 27, 2012 3:06 AM
    • Unmarked as answer by Jaynet Zhang Friday, July 27, 2012 3:11 AM
    Wednesday, July 25, 2012 6:04 PM
  • check this link this may help you out

    http://office.microsoft.com/en-us/word-help/allow-editing-in-a-protected-document-HP001044747.aspx

    Friday, August 17, 2012 10:23 AM
  • Those are the exact steps I am following. However, I am doing this to a template, and when I open a new document based on the template the protection is turned off.

    I hope I'm explaining this properly.

    Steps to replicate:

    1. Create new document.
    2. Add some content.
    3. Set Editing Restrictions to Comments.
    4. Turn on Protection, and set a password.
    5. Save document as MyTemplate.
    6. Create new document based on MyTemplate.
    7. Observe that Protection is turned off.

    This is not the case with the other Editing Restrictions options.

    Is there a better place to report this? It seems to be a bug, and the responses so far are asking me to repeat steps which I have followed and described.

    Friday, August 17, 2012 2:07 PM