locked
Final steps : Configuring incoming emails RRS feed

  • Question

  • Hi all,
    I'd like to get to work incoming emails.
    I was following the manual and did everything carefully, but still have a problem.
    I have setted up incoming emails in central administration and making contacs in OU works fine too, but
    if I send an email It will returned back with following errors :

        --- The following addresses had delivery problems ---
    email@adress.com (No delivery mechanism available.)

    Original-Recipient: <email@adress.com>
    Action: failed
    Diagnostic-Code: smtp; 442 No delivery mechanism available.
    Remote-MTA: 0.0.0.0

    I'm not able to solve this problem.
    Thanks for any solution

    Thursday, September 18, 2008 1:35 PM

Answers

  •  Hello,
    There are many different ways to configure incoming email on Sharepoint, but I would start at checking your DNS records. Did you created your DNS records? Next would be to verify that your SMTP server is accepting emails.

    You should than be ready to go.

    Please post your results.

    cheers
    Ivan Bondy - MCPD, MCDBA, MCSA, MCTS - Sharepoint consultant
    Thursday, September 18, 2008 2:41 PM
  • Hello,
    You need to configure to connectors on your Exchange server.
    1 to route email to Internet and 1 to route email to your Sharepoint server.
    The Sharepoint connector should specify delivery only for your Sharepoint domain. Internet connector should handle all other email.

    Cheers
    Ivan Bondy - MCPD, MCDBA, MCSA, MCTS - Sharepoint consultant
    Friday, September 19, 2008 1:48 PM

All replies

  •  Hello,
    There are many different ways to configure incoming email on Sharepoint, but I would start at checking your DNS records. Did you created your DNS records? Next would be to verify that your SMTP server is accepting emails.

    You should than be ready to go.

    Please post your results.

    cheers
    Ivan Bondy - MCPD, MCDBA, MCSA, MCTS - Sharepoint consultant
    Thursday, September 18, 2008 2:41 PM
  • Hi,
    I reset everything again, set smtp connector and then it was working.

    But I have a huge problem.
    I have two exchange servers. One exchange is for local domain and the other one is internet mail gate-way.
    The problem is : when I set up the smtp connector for SharePoint server then the local exchange server send all emails only to SharePoint server and not to mail gateway.
    So no email is delivered outside the domain.

    I can't experiment with this because it is running domain.

    I have one question. Could the local exchange server be a sharepoint incoming email server without installing sharepoint on it ?

    Friday, September 19, 2008 11:33 AM
  • Hello,
    You need to configure to connectors on your Exchange server.
    1 to route email to Internet and 1 to route email to your Sharepoint server.
    The Sharepoint connector should specify delivery only for your Sharepoint domain. Internet connector should handle all other email.

    Cheers
    Ivan Bondy - MCPD, MCDBA, MCSA, MCTS - Sharepoint consultant
    Friday, September 19, 2008 1:48 PM
  • Hi,
    You're right, I know that. I setted up it incorrectly and had issue above.

    Monday, September 22, 2008 6:43 AM