locked
WDS not installing when enabled in SCCM 2012 RRS feed

  • Question

  • When enabling the PXE role on a DP for our SCCM 2012 R2 environment the WDS role does not automatically install on the DP. We have been successful on 2 other DP's. Am i missing something obvious? We followed the below steps on the DP

    Prepare Environment and Servers for SCCM Roles (Request assistance from Chris for server builds)

    1. Add  accounts to Local Administrators groups of all SCCM servers*
    2. Add a computer object to the local admin group 

    Common HTTP Features

    • Static Content

    • Default Document

    • Directory Browsing

    • HTTP Errors

    • HTTP Redirection

     

    Application Development

    • ASP.NET

    • .NET Extensibility

    • ASP

    • ISAPI Extensions

    • ISAPI Filters

     

    Health and Diagnostics

    • HTTP logging

    • Logging tools

    • Request Monitor

    • Tracing

     

    Security

    • Basic Authentication

    • Windows Authentication

    • URL Authorization

    • Request Filtering

    • IP and Domain Restrictions

     

    Performance

    • Static Content Compression

     

    Management Tools

    • IIS Management Console

    • IIS Management Scripts and Tools

    • Management Service

    • IIS 6 Management Compatibility

    • IIS 6 Metabase Compatibility

    • IIS 6 WMI Compatibility

    • IIS 6 Scripting Tools

    • IIS 6 Management Console

    Steps are for Server 2008 R2 and may not be necessary with Server 2012

    Thursday, September 4, 2014 5:44 PM

Answers

  • Give this a go

    http://sccmentor.wordpress.com/2014/01/07/wds-not-installing-when-pxe-enabled-on-the-dp/


    Cheers

    Paul | sccmentor.wordpress.com

    • Marked as answer by Daniel JiSun Wednesday, September 10, 2014 8:07 AM
    Thursday, September 4, 2014 8:08 PM
  • You need to specify DHCP options 66 & 67 so that WinPE can locate the boot images. 

    Take a look at the section DHCP Options in Gerry Hampson's blog 

    http://gerryhampsoncm.blogspot.co.uk/2013/02/sccm-2012-sp1-step-by-step-guide-part_9487.html


    Cheers

    Paul | sccmentor.wordpress.com

    • Marked as answer by Daniel JiSun Wednesday, September 10, 2014 8:07 AM
    Friday, September 5, 2014 3:06 PM

All replies

  • The installation of WDS is performed by distmgr so examine distmgr.log

    Torsten Meringer | http://www.mssccmfaq.de

    Thursday, September 4, 2014 6:05 PM
  • It doesn't happen very often but occasionally I've had to install WDS manually (not configure - just verify the correct folder structure) before enabling PXE on a DP.


    Gerry Hampson | Blog: www.gerryhampsoncm.blogspot.ie | LinkedIn: Gerry Hampson | Twitter: @gerryhampson


    Thursday, September 4, 2014 7:41 PM
  • Give this a go

    http://sccmentor.wordpress.com/2014/01/07/wds-not-installing-when-pxe-enabled-on-the-dp/


    Cheers

    Paul | sccmentor.wordpress.com

    • Marked as answer by Daniel JiSun Wednesday, September 10, 2014 8:07 AM
    Thursday, September 4, 2014 8:08 PM
  • Hi,

    Can you see the shared folders on the local drive?

    Get access to SMS_DP$\sms\logs\smsdpprov.log.

    This log may also help us address the issue.

    Friday, September 5, 2014 5:54 AM
  • Here is a bit of the log

    [F9C][Thu 09/04/2014 21:58:17]:Installed PXE
    [F9C][Thu 09/04/2014 21:58:18]:CSMSDPInstProv::EnableDPUsageStatsGathering entered
    [F9C][Thu 09/04/2014 21:58:18]:1998-01-01T00:00:00
    [F9C][Thu 09/04/2014 21:58:19]:A DP usage gathering task has been registered successfully
    [A58][Fri 09/05/2014 01:20:36]:Content 'P010007C.127' for package 'P010007C' has been added to content library successfully
    [A58][Fri 09/05/2014 01:20:36]:Removed older version P010007C.126 of package P010007C from content library
    [A58][Fri 09/05/2014 01:20:36]:RegOpenKeyExW failed for System\CurrentControlSet\Services\WDSSERVER\Providers\WDSTFTP
    [A58][Fri 09/05/2014 01:20:36]:RegReadString failed; 0x80070002
    [A58][Fri 09/05/2014 01:20:36]:GetPXERootFolder failed; 0x80070002
    [A58][Fri 09/05/2014 01:20:36]:GetPXEImagesDirectory failed; 0x80070002
    [CA4][Fri 09/05/2014 01:22:29]:CcmInstallPXE
    [CA4][Fri 09/05/2014 01:22:29]:PXE provider is already installed.
    [CA4][Fri 09/05/2014 01:22:29]:Installed PXE
    [CA4][Fri 09/05/2014 01:22:29]:CSMSDPInstProv::EnableDPUsageStatsGathering entered
    [CA4][Fri 09/05/2014 01:22:30]:1998-01-01T00:00:00
    [CA4][Fri 09/05/2014 01:22:30]:A DP usage gathering task has been registered successfully
    [6CC][Fri 09/05/2014 01:23:30]:Content 'P010007B.127' for package 'P010007B' has been added to content library successfully
    [6CC][Fri 09/05/2014 01:23:30]:Removed older version P010007B.126 of package P010007B from content library
    [6CC][Fri 09/05/2014 01:23:30]:RegOpenKeyExW failed for System\CurrentControlSet\Services\WDSSERVER\Providers\WDSTFTP
    [6CC][Fri 09/05/2014 01:23:30]:RegReadString failed; 0x80070002
    [6CC][Fri 09/05/2014 01:23:30]:GetPXERootFolder failed; 0x80070002
    [6CC][Fri 09/05/2014 01:23:30]:GetPXEImagesDirectory failed; 0x80070002
    [A0][Fri 09/05/2014 07:45:23]:CSMSDPInstProv::EnableDPUsageStatsGathering entered
    [A0][Fri 09/05/2014 07:45:23]:1998-01-01T00:00:00
    [A0][Fri 09/05/2014 07:45:23]:A DP usage gathering task has been registered successfully

    Friday, September 5, 2014 11:12 AM
  • Did you try the fix I suggested?

    Cheers

    Paul | sccmentor.wordpress.com

    Friday, September 5, 2014 11:42 AM
  • Thanks, i did and it kid of work but not completly. I removed WDS unchecked PXE and rebooted. Then checked off PXE and it istalled.

    The problem now is that when they try they get PXE-E53: No boot filename recieved, i see under the smsimage folder the boot images.

    Friday, September 5, 2014 12:56 PM
  • Have you specified the boot file name in your DHCP options?

    Cheers

    Paul | sccmentor.wordpress.com

    Friday, September 5, 2014 2:28 PM
  • Not sure what you are meaning with the above. I ahve had the admin in that location add the IP helper-address
    Friday, September 5, 2014 2:43 PM
  • You need to specify DHCP options 66 & 67 so that WinPE can locate the boot images. 

    Take a look at the section DHCP Options in Gerry Hampson's blog 

    http://gerryhampsoncm.blogspot.co.uk/2013/02/sccm-2012-sp1-step-by-step-guide-part_9487.html


    Cheers

    Paul | sccmentor.wordpress.com

    • Marked as answer by Daniel JiSun Wednesday, September 10, 2014 8:07 AM
    Friday, September 5, 2014 3:06 PM
  • You should really be using IP Helper addresses for PXE and not DHCP Scope Options as they are not recommended by MS. 
    Wednesday, November 2, 2016 7:48 PM