none
Disabling Windows Defender as a Task Sequence RRS feed

  • Question

  • Can this be done via a Task Sequence rather from within an image?
    Monday, June 1, 2015 6:36 AM

All replies

  • Sure, try this:

    Add two run command line steps in your Task Sequence' State Restore step for every service you wish to disable:

    sc config "Name of Service" start= disabled
    sc stop "Name of Service"

    In this case the Name of Service is "WinDefend"

    Cheers! Rens


    If this post is helpful please click "Mark for answer", thanks! Kind regards

    Monday, June 1, 2015 7:27 AM
  • hii,

    you can disable windows defender with the registry key which can be included in SCCM 2007 Task sequence: 

    http://tompopov.blogspot.in/2014/08/disable-windows-defender-using-registry.html

    Or you can this technet blog which will guide you:

    http://blogs.technet.com/b/configmgrteam/archive/2012/04/12/launching-a-windows-defender-offline-scan-with-configuration-manager-2012-osd.aspx

    Regards.


    If you find my contribution useful then please do mark as an answer or vote as helpful.

    Monday, June 1, 2015 7:31 AM
  • Sure, try this:

    Add two run command line steps in your Task Sequence' State Restore step for every service you wish to disable:

    sc config "Name of Service" start= disabled
    sc stop "Name of Service"

    In this case the Name of Service is "WinDefend"

    Cheers! Rens


    If this post is helpful please click "Mark for answer", thanks! Kind regards

    Ok it failed. I tried doing some manual tests within the OS with an elevated command prompt. Windows 8.1

    C:\windows\system32>sc stop "WinDefend"
    [SC] OpenService FAILED 5:

    Access is denied.


    C:\windows\system32>sc config "WinDefend" start= disabled
    [SC] OpenService FAILED 5:

    Access is denied.

    Monday, June 1, 2015 11:53 PM
  • Same problem here. Did you ever find a solution?
    Thursday, July 28, 2016 6:47 PM
  • I believe adding amd64_Security-Malware-Windows-Defender component to your unattend.xml file and then set DisableAntiSPyware to True will accomplish what you are asking.
    Thursday, July 28, 2016 7:45 PM