locked
Custom icon position in Windows 7 Professional stored in roaming Desktop folder (Windows 2003 Standard with a domain)? Icons keep on auto-arranging on the left side after restart even Auto Arrange is not selected. RRS feed

  • General discussion

  • Auto Arrange is unticked but Icons would move back after Refresh s it was on.

    The remote Desktop folder is set to "Read Only" so users can not delete or add icons (it is a student environment) on Windows Server 2003. I set basic redirect and unticked "Grant the user exclusive rights to Desktop" (because it would not work withou it), unticked "Move contents of Desktop to the new location" and "Leave the folder in the new location when policy is removed".
    .
    What I tried:
    .
    1. delprof a profile a create new
    2. tried to replace entries in [HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell \Bags\1\Desktop] with one from a working profile (not with roaming Desktop)
    3. tried to remove HKCU entries and running sfc /scannow
    4. Adding dword [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer] NoSaveSettings=0
    5. installed http://www.howtogeek.com/howto/windows-vista/save-and-restore-desktop-icon-layout-in-windows-vista/
    6. Trying to set Auto-Arrange and restart and set it back
    7. Setting user as Local Administrator
    8. Setting permission on remote Desktop folder to Full for this user

    It is working perfectly on XP workstation and believe or not on a test Windows 7 Ultimate workstation.

    I managed to make it work somohow by using this steps once but was not able to replicate it.

    I noticed that when I selected Auto Arrange settings using right-click nothing changed in registry key "FFlags" (HCKU\\\\Bags\1\Desktop]. I worked in a profile without roaming Desktop.

    Sunday, December 20, 2009 12:14 PM

All replies

  • PROBLEM SOLVED

    The problem was that the remote Desktop folder did not have write permission for the users who use it. However, that was the point. What I did I set Full Share permission and Read Security permission for that group and it started to work. I noticed new file recycle.bin and desktop.ini being created in this folder. Will see how it works if I run more workstations.

    However, I made if work in original scenario after running Live Messenger! But could only replicate it twice and then it stopped working again.

    The odd thing is it worked perfeclty in Windows 7 Ultimate and XP.

    Can anyone explain this behavior?
    Monday, December 21, 2009 2:34 PM